Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-05-03, 10:40 AM   #1
wangsj
Registered User
 
Join Date: May 2003
Posts: 2
Default X fails after install nvidia-1.0-4363 in Redhat9

I installed nvidia-1.0-4363 successfully without any error in my Redhat9 computer. But when I start X using nvidia driver, it FAILs. If I use original nv driver from Redhat distribution, it start normally. Can you tell me if there is any wrong?

Vidio Card: Nvidia TNT2 module 64. And Redhat tells me riva TNT2.
Driver version: 1.0-4363
Distribution: Redhat9
Video BIOS: V2.05.13.03.0309
Processor: AMD Duron 600
Mother board: MicroStar MS6340

XF86config and log is attached below.
Attached Files
File Type: zip xfree86.0.zip (4.5 KB, 136 views)
wangsj is offline   Reply With Quote
Old 05-05-03, 11:50 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
Quote:
Q: My X server fails to start, and my XFree86 log file contains the error:

"(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

A: Nothing will work if the NVIDIA kernel module doesn't function
properly. If you see anything in the X log file like "(EE)
NVIDIA(0): Failed to initialize the NVIDIA kernel module!" then
there is most likely a problem with the NVIDIA kernel module.
First, you should verify that if you installed from rpm that
the rpm was built specifically for the kernel you are using.
You should also check that the module is loaded ('/sbin/lsmod');
if it is not loaded try loading it explicitly with 'insmod' or
'modprobe' (be sure to exit the X server before installing a new
kernel module).
If you receive errors about unresolved symbols,
then the kernel module has most likely been built using header files
for a different kernel revision than what you are running. You can
explicitly control what kernel header files are used when building
the NVIDIA kernel module with the --kernel-include-dir option (see
`sh NVIDIA-Linux-x86-1.0-4363.run --advanced-options`
for details).

Please note that the convention for the location of kernel header
files changed approximately at the time of the 2.4.0 kernel release,
as did the location of kernel modules. If the kernel module fails to
load properly, modprobe/insmod may be trying to load an older kernel
module (assuming you've upgraded). cd'ing into the directory with
the new kernel module and doing 'insmod ./nvidia.o' may help.

Another cause may be that the /dev/nvidia* device files may be missing.

Finally, the NVIDIA kernel module may print error messages indicating
a problem -- to view these messages please check /var/log/messages, or
wherever syslog is directed to place kernel messages. These messages
are prepended with "NVRM".
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 05-06-03, 09:35 PM   #3
wangsj
Registered User
 
Join Date: May 2003
Posts: 2
Default Still fail

I checked my setting. And stiil fails.

I used "sh NVIDIA-Linux-x86-1.0-4363.run" to install nvidia driver. Still no errors and no wanings too. /dev/nvidia* created nomally. I can insmod nvidia normally, with only one GPL waring.
But when I cat /dev/nvidia0, it tells me that "NVRM: init_RAM_failed".

I think is has no relation whith Xserver. The resean may be:
1) linux kernel.
2) Bios setting.


My kernel is the original one dilivered from Redhat9 distribution. And I think many people have succeded in installing this driver for Redhat9. Moreover I install kernel souce RPM package. And no other kernel has been installed or comiled in my computer.

Now I will try to subsitute my redhat9 with other kernels and install nvidia driver. If this works I will accept too.

For Bios settings, can anyone tell me how to set them?
wangsj is offline   Reply With Quote
Old 05-07-03, 07:29 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

PnP Aware OS (or whatever your BIOS calls it) should be off.

Assign IRQ to VGA should be on.

That's about all I know of, BIOS-wise.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM

All times are GMT -5. The time now is 11:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.