Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-12-08, 12:55 PM   #25
__entropy__
Registered User
 
Join Date: Oct 2006
Posts: 17
Default Re: [173.08]2D is very slow

173.08 is a complete letdown for me.
Using a 6600GT (AGP) and KDE 3.5.9 accelerated subpixel hinting seems not to be available
anymore. Console performance is _very_ sluggish and reminds me of the time back in 2005/2006
before acceleration had been introduced to those cards.

Following the long list of threads complaining about horrible 2D perfomance for GF 8XXX+ cards,
my personal workaround _was_ just sticking to my GF6.
If it turns out that Kernel 2.6.25(+) forces me to use drivers that don't come with feasible AA font acceleration
- who knows which support will be dropped additionally for those "soon to be announced legacy cards -
I'll definitely switch to your competitors products.
The Ati chip (9600m) in my notebook provides a much better work experience with the OSS X.Org driver anyway.

Of course, a driver can not perform better than its engineering team.
But still, I appreciate your efforts...

Cheers
__entropy__ is offline   Reply With Quote
Old 04-12-08, 02:37 PM   #26
JackieBrown
Registered User
 
Join Date: Dec 2004
Posts: 47
Default Re: [173.08]2D is very slow

I don't believe the people that say that KDE 4 is unusable (in general - not due to drivers) have really given it a chance.
JackieBrown is offline   Reply With Quote
Old 04-12-08, 02:59 PM   #27
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Default Re: [173.08]2D is very slow

I can confirm this bug, it's not related to compiz or kde4, I do not use that stuff.

2d with 173.08 is unusable, it's not just slow, it's VERY slow.

System Debian Sid 32 bit with kde 3.5.9 desktop.

I'll post a full bug report output file later, but I had to roll back to 171.06 because the desktop was basically running at about 1/10th 2d speed, window painting is visible, scrolling virtual terminal konsole is jerky. FYI, 171.06 is completely normal, no problems at all, which should make it easier to track down the issue.

Oddly, glxgears shows roughly the same framerate for 3d, so maybe the thread title is correct to pinpoint this to a 2d specific bug.

I see this I think more than many users because I use 2x 1280x1024 dual monitors. But it's absolutely unmistakable.

I'll post full output when I reinstall the 173.08, but I wanted to just confirm the bug report, and I'm glad to see that I'm not the only one seeing it.

For now, here's the bug report using 171.06 in case it provides any useful information:
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (36.4 KB, 132 views)
gfxdrone is offline   Reply With Quote
Old 04-12-08, 03:18 PM   #28
pawels133
Registered User
 
pawels133's Avatar
 
Join Date: Mar 2008
Posts: 201
Default Re: [173.08]2D is very slow

@__entropy__

Can you paste your xorg.conf please? I have Geforce 6800 and it seems that 2D performance is not better than on 8xxx series. Maybe little tuning will help.
__________________
Not everybody can smoke and drink... xd
pawels133 is offline   Reply With Quote
Old 04-12-08, 03:19 PM   #29
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Default Re: [173.08]2D is very slow

and here's the bug report from 173.08

As I type, everything is slow on the desktop, on every level, even to keystrokes appearing in this text box, to dmesg output appearing in console, to scrolling windows.

I would say 1/10th speed is about right, give or take a bit. Clearly a non-trivial bug.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (36.4 KB, 133 views)
gfxdrone is offline   Reply With Quote
Old 04-12-08, 03:44 PM   #30
__entropy__
Registered User
 
Join Date: Oct 2006
Posts: 17
Default Re: [173.08]2D is very slow

Quote:
Originally Posted by pawels133
@__entropy__

Can you paste your xorg.conf please? I have Geforce 6800 and it seems that 2D performance is not better than on 8xxx series. Maybe little tuning will help.
I wouldn't consider my xorg.conf very tuned, nothing special in it.
Here you go. xorg.conf.gz

Btw, in my opinion the usual bug report on those 2D issues is wasted
time since the nvidia devs are certainly aware of these "bugs".
Those are missing or dropped (basic) features - not bugs.

Cheers
__entropy__ is offline   Reply With Quote
Old 04-12-08, 09:58 PM   #31
drzoo2
Registered User
 
Join Date: Dec 2005
Posts: 24
Default Re: [173.08]2D is very slow

I can confirm the Beta driver does slow my 2D considerably. Scrolling is unbearable. I can see slowdowns in the GLXgears screen saver that aren't their with the released driver. Switching back make a world of difference. That being said Kudos to the driver team for fixing the UT2004 graphics bug. The sky textures look nice now.....no more bars. Now if you can fix the wicked, wicked shuttering, we'd have a playable game on my 8800GT.

z
drzoo2 is offline   Reply With Quote
Old 04-14-08, 08:57 AM   #32
pawels133
Registered User
 
pawels133's Avatar
 
Join Date: Mar 2008
Posts: 201
Default Re: [173.08]2D is very slow

@__entropy__

Thank you. I've tried your xorg.conf, but it didn't help. Now, I know that only good drivers will help, but there aren't good drivers for my card right now.
__________________
Not everybody can smoke and drink... xd
pawels133 is offline   Reply With Quote

Old 04-14-08, 06:41 PM   #33
tec-buck
Registered User
 
Join Date: Mar 2007
Posts: 17
Default Re: [173.08]2D is very slow

Quote:
Originally Posted by gonzo.init
what U all doing..?

Nvidia has been the number one choice for Linux users since... since... forever! and Ive been using it since 2001 (Linux/nvidia), never have I resorted to the excuse *blame it on nvidia* because once one look at the other options... nuthin'

I think it's a user- or hardware problem... I've used nVIDIA and Linux for years and never had any of your problems, fact is that I build computers and install Linux for customers that feel like testing something better...

Ohh, You are using beta software..? Like compiz..? Well, then you have to understand that alpha/beta software isn't for everybody... and above all not for you...

this is a good tip for many people out there...

Section "Extensions"
Option "Composite" "Disable"
EndSection
Cheers Gonzo.init!
These drivers work great for me! I will say this though, they don't always work right out of the box, it will typically take me two or three changes to my xorg.conf file and a reboot before I'm satisfied. I'm using the 17* driver (8800Gt sli), just switched this weekend, and have experinced no sugnificate problems. The only change I noticed was improved functionallity with with HL2:E2. Nvidia and Linux are a great combination.

And to provide a little support for the topic at hand, I have also found that the composite exention has a significat effect on performace, inparticualr when compiz is installed. This might be a good thing to look at.
tec-buck is offline   Reply With Quote
Old 04-15-08, 01:43 AM   #34
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [173.08]2D is very slow

Quote:
Originally Posted by tec-buck
And to provide a little support for the topic at hand, I have also found that the composite exention has a significat effect on performace, inparticualr when compiz is installed. This might be a good thing to look at.
Unable to confirm this statement here on 7600GT, 2d performance is still choppy even without composite extension.
kriko is offline   Reply With Quote
Old 04-15-08, 02:05 AM   #35
bebar
Registered User
 
Join Date: Apr 2008
Posts: 1
Default Re: [173.08]2D is very slow

I confirm this bug. I'am unable to use openoffice, firefox, thunderbird or evolution. Scrolling is too slow.

8600m gt
bebar is offline   Reply With Quote
Old 04-15-08, 07:35 AM   #36
bearoso
Registered User
 
Join Date: Sep 2003
Posts: 57
Default Re: [173.08]2D is very slow

I can confirm this as well. At first I wasn't sure it was there, but, for example, websites with static elements have significantly slower redraw with 173.08 contrasting with 171.06. I don't use any compositors, so that's irrelevant.
bearoso is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 173.14.35: Fedora 17 x86 terribly slow Mr Wolf NVIDIA Linux 25 07-02-12 01:44 AM
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM
Slow XP startup after upgrade.... Ramshambo2001 Microsoft Windows XP And Vista 10 10-10-02 01:35 AM

All times are GMT -5. The time now is 08:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.