Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-11-08, 06:41 AM   #73
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [173.08]2D is very slow

So there really is a problem with nvidia and 2d. Can't wait to get my hands on old dusty radeon - if it will perform better, then this is the last geforce I bought (till they fix this).
Why pay so much for a graphic card that performs not quite well in environment you use most of computing time?
kriko is offline   Reply With Quote
Old 06-11-08, 08:24 AM   #74
tbyte
Registered User
 
tbyte's Avatar
 
Join Date: Apr 2003
Location: Europe, Bulgaria
Posts: 28
Cool Re: [173.08]2D is very slow

Big part of the problem is that nvidia driver is unable to set automatically this 'InitialPixmapPlacement' (whatever that means) to right value for the current system. It makes a HUGE difference setting that right for your system. At home on 8800 right value was 0 if I'm not mistaken, here at work on 6200 it is 2 and on my colleague's 6200 it is 0. And nvidia's setting is ALWAYS 1. So the driver just don't know what to set and they just hard set it to 1. So if You want to experiment try this 'nvidia-settings -a InitialPixmapPlacement=0 to 4' and running gtkperf after each setting to check if speed changes. Mine went from 60 sec total to 7 sec !!! (that of course depend much on the theme and fastest one is 'ThinIce'). And of course it SHOULD NOT BE USER'S problem to test which setting is best for their system and that default setting to be 90% slower than best making the whole system worthless ...
tbyte is offline   Reply With Quote
Old 06-11-08, 08:33 AM   #75
burli
Registered User
 
Join Date: Jan 2004
Posts: 13
Default Re: [173.08]2D is very slow

Quote:
Originally Posted by ollebull View Post
I have actually used the same program (Eagle) and I recognize your problem. With all of the nvidia cards I have used Eagle is redrawing painfully slow (under Linux, but real fast under Windows). I though that had something to do with the program it self, a bad Linux port. But if you have got good performance with a Intel card under Linux I guess it is the nvidia driver that is the problem again?

AaronP or any nvidia expert do you know why is it such a big difference between Windows and Linux performance? 2D drawing sounds like quite basic functionality. Of course I'm not an expert in the subject so I don't know. But I would be interested in some explanation of what makes it so hard under Linux though.
I solved the Eagle Problem. Bevore you start Eagle you shoud enter

export XLIB_SKIP_ARGB_VISUALS=1

or you can use a script to start Eagle

Code:
  #!/bin/sh
 export XLIB_SKIP_ARGB_VISUALS=1 
 /usr/bin/eagle
I dont know why, but it works
burli is offline   Reply With Quote
Old 06-11-08, 08:44 AM   #76
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [173.08]2D is very slow

Here I get best performance with InitialPixmapPlacement=0.
What does this means - I think it was explained somewhere.

EDIT: Here is explanation, so I'm using sysmem for pixmaps
http://cgit.freedesktop.org/~aplattn...dc589855#n2797
kriko is offline   Reply With Quote
Old 06-11-08, 08:56 AM   #77
burli
Registered User
 
Join Date: Jan 2004
Posts: 13
Default Re: [173.08]2D is very slow

Quote:
Originally Posted by tbyte View Post
Big part of the problem is that nvidia driver is unable to set automatically this 'InitialPixmapPlacement' (whatever that means) to right value for the current system. It makes a HUGE difference setting that right for your system. At home on 8800 right value was 0 if I'm not mistaken, here at work on 6200 it is 2 and on my colleague's 6200 it is 0. And nvidia's setting is ALWAYS 1. So the driver just don't know what to set and they just hard set it to 1. So if You want to experiment try this 'nvidia-settings -a InitialPixmapPlacement=0 to 4' and running gtkperf after each setting to check if speed changes. Mine went from 60 sec total to 7 sec !!! (that of course depend much on the theme and fastest one is 'ThinIce'). And of course it SHOULD NOT BE USER'S problem to test which setting is best for their system and that default setting to be 90% slower than best making the whole system worthless ...
Great stuff. But there's no big different between 0 to 3 (8.3 to 10 seconds). Only 4 will be slow with 20 seconds. For me 0 is fine
burli is offline   Reply With Quote
Old 06-11-08, 09:09 AM   #78
ollebull
Registered User
 
Join Date: Jun 2004
Posts: 17
Default Re: [173.08]2D is very slow

burli that solved the eagle problem, thanks!
I have too tested the diffrent settings with "initialPixmap...". And as burli, the 0-3 is no big difference (~8 seconds with ThinIce theme), and the 4 slows down alot.
ollebull is offline   Reply With Quote
Old 06-11-08, 04:33 PM   #79
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [173.08]2D is very slow

There is also a good performance boost when I'm using nvidia internal agp driver instead of amd64agp. Gtkperf took 4 sec to complete 30 rounds, before it took 8.
kriko is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 173.14.35: Fedora 17 x86 terribly slow Mr Wolf NVIDIA Linux 25 07-02-12 01:44 AM
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM
Slow XP startup after upgrade.... Ramshambo2001 Microsoft Windows XP And Vista 10 10-10-02 01:35 AM

All times are GMT -5. The time now is 03:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.