Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-04-03, 07:39 AM   #1
kodge
Registered User
 
Join Date: Feb 2003
Posts: 2
Default Bad FPS on 4200ti ?

Hi

I have a GeForce 4 4200TI card 4x AGP. I run Linux 2.4.21rc1 (Slackware 8.1) with the latest NVidia 4363 drivers, X-4.2. I have an Athlon XP 2000 with a VIA KT400 motherboard.

When I first tested the card (on a different system), the default glxgears produced FPS of 9000 or more. I even had the occasional 11000 FPS. These were with older NVidia drivers, and the system in question is perhaps half as powerful as the system i'm currently using.

When I put the card on my current system, with the KT400 Mobo, my FPS dropped to around 7000. For some reason, after playing Unreal Tournament 2003 yesterday, and updating to the latest NV drivers. the framerate on glxgears is now between 3500FPS and 4500FPS. I've tried switching to older drivers (all the way back to 3123) but nothing seems to help.

I doubt this behaviour is normal. Can someone suggest a reason for this? (i've checked that i'm using the proper NV GL libraries etc etc). Are there any options i can provide to the kernel module to improve performace perhaps? or some XF86Config option i'm missing?

Also, could someone pls provide me with sample framerates for this card when running glxgears. I simply run "glxgears" for my tests, i do not resize the default window in any way. I run X at 1024x768 (no twinview/xinerama setup).

Thanks

kodge
kodge is offline   Reply With Quote
Old 05-04-03, 07:07 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Is AGP enabled?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 05-05-03, 01:24 PM   #3
kodge
Registered User
 
Join Date: Feb 2003
Posts: 2
Default RE: Bad FPS on 4200ti?

yep, AGP's enabled. and i'm using 2.4.20rc1 which has support for the kt400 AGP. I'm not using nvidia's AGP driver since the kt400 isnt listed as officially supported (yet?)

I switched my machine on 2day and my glxgears is running at almost 7000FPS (6800 or so on average). Still, it's a far cry from the 10000 to 11000FPS i used to get at times (even clocked a little over 19000 the one time. but just the once). I'm guessing it *might* be an AGP driver problem, so i've compiled AGP as a module.

Still, i'd like some specs on the FPS others are getting. I play unreal 2003 and there are noticeable jerks at times. Someone I know with a 1ghz machine and a el-cheapo GF4 MX has the game running quite smoothly (on windows), so I expect linux to perform similarly.

thanks

kodge
kodge is offline   Reply With Quote
Old 05-05-03, 05:24 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: RE: Bad FPS on 4200ti?

Quote:
Originally posted by kodge
I'm not using nvidia's AGP driver since the kt400 isnt listed as officially supported (yet?)
That "list" is horrifically out of date. It is supported -- until kernel 2.4.21-rc1 (or whichever -pre kernel added the KT400 driver), using the internal AGP driver -- "NvAGP" "1" -- was the only way to get it to work.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 05-05-03, 05:42 PM   #5
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Quote:
yep, AGP's enabled. and i'm using 2.4.20rc1 which has support for the kt400 AGP. I'm not using nvidia's AGP driver since the kt400 isnt listed as officially supported (yet?)
It is - the README just has a stale chipset list. Can you try the NVAGP?

Quote:
Someone I know with a 1ghz machine and a el-cheapo GF4 MX has the game running quite smoothly (on windows), so I expect linux to perform similarly.
Is he using the OGL renderer? If not, you won't be able to compare framerates, as Linux is limited to the OGL renderer.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best Games Of 7 Day FPS.. That Don't Have Any Shooting News Gaming Headlines 0 06-19-12 06:30 AM
302.17 = FPS drops in Quake Live Lamieur NVIDIA Linux 0 06-18-12 01:13 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
low fps why??? nipster Benchmarking And Overclocking 4 08-07-02 02:35 PM

All times are GMT -5. The time now is 03:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.