Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-30-03, 06:55 PM   #1
wasima
Registered User
 
Join Date: Apr 2003
Posts: 5
Default TV-Out and 50Hz

Hello,
I have a GEForce 4MX card and have installed the 1.0-4363 drivers. I can finally start using AGP which is great! However I still have this little problem with TV-Out.

As I'm in the UK we have a 50Hz TV system, but it seems as though I'm only allowed to specify a 60Hz TV in the configuration. I believe this is why, when watching dvds with a lot of action, often the bottom half of the screen lags the top half by a frame - very unsettling!

I haven't found anything through google on this matter that I can use (nvtv does not seem to like the card very much). Any help would be much appreciated.

BTW, here's the device section from my XF86Config-4:

Section "Device"
Identifier "NVidia GE-Force 4MX"
Driver "nvidia"
Option "NvAGP" "1"
Option "UseEdidFreqs" "true"
Option "CursorShadow" "true"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
# Option "TwinViewOrientation" "Clone"
Option "ConnectedMonitor" "CRT, TV"
Option "TVStandard" "PAL-I"
# Option "TVOutFormat" "Composite"
Option "TVOutFormat" "SVIDEO"
Option "MetaModes" "1600x1200,800x600; 1280x1024,800x600; 1024x768,800x600; 800x600,800x600; 640x480,640x480"
EndSection

Thanks,

Wasim.
wasima is offline   Reply With Quote
Old 04-30-03, 07:20 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

What happens when you specify 50Hz as the refresh? Can you provide a verbose X log?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 05-01-03, 01:06 PM   #3
wasima
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

That was a quick reply! I've attached the log as produced when I change 60 to 50. In simplest terms, "it don't work"!

Thanks,

Wasim.
Attached Files
File Type: log xfree86.0.log (34.2 KB, 149 views)
wasima is offline   Reply With Quote
Old 05-01-03, 01:38 PM   #4
alien999999999
Registered User
 
alien999999999's Avatar
 
Join Date: Apr 2003
Location: Belgium
Posts: 218
Send a message via ICQ to alien999999999
Default

maybe try to add a valid modeline for you TV.

use 'gtf 800 600 50' & 'gtf 640 480 50' i think that's the command name, not sure about that, it seems to me that that would most likely help your situation

Alien
alien999999999 is offline   Reply With Quote
Old 05-01-03, 02:34 PM   #5
kow
Registered User
 
Join Date: Apr 2003
Posts: 20
Default

If he does a modeline, he'll probably have to tag on "Interlace" on the end (I think PAL is interlaced, right?).

There are a couple issues with this, though. Only some of the Nvidia chipset-based cards support that interlace option (the list was specified in one of the old driver readmes, maybe 4191 otherwise earlier). The second issue is that the interlace mode support in the drivers has been broken.

I would suggest trying Andy's thing again, but using the ignore EDID option in your config file(you'll have to reference the readme for the specific line). I'm no pro though, so don't put some weird setting in and blow up your screens.
kow is offline   Reply With Quote
Old 05-01-03, 04:00 PM   #6
wasima
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

I've tried using IgnoreEDID - still no luck :-(

I'm editing the XF86Config-4 file to use 2 different displays (app-r in the readme) - I'll report if it works or not. It's not the most fascinating file to edit!

Thanks,

Wasim.
wasima is offline   Reply With Quote
Old 05-01-03, 06:13 PM   #7
wasima
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

Still no luck :-(

With the Config attached the log file tells me:

(II) NVIDIA(1): Not using mode "800x600@50" (bad mode clock/interlace/doublescan)

BTW I have a GeForce4 MX 440SE

and then goes ahead and uses 1024x768@60Hz (I thought 800x600 was the maximum for TV-Out)

Setting the refresh rate to 50Hz does not even get me into X.

Any ideas, or do I accept defeat graciously? It seems that with the new AGP8x, or due to some other change, there appears to be a little less of that split screen momentary glitch, but it's still there.

Thanks,

Wasim.
Attached Files
File Type: txt xf86config-4.txt (6.3 KB, 145 views)
wasima is offline   Reply With Quote
Old 05-02-03, 10:04 AM   #8
kow
Registered User
 
Join Date: Apr 2003
Posts: 20
Default

Where's the log for your original config file? I guess I didn't pay enough attention to your original post, but now that I look at it I don't know if I buy into your theory about the card popping out a 60hz interlaced signal when you specified the pal-i standard. If it was doing that, I'd expect you'd be getting wacky video all of the time and not just when movie action gets intense.
kow is offline   Reply With Quote

Old 05-02-03, 02:00 PM   #9
alien999999999
Registered User
 
alien999999999's Avatar
 
Join Date: Apr 2003
Location: Belgium
Posts: 218
Send a message via ICQ to alien999999999
Default

Quote:
Originally posted by wasima
Still no luck :-(

With the Config attached the log file tells me:

(II) NVIDIA(1): Not using mode "800x600@50" (bad mode clock/interlace/doublescan)

BTW I have a GeForce4 MX 440SE

and then goes ahead and uses 1024x768@60Hz (I thought 800x600 was the maximum for TV-Out)

Setting the refresh rate to 50Hz does not even get me into X.

Any ideas, or do I accept defeat graciously? It seems that with the new AGP8x, or due to some other change, there appears to be a little less of that split screen momentary glitch, but it's still there.

Thanks,

Wasim.

Idon't know if it is me, but you have way too much devices, monitors, ...

you want TV as a only display right?

use:

connectedMonitor "null, TV"
twinview
twinview orientation "clone"

secondmonitorvertrefresh 50-60 !this should help alot
secondmonitorhoriz 30-70


and do get different XFconfig files...

try not to get everythin in one file....
just copy the one you need over the XFConfig-4

good luck
alien999999999 is offline   Reply With Quote
Old 05-02-03, 05:11 PM   #10
wasima
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

I've attached the log file that I get with the original config, but with VertRefresh 50-60. It seems to say that it's running the TV at 60Hz. Incidentally there is some flicker under normal circumstances that makes reading almost impossible, but general film scenes are watchable. It's really when there is action that there are problems. The same scenes on the monitor (either when using clone or separately) appear perfectly fine - so it shouldn't be a processing speed issue.

I've only got a monitor and a tv. I'm really trying to get both working together. I'll try out the suggestion with one display at a time to see if it helps. Though it's not really what I wanted, I guess I can exit X between watching films and doing work. It's a hard choice which version to run :-)

Wasim.
Attached Files
File Type: log xfree86.0.log (37.9 KB, 120 views)
wasima is offline   Reply With Quote
Old 05-04-03, 07:12 PM   #11
ollelgn
Registered User
 
Join Date: Mar 2003
Posts: 4
Default

Try adding the following line to your Monitor Section:

# PAL 50
ModeLine "800x600x50" 33.1584 800 840 968 1056 600 601 605 628

And to your device or screen-section:
Option "SecondMonitorVertRefresh" "50-85"
Option "MetaModes" "1280x1024,800x600x50; 1024x768,800x600x50; 800x600, 80
0x600x50"

Works fine for me with PAL-B, the xfree logs tells me that valid modes for TV are 800x600 in 50 Hz
ollelgn is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.