Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-06-08, 02:30 PM   #1
sjoerd
Registered User
 
Join Date: Dec 2006
Posts: 9
Default GLX won't initialize

I see the message
Quote:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.
in my Xorg.0.log file, and indeed, there is no GLX in my X server. The X server does start, and it does use the nvidia driver.

All relevant details are in the attached bug report, but a quick summary here:
Fedora 8, fully up-to-date, but running kernel-2.6.24.4-64.fc8.x86_64 on a Dell Inspiron 1720 (Intel Core 2 Duo) in 64 bit mode with a GeForce 8600M GT card. nVidia driver from freshrpms (version nvidia-x11-drv-169.12-1.fc8.x86_64).

I did reinstall as the message suggests.

It did work before (at least googleearth used to work), but that may well have been with another (older) kernel that I don't have installed anymore.

Does anybody have any suggestions as what could be the problem?
Attached Files
File Type: gz nvidia-bug-report.log.gz (25.2 KB, 178 views)
sjoerd is offline   Reply With Quote
Old 05-06-08, 03:54 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GLX won't initialize

Try adding

Load "glx"

to the "Module" section of /etc/X11/xorg.conf.
AaronP is offline   Reply With Quote
Old 05-06-08, 04:37 PM   #3
sjoerd
Registered User
 
Join Date: Dec 2006
Posts: 9
Default Re: GLX won't initialize

I can't currently try (I can't restart X since my system is busy doing stuff), but this suggestion makes a lot of sense.

I recently added the Modules section to include the synaptics driver. So when there was no Modules section, the glx module was apparently loaded automatically, but with a Modules section you have to be explicit?

In any case, if this is indeed the problem, the error message could be clearer...

I'll report back whether or not this actually works.
sjoerd is offline   Reply With Quote
Old 05-06-08, 04:49 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GLX won't initialize

The default module loading behavior has changed a lot recently so it's hard to keep track, but I believe the behavior you describe is correct for your version of the X server. You'll also want to load "extmod" or you'll be missing a bunch of extensions like XVideo and SHAPE.
AaronP is offline   Reply With Quote
Old 05-06-08, 04:52 PM   #5
sjoerd
Registered User
 
Join Date: Dec 2006
Posts: 9
Default Re: GLX won't initialize

Thanks for the help.

Your suggestion does indeed work.

I'll add extmod as well, but I haven't missed it yet.
sjoerd is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 02:24 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GLX bug? (1.0-3123) marc NVIDIA Linux 2 09-21-02 05:58 PM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 01:41 PM
Remote Accelerated GLX and Raster Display Oddity dzzero NVIDIA Linux 2 09-18-02 02:59 PM

All times are GMT -5. The time now is 09:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.