Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-08, 10:23 AM   #1
SamZ
Registered User
 
Join Date: May 2008
Posts: 6
Default Problem running fullscreen with "Rotate" "CCW"

Hi.
I am trying to run a custom app in fullscreen mode on FreeBSD. It works great with the latest drivers, but now I want to run the monitor in vertical (portrait) mode.

I am using SDL just to set up the fullscreen mode, and then OpenGL after that.

When I use Option "Rotate" CCW in xorg.conf, X comes up as it should. Running the app in a window works as it should, and everything is in portrait mode.

However, when I switch to fullscreen mode, the screen is offset several hundred pixels to the right. For a 1440x900 monitor, if I run rotated at 900x1440, it works, but it is as if the screen is centered in a 1440x1440 virtual window, and I lost the right half of my app.

Any suggestions?

Thanks
Sam
SamZ is offline   Reply With Quote
Old 05-15-08, 10:24 AM   #2
SamZ
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: Problem running fullscreen with "Rotate" "CCW"

This turned out to be a bug in the SDL code - at least I was able to fix it by not centering the window from SDL.

s
SamZ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.