Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-26-08, 04:31 AM   #13
Žom
Registered User
 
Join Date: May 2008
Posts: 22
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by bearoso
Honestly, if you need help patching the source, you probably won't want to mess with it. I have no clue how Ubuntu manages its compiz package and a manual installation is liable to screw things up.
OK, I will be reasonable, and wait for (I hope) a checkbox "always glXSwapBuffers()" in ccsm in a future version of compiz...


For the moment, I enabled nvidia open gl sync to vblank + xvideo sync to vblank (the only way to avoid video vsync problem for me), and disabled compiz sync to vblank (else the video is not smooth).

The problem is for moving windows, where vsync problems occur, which can be avoided for the moment only with enabling compiz sync to vblank and disabling nvidia sync to vlank... but in that case I have to switch on/off this option every time I watch a movie...
Žom is offline   Reply With Quote
Old 05-31-08, 01:21 PM   #14
Žom
Registered User
 
Join Date: May 2008
Posts: 22
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by Žom
For the moment, I enabled nvidia open gl sync to vblank + xvideo sync to vblank (the only way to avoid video vsync problem for me)
And it doesn't always work...
Žom is offline   Reply With Quote
Old 06-09-08, 08:40 AM   #15
Žom
Registered User
 
Join Date: May 2008
Posts: 22
Default Re: Sync to VBlank : doesn't work correctly

Does anyone have a solution to make vertical synchronisation work?

At least for watching videos...?
Žom is offline   Reply With Quote
Old 07-27-08, 12:04 PM   #16
mipa
Registered User
 
Join Date: Jan 2007
Posts: 9
Default Re: Sync to VBlank : doesn't work correctly

I have found that the rendering problems are related to XVideo. Only way to see solid frames in desktop and in video is to use OpenGL-rendering for both desktop and video. I use Gnome with Compiz-Fusion (OpenGL) and Xine with OpenGL video driver output.

NOTE At first it is good to remember that the NVIDIA X Server Settings must be enabled every time you start your desktop and BEFORE starting Compiz. Otherwise those settings not apply. I have done it with a starting script which is enabled in the Gnome Sessions Manager.

Code:
#!/bin/bash

# LOAD NVIDIA SETTINGS
sleep 6
nvidia-settings -l

# START COMPIZ
sleep 6
compiz-manager --loose-binding
For Compiz 0.7.6 and Fusion

Code:
#!/bin/bash

# LOAD NVIDIA SETTINGS
sleep 6
nvidia-settings -l

# START COMPIZ
sleep 6
compiz --replace ccp &
sleep 1
emerald --replace &
It is important to enable 1) Sync to VBlank for OpenGL and 2) Allow Flipping from NVIDIA Settings -> OpenGL Settings.

And to disable 3) Sync to VBlank from Compiz Settings Manager -> Display Settings. Also must enable 4) Detect Refresh Rate from Compiz Settings Manager -> Display Settings.

Most important thing is to 5) check that your system is using correct refresh rate. You can see the current refresh rate using command xrandr. Example for me it must be 60Hz which is my LCD-panel's refresh rate. 6) ENABLE Undirect Fullscreen Windows from CompizConfig Settings Manager -> General Options

So i recommend to use OpenGL for everything. For some reason XVideo Sync to VBlank never works CORRECTLY (with Compiz or without Compiz) even it is enabled in NVIDIA Settings -> X Server XVideo Settings. I have those XVideo sync options (Texture Adaptor and Blitter Adaptor) still enabled but i think they have not any effect to OpenGL-applications.

My comp specs: Core2Duo and GeForce 7950 GT.

I have kernel option pci=nommconf. And Compiz-Manager is started with option --loose-binding.

Last edited by mipa; 08-20-08 at 11:20 AM. Reason: Compiz 0.7.6
mipa is offline   Reply With Quote
Old 07-27-08, 01:03 PM   #17
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by mipa View Post
I have found that the rendering problems are related to XVideo. Only way to see solid frames in desktop and in video is to use OpenGL-rendering for both desktop and video. I use Gnome with Compiz-Fusion (OpenGL) and Xine with OpenGL video driver output.

It is important to enable 1) Sync to VBlank for OpenGL and 2) Allow Flipping from NVIDIA Settings -> OpenGL Settings.

And to disable 3) Sync to VBlank from Compiz Settings Manager -> Display Settings. Also must enable 4) Detect Refresh Rate from Compiz Settings Manager -> Display Settings.

Most important thing is to 5) check that your system is using correct refresh rate. You can see the current refresh rate using command xrandr. Example for me it must be 60Hz which is my LCD-panel's refresh rate.

So i recommend to use OpenGL for everything. For some reason XVideo Sync to VBlank never works CORRECTLY (with Compiz or without Compiz) even it is enabled in NVIDIA Settings -> X Server XVideo Settings. I have those XVideo sync options (Texture Adaptor and Blitter Adaptor) still enabled but i think they have not any effect to OpenGL-applications.

My comp specs: Core2Duo and GeForce 7950 GT.

I have kernel options pci=nommconf and maxcpus=1 (Because my comp gets hard-locking without it). And Compiz-Manager is started with option --loose-binding.
I believe it is stated somewhere in the driver docs that xvideo does not sync to vblank if there is a opengl compositor enabled (nor do ogl apps for that matter hence setting ogl Output will have no effect). Another thing that I have noticed is that with twinview enabled X thinks my screen has a refresh of 50Hz Disabling twinview fixes that problem (but then gives me hassle when I want use an external monitor).
txf is offline   Reply With Quote
Old 07-27-08, 05:47 PM   #18
ballmersmallmer
Registered User
 
Join Date: Jul 2008
Posts: 3
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by txf View Post
-- Another thing that I have noticed is that with twinview enabled X thinks my screen has a refresh of 50Hz Disabling twinview fixes that problem (but then gives me hassle when I want use an external monitor).
Hi there,

Maybe this helps:

To get the right refresh rate readout with Twinview you should add the following line to your xorg.conf:

Code:
Section "Device"
        Identifier      "Videocard0"
        Driver          "nvidia"
---
---
        Option          "DynamicTwinView"               "True"
---
---
EndSection
Don't know about possible side effects when using DynamcTwinView though...

Cheers
ballmersmallmer is offline   Reply With Quote
Old 07-27-08, 06:08 PM   #19
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by ballmersmallmer View Post
Hi there,

Maybe this helps:

To get the right refresh rate readout with Twinview you should add the following line to your xorg.conf:

Code:
Section "Device"
        Identifier      "Videocard0"
        Driver          "nvidia"
---
---
        Option          "DynamicTwinView"               "True"
---
---
EndSection
Don't know about possible side effects when using DynamcTwinView though...

Cheers
no its already enabled by default ... he should disable it.
the side effects are you can no longer enable/disable displays without restarting X.
Dragoran is offline   Reply With Quote
Old 07-27-08, 08:32 PM   #20
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by Dragoran View Post
no its already enabled by default ... he should disable it.
the side effects are you can no longer enable/disable displays without restarting X.
I wonder if nvidia is waiting for randr 1.3 before fixing twinview (cos it seriously sucks atm)
txf is offline   Reply With Quote

Old 07-30-08, 04:15 PM   #21
mipa
Registered User
 
Join Date: Jan 2007
Posts: 9
Default Re: Sync to VBlank : doesn't work correctly

I have updated my previous post containing some useful tips. There was one important note missing.
mipa is offline   Reply With Quote
Old 08-20-08, 11:29 AM   #22
mipa
Registered User
 
Join Date: Jan 2007
Posts: 9
Default Re: Sync to VBlank : doesn't work correctly

I have found that after updating my mobo's bios threre is no more freezing problems when i use 2 cores of my cpu.

I also updated again my previous post were are useful tips if you are using Compiz and have problems with it.
mipa is offline   Reply With Quote
Old 12-20-08, 07:48 PM   #23
miltiad
Registered User
 
Join Date: Jun 2006
Posts: 26
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by txf View Post
I wonder if nvidia is waiting for randr 1.3 before fixing twinview (cos it seriously sucks atm)
They said it's their top priority to support randr 1.2 (not 1.3 thought)
miltiad is offline   Reply With Quote
Old 12-21-08, 10:59 AM   #24
miltiad
Registered User
 
Join Date: Jun 2006
Posts: 26
Default Re: Sync to VBlank : doesn't work correctly

Quote:
Originally Posted by mipa View Post
I have found that the rendering problems are related to XVideo. Only way to see solid frames in desktop and in video is to use OpenGL-rendering for both desktop and video. I use Gnome with Compiz-Fusion (OpenGL) and Xine with OpenGL video driver output.

NOTE At first it is good to remember that the NVIDIA X Server Settings must be enabled every time you start your desktop and BEFORE starting Compiz. Otherwise those settings not apply. I have done it with a starting script which is enabled in the Gnome Sessions Manager.

Code:
#!/bin/bash

# LOAD NVIDIA SETTINGS
sleep 6
nvidia-settings -l

# START COMPIZ
sleep 6
compiz-manager --loose-binding
For Compiz 0.7.6 and Fusion

Code:
#!/bin/bash

# LOAD NVIDIA SETTINGS
sleep 6
nvidia-settings -l

# START COMPIZ
sleep 6
compiz --replace ccp &
sleep 1
emerald --replace &
It is important to enable 1) Sync to VBlank for OpenGL and 2) Allow Flipping from NVIDIA Settings -> OpenGL Settings.

And to disable 3) Sync to VBlank from Compiz Settings Manager -> Display Settings. Also must enable 4) Detect Refresh Rate from Compiz Settings Manager -> Display Settings.

Most important thing is to 5) check that your system is using correct refresh rate. You can see the current refresh rate using command xrandr. Example for me it must be 60Hz which is my LCD-panel's refresh rate. 6) ENABLE Undirect Fullscreen Windows from CompizConfig Settings Manager -> General Options

So i recommend to use OpenGL for everything. For some reason XVideo Sync to VBlank never works CORRECTLY (with Compiz or without Compiz) even it is enabled in NVIDIA Settings -> X Server XVideo Settings. I have those XVideo sync options (Texture Adaptor and Blitter Adaptor) still enabled but i think they have not any effect to OpenGL-applications.

My comp specs: Core2Duo and GeForce 7950 GT.

I have kernel option pci=nommconf. And Compiz-Manager is started with option --loose-binding.
I have tried your solution but it doesn't seem to work for me. I have found another workaroung that works on my configuration:
I have a 1280x1024 LCD screen and a 1920x1080 plasma.

Using the lastest beta Nvidia driver (180.11). I use the settings as seen in the screenshot attach to this comment.

With compiz enabled in full-screen or not I have tearing on both display with totem.

The only way to stop the tearing I have found is:
- Disable Compiz
- ALT+F2 nvidia-settings -l (to load the nvidia settings)

And I can watch video without tearing on my plasma and my LCD.
Attached Thumbnails
Click image for larger version

Name:	Capture-NVIDIA X Server Settings.png
Views:	435
Size:	74.4 KB
ID:	34551  
miltiad is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiseat X with two cards: used to work, now segfaulting Artefact2 NVIDIA Linux 10 06-26-12 06:22 PM
Sync it up: Hands on with the preview of Windows 8's cloud sync service News Archived News Items 0 06-02-12 09:30 PM
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 03:38 PM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 04:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Š1998 - 2014, nV News.