Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-03-08, 10:21 PM   #25
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

And just to annoy you all Ubuntu released 2.6.24-18 at some point in the last day or so

Although you chose to use the nvidia drivers, Ubuntu ships the previous stable version, for this and other reasons you might need to rebuild this package as well

apt-get source linux-restricted-modules-2.6.24-18-rt

Although now I think about it, you really only need to rebuild the kernel and the other packages from repositories should in theory be ok, will try and find out I guess since the above command tries to pull 151M of files
evilbunny is offline   Reply With Quote
Old 06-03-08, 10:52 PM   #26
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

The nvidia drivers Ubuntu ships 169.12 works just fine, I haven't test the nv driver.

All I needed to do was rebuild the kernel after patching, the modules didn't need to be rebuilt and the ones from the repositories work just fine and dandy.

Thanks to the 2 posters above for pointing this fix out, I'm now a much happier camper
evilbunny is offline   Reply With Quote
Old 06-05-08, 02:43 PM   #27
Fourmiii
Registered User
 
Join Date: May 2008
Posts: 4
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Indeed, the kernel guys release -18 the same day I posted the fix above.. oh great !!

In the meantime, I figured out how to properly build only the debs I need (the -rt ones). Only problem is the update manager always wants to install the debs from the repo since they have the same version and it thinks my debs aren't good enough

Here's the new way of doing it, note the editing of amd64.mk to only build the rt flavour.
Code:
# Install Kernel Sources
sudo apt-get build-dep linux-image-2.6.24-18-rt
sudo apt-get source linux-image-2.6.24-18-rt

# Install Kernel Modules Sources
sudo apt-get build-dep linux-ubuntu-modules-2.6.24-18-rt
sudo apt-get source linux-ubuntu-modules-2.6.24-18-rt

# Apply NVRM patch
sudo patch -p0 < NVRM_512M_fix.diff

# Build debs for linux-image & linux-headers
cd linux-2.6.24/
# Modify flavours in debian/rules.d/amd64.mk (rt instead of generic)
sudo CONCURRENCY_LEVEL=2 fakeroot debian/rules custom-binary-rt
cd ..

# Build 
cd linux-ubuntu-modules-2.6.24-2.6.24/
# Modify flavours in debian/rules.d/amd64.mk (rt instead of generic)
sudo CONCURRENCY_LEVEL=2 fakeroot debian/rules binary-debs
cd ..
Fourmiii is offline   Reply With Quote
Old 06-05-08, 08:40 PM   #28
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Quote:
Originally Posted by Fourmiii View Post
Indeed, the kernel guys release -18 the same day I posted the fix above.. oh great !!
I'm positive they did that just to mess with you

Quote:
In the meantime, I figured out how to properly build only the debs I need (the -rt ones). Only problem is the update manager always wants to install the debs from the repo since they have the same version and it thinks my debs aren't good enough
I followed your instructions from before, but only did the kernel, not the modules and everything worked fine, it didn't try to replace my kernel with one from the repositories. I didn't rebuild the modules, they worked fine as is.
evilbunny is offline   Reply With Quote
Old 06-17-08, 11:22 PM   #29
mcurran
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I have a G1Sn-B1 and I'm having the same issue. My problem is that I'm using Linux Mint 5 (Elyssa) and I cannot just copy and paste these instructions When I get to the patch command, it asks which file to patch, so I tell it, and it says the file does not exist. So I tried downloading the source and modules deb packages and patching those, but it says that the patching process failed at 122 or something. Does anyone have any suggestions for me? Sorry, I'm a linux noob and I don't understand why I can't just go gedit a simple file instead of all this patching. Is it because my directories do not match? I ran into this same problem when trying to patch my old wifi card for injection: The Ubuntu patch didn't work on Mint, even though their based on the same kernel or whatever. Oh yeah, my Elyssa is currently using 2.6.24-16, so I might need to patch that instead. Someone please help!!!!

If I cd into my Desktop and then type sudo apt-get source linux-image-2.6.24-16-rt and it successfully downloads, shouldn't the file then be available on my Desktop - In other words, it should not be asking me which file to patch after typing "sudo patch -p0 <NVRM_512M_fix.txt" right?.. WTF!
mcurran is offline   Reply With Quote
Old 06-21-08, 04:10 AM   #30
evilbunny
Registered User
 
Join Date: May 2008
Posts: 16
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

2.6.24-19 is out, it seems to patch cleanly as well.

I'm not sure if it's gdebi or ucf or something else, but once I build and install the kernel package as per the instructions above I can download the rest of the packages just fine from online repositories without needing to rebuild them all.
evilbunny is offline   Reply With Quote
Old 07-01-08, 08:20 PM   #31
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

This is why I love the linux community. I didn't know what I was doing but I followed the instructions, and with a little guess work my Asus G1sn-A1 is at 1680X1050 while using 4GB RAM. booya.
add2700 is offline   Reply With Quote
Old 07-04-08, 08:04 PM   #32
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I have the ASUS G1sn-A1 laptop with 4GB RAM and the nvidia 9500m GS video card. I first was running ubuntu 8.04 32 bit and I got the kernel patch fix to work once, and I booted up in 1680 res. Then like an idiot I tried to run the envy nvidia installer to see if I could enable compiz and broke the fix.
I've since reloaded ubuntu 8.04 64bit and tried to patch the kernel 3-4 times, and it just won't work. Installing the nvidia drivers manually errors out, and installing with envyng acts like it works, but upon reboot i get the message that the laptop is operating in limited graphics mode.
Attached is the nvidia error log.
Here is uname -a:
Linux bendr2007 2.6.24-19-rt #1 SMP PREEMPT RT Thu Jul 3 22:17:03 MDT 2008 x86_64 GNU/Linux

I guess I really need more detailed steps on running the patch from scratch. Much appreciated. I am a windows wiz so if anyone has any windows XP questions shoot me a message.
Attached Files
File Type: log nvidia-bug-report.log (137.3 KB, 188 views)
add2700 is offline   Reply With Quote

Old 07-05-08, 12:35 AM   #33
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

UPDATE: I dowloaded Kernelcheck and updated my kernel to 2.6.25.10 ultimate, but still no 1680 on bootup. Then I downloaded the headers for that kernel. Then I rebooted again and voila! 1680! but I cannot enable desktop effects.

Is this how I have to run until there's a better nvidia driver or kernel released? Or more likely, I'm doing it wrong?

EDIT-im doing it wrong. I must be just running with the old, slow vesa driver? Going to try to install NVIDIA usung envy
add2700 is offline   Reply With Quote
Old 07-05-08, 03:21 PM   #34
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

last night i completed all the requested instructions to properly install the nvidia 173 driver, and it failed. please see attached.

FYI- I'm using the 2.6.25.10-ultimate 64bit kernel. PLZ tell me if I'm doing it wrong.
Attached Files
File Type: log nvidia-installer.log (34.4 KB, 180 views)
add2700 is offline   Reply With Quote
Old 07-06-08, 03:27 PM   #35
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Ok ran the kernel patch again on a fresh 8.04 32 bit install. The only thing I did different that I can see is rename the patch file from .txt to .diff, but the point is I now have beautiful 1680 res with the nvidia driver and compiz enabled woot.
add2700 is offline   Reply With Quote
Old 07-15-08, 03:20 PM   #36
mcurran
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

google that error - The patch probably worked - It's the driver your having a problem with. Patch the kernel and modules, make debs, install them, reboot, and then start installing the driver manually by following the instructions you find, or use EnvyNG. Also, if you already installed the driver, just open xorg.conf and replace "vesa" with "nvidia" and you should be good to go - That's what I did, because I configured the vesa driver after the nvidia driver didn't work (before the patch).
mcurran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT650M not recognized by 295.59 Driver on Ubuntu 12.04 hvontres NVIDIA Linux 13 06-22-12 02:33 PM
Powermizer problem, nvidia 9500m gs ubuntu backtoback NVIDIA Linux 3 05-25-12 01:13 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 06:32 PM

All times are GMT -5. The time now is 06:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.