Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-15-08, 06:27 PM   #37
les_caesars
Registered User
 
Join Date: Jul 2008
Posts: 1
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

For those of you who are using the ASUS G1SN-B1 and maybe are a little too scared to patch the kernel on your own, here are the DEB files for the patched kernel that worked for me. By the time you read this, the kernel is probably going to be a few versions old, but probably not enough to "break" any programs you're using. This should at the very least let you use compiz and your fancy graphics again. I would guess that this also works with the G1SN-A1, but I don't know that. In any case, use at your own risk.

TO INSTALL:

http://www.zshare.net/download/153885282a8f1547/
(the file is about 20 MB, so it's too big to attach)

Download and extract the .zip, open up the terminal, cd to the directory where the extracted .deb files can be found and type:


Code:
sudo dpkg -i linux-headers-2.6.24-19-rt_2.6.24-19.34_amd64.deb linux-headers-lum-2.6.24-19-rt_2.6.24-19.28_amd64.deb linux-image-2.6.24-19-rt_2.6.24-19.34_amd64.deb linux-ubuntu-modules-2.6.24-19-rt_2.6.24-19.28_amd64.deb
Then, restart the computer. If you're stuck in the terminal, you can restart by typing the command:

Code:
sudo shutdown -r now
les_caesars is offline   Reply With Quote
Old 07-17-08, 08:00 PM   #38
mcurran
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

add2700 or anyone with a G1Sn: Do you have a good resolution set for GRUB and usplash? I have been trying forever to get 1680x1050 res for usplash, and I have gotten close by editing usplash.conf; however, there are black margins (picture does not stretch to fit), and the screen flashes as if the framebuffer is not as good as it can be. For some reason the live CD's detect the highest capable res. but unfortunately my installation doesn't. Have you got a decent GRUB, or usplash? If so, please let me know how you accomplished it.

Fourmiii: Maybe you could let me know how to load a decent framebuffer module that supports my native 1680x1050 before x is started (during boot). I would like to apply any patches now; if necessary, since I'm redoing my system again...

Sorry for not starting a new thread, but it would be cool to kill two display bugs with one stone here.
mcurran is offline   Reply With Quote
Old 07-22-08, 11:09 PM   #39
mcurran
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

I figured out how to correct my usplash by appending "vga=0x0369" to each kernel line in my /boot/grub/menu.lst file (Gets me 1680x1050). I also had to add fbcon and vesafb to my framebuffer modules /etc/initramfs-tools/modules, unblacklist vesafb in /etc/modprobe.d/blacklist-frambuffer, and then update-initramfs and reboot. I still can't get my grub to conform... Any help would be much appreciated.
mcurran is offline   Reply With Quote
Old 09-11-08, 09:27 AM   #40
slowcar
Registered User
 
Join Date: Sep 2008
Posts: 1
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Quote:
Originally Posted by evilbunny View Post
I can confirm 100% it's not just Ubuntu or the 2.6.24 kernel for that matter.

Code:
# cat /proc/version 
Linux version 2.6.25.3-18.fc9.x86_64 (mockbuild@) (gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) ) #1 SMP Tue May 13 04:54:47 EDT 2008
After installing from the Fedora 9 CD it insisted on doing an update, including a kernel update I let this go through then installed the kernel-devel package etc, however the error message is more or less identical:

Code:
warning: process `nvidia-installe' used the deprecated sysctl system call with 1.23.
warning: process `nvidia-installe' used the deprecated sysctl system call with 1.23.
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
NVRM: BAR1 is 256M @ 0x00000000 (PCI:0001:00.0)
NVRM: This is a 64-bit BAR mapped above 4GB by the system BIOS or
NVRM: Linux kernel. The NVIDIA Linux graphics driver and other
NVRM: system software do not currently support this configuration
NVRM: reliably.
nvidia: probe of 0000:01:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!
warning: process `nvidia-installe' used the deprecated sysctl system call with 1.23.
ACPI: PCI interrupt for device 0000:03:00.0 disabled
At which point the nvidia installer halts, I didn't try this with only 2G of ram as I figured it would work just fine, although the nv driver works, so those having trouble with it might want to try doing what I'm about to and upgrade to the next Ubuntu version to get a newer nv/kernel etc versions if available.
Quote:
Originally Posted by add2700 View Post
last night i completed all the requested instructions to properly install the nvidia 173 driver, and it failed. please see attached.

FYI- I'm using the 2.6.25.10-ultimate 64bit kernel. PLZ tell me if I'm doing it wrong.
I had the same problem (64-bit BAR mapped above 4GB by the system BIOS) on a Intel ServerBoard SE7525RP2 (EM64T) running Fedora CORE4 x86_64 with kernel 2.6.12 . I updated the BIOS to the most recent version. Everything works fine now. I can compile and load the NVIDIA driver (V173.14.12 x84_64).

Also check in your BIOS if there's an option to force the remapping of the 64-bit BAR below 4GB. Some BIOS may have this option. Mine doesn't have this option but the update resolved the problem.
slowcar is offline   Reply With Quote
Old 09-14-08, 06:23 AM   #41
eTiMaGo
Registered User
 
Join Date: Jul 2006
Posts: 8
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Quote:
Originally Posted by les_caesars View Post
For those of you who are using the ASUS G1SN-B1 and maybe are a little too scared to patch the kernel on your own, here are the DEB files for the patched kernel that worked for me. By the time you read this, the kernel is probably going to be a few versions old, but probably not enough to "break" any programs you're using. This should at the very least let you use compiz and your fancy graphics again. I would guess that this also works with the G1SN-A1, but I don't know that. In any case, use at your own risk.

TO INSTALL:

http://www.zshare.net/download/153885282a8f1547/
(the file is about 20 MB, so it's too big to attach)

Download and extract the .zip, open up the terminal, cd to the directory where the extracted .deb files can be found and type:


Code:
sudo dpkg -i linux-headers-2.6.24-19-rt_2.6.24-19.34_amd64.deb linux-headers-lum-2.6.24-19-rt_2.6.24-19.28_amd64.deb linux-image-2.6.24-19-rt_2.6.24-19.34_amd64.deb linux-ubuntu-modules-2.6.24-19-rt_2.6.24-19.28_amd64.deb
Then, restart the computer. If you're stuck in the terminal, you can restart by typing the command:

Code:
sudo shutdown -r now
Thanks, this worked like a charm for me, followed by installing the drivers through EnvyNG. I have an Acer 6920 with 4GB RAM and a 9500M GS (and a sexy 1920x1080 screen) and it works great!

A question, though, Ubuntu keeps on asking me to update to the latest kernel and headers (24-19rt) but will this break the fix?
eTiMaGo is offline   Reply With Quote
Old 09-18-08, 12:17 PM   #42
shurymury
Registered User
 
Join Date: Sep 2008
Posts: 1
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Sorry if this would sound stupid ..

What else should I do beside recompiling the kernel?

Should I install NVidia drivers? Where from?

It was not a good idea to switch to Mac ... after a few years, I feel really dumb - I do not remember a thing.

Shura.
shurymury is offline   Reply With Quote
Old 10-23-08, 08:46 AM   #43
skreo56
Registered User
 
Join Date: Oct 2008
Posts: 1
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Hi,

I have an Asus W7Sg with a GeForce 9300M G, whith 3 (1+2) MB of RAM and I've experienced the same problems.

I've tried Unbuntu Hardy updated to Beta Intrepid and Mandriva 2009. the problem was still on whether I actually used a 32 bits OS or a 64 bits one.

So I ve tried to remove the RAM extension of 2MB, living only 1MB available. BINGO
As usual the driver compilation via the nvidia script generated the nvidia.ko but this time it loaded in memory perfectly well, as well as all the rest of the accelerating components did.

So now I've restored the 3 MB and then it just started to crash X again. I had to put back xorg.conf using the vesa driver to get at least the stupid but ever so rescuing frame buffer working.

I'm not gonna copy here the famous NVRM lines produced by the kernel when you intend to load the nvidia driver, every one here concerned by this topic has already seen them hundreeds of time and knows them almost by heart now.


I saw that there were BIOS 305, 306 and 307, to replace the actual and original 304 that I have. And as far as I could see, two of them, 306 and 307 have been especially released for nvidia matters.

What do you suggest me first: Updating the Bios or Applying the kernel patch to recompile everything?

Thanks
skreo56 is offline   Reply With Quote
Old 11-25-08, 02:13 PM   #44
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

GOOD NEWS! Ubuntu 8.10 64 bit with kernel 2.6.27 runs this setup fine with beautiful 1680X1050 resolution.
add2700 is offline   Reply With Quote

Old 11-27-08, 02:16 PM   #45
Mothra13
Registered User
 
Join Date: Nov 2008
Posts: 2
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Hello, I have a Asus G1sn-B1 and i was so thankful to find this thread, I'm only having one problem, the link that les_caesars posted does not work any more and I cant seem to get it to download. If anyone could mirror it that would be great!
Mothra13 is offline   Reply With Quote
Old 11-27-08, 04:39 PM   #46
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

The poin t is you dont have to patch your kernel now. Just upgrade to Ubuntu 8.10, or 2.6.27 kernel.
add2700 is offline   Reply With Quote
Old 11-27-08, 10:38 PM   #47
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Sorry, I spoke too soon. I have 1680 res but not with the NVIDIA driver. this sucks. Going to go back and try to recompile AGAIN.
add2700 is offline   Reply With Quote
Old 11-28-08, 11:49 AM   #48
add2700
Registered User
 
Join Date: Jul 2008
Posts: 9
Default Re: Unable to install Nvidia driver on 9500M + Ubuntu

Follow the steps here, which are updated and taken from this post:
http://backports.ubuntuforums.com/sh...8&postcount=37

It's really easy if you just take it one step at a time. It takes about 1.5 hours to run and compile everything, so just surf reddit while it's running.

Then follow the steps at here to install the NVIDIA driver:
http://www.albertomilone.com/nvidia_scripts1.html

This does work, just takes some patience. Follow each step one at a time and you can't miss.
add2700 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT650M not recognized by 295.59 Driver on Ubuntu 12.04 hvontres NVIDIA Linux 13 06-22-12 01:33 PM
Powermizer problem, nvidia 9500m gs ubuntu backtoback NVIDIA Linux 3 05-25-12 12:13 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM

All times are GMT -5. The time now is 12:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.