Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-14-03, 06:39 PM   #13
Eljefe62
Registered User
 
Join Date: May 2003
Location: Houston TX
Posts: 10
Default

still no luck
didn't put in the option "dpms", but i don't think that's the problem i've got no idea where to go from here, any other suggestions?
Eljefe62 is offline   Reply With Quote
Old 05-14-03, 07:53 PM   #14
Gyokuran
Registered User
 
Join Date: May 2003
Posts: 30
Default

post the current error from the logs.
Gyokuran is offline   Reply With Quote
Old 05-15-03, 01:06 AM   #15
leibold
Registered User
 
Join Date: May 2003
Posts: 66
Default

Quote:
Originally posted by Eljefe62
any other suggestions?
Well, it seems that you have the nvidia module compiled, but not loaded.
As root try modprobe nvidia. What (if any) response do you get ?
After the modprobe command do a dmesg. It may output a lot, but only the last few lines are of interest (pay attention to anything with "agp", "gart", "nvidia" or "NVRM" in it).
Another diagnostic command is lsmod | grep nvidia to see if it got loaded ok.
leibold is offline   Reply With Quote
Old 05-15-03, 01:37 AM   #16
Eljefe62
Registered User
 
Join Date: May 2003
Location: Houston TX
Posts: 10
Default /var/log/XFree86.0.log.old

Here's XF86 log
Attached Files
File Type: log xfree86.0.log (27.6 KB, 133 views)
Eljefe62 is offline   Reply With Quote
Old 05-15-03, 01:39 AM   #17
Eljefe62
Registered User
 
Join Date: May 2003
Location: Houston TX
Posts: 10
Default

the nvidia module is getting loaded (and i've also tried manually loading it)
dmesg | grep produces none of the things you suggested, leibold
Eljefe62 is offline   Reply With Quote
Old 05-15-03, 01:41 AM   #18
Eljefe62
Registered User
 
Join Date: May 2003
Location: Houston TX
Posts: 10
Default

now i can get the x server up and running (with blank screen, of course) and i can hear kde come up, but trying to ctrl-alt-bkspace doesn't work like it should, ie it is back to the command line but doesn't release the screen, it's still blank
now at least i can ctrl-alt-del it instead of using reset button
Eljefe62 is offline   Reply With Quote
Old 05-15-03, 02:15 AM   #19
tuxit
Registered User
 
Join Date: May 2003
Posts: 2
Default

In your XF86Config file, find the driver section for nvidia. Add a line

Option "NvAGP" "0"

as per the Nvidia readme, and try again. If that works then the problem is AGP related.
tuxit is offline   Reply With Quote
Old 05-15-03, 02:52 AM   #20
krtek
Registered User
 
Join Date: Apr 2003
Location: Vienna, Austria
Posts: 6
Default

i had the same problem with suse 8.2 and a geforce4 mmx440. after installing the 4349 drivers, the screens turned black. i tried several suggestions, including the option to turn agp off. nothing worked until 4363 was released. i did not change anything except unistalling the new drivers, and now i got X and 3D acceleration working fine IF i load Suse in failsafe mode! does anyone know why this works in failsafe, but not with the normal kernel? where is the difference?

thx a lot!
krtek is offline   Reply With Quote

Old 05-15-03, 04:13 AM   #21
goshoo
Registered User
 
Join Date: May 2003
Location: Sofia, Bulgaria
Posts: 1
Post

Hi all,
I am using Suse from a few days (before i was redhat user) with GeForce 4 MX 440 with Nvidia TV-OUT chip.
I successfuly installed nvidia driver (1.0-4363) with original Suse 8.2 kernel.
chanching current runlevel to 3.
running nvidia installer.
running SaX2 and change device to use nvidia driver (not nv) and chage colors and resolution.

When i add (in Section device)
Optin "TwinView" "on"
Optin "Orientation" "Clone"
Option "MetaMode" "1024x768, 1024x768; 800x600, 800x600 ; 640x480, 640x480"
Option "TVStandard" "PAL-B"
Option "ConnetcedMonitor" "CRT, TV"
Option "SecondMonitorHorizSync" "50" // I'm not sure for this value but works on Redhat 8 & 9
Option "SecondMonitorVertRefresh" "60" // I'm not sure for this value but works on Redhat 8 & 9

XServer tell me that is not available modes for TV-0

Driver NVidia 1.0-4363 is sertified for Suse 8.2 and i wish to see configuration files from tests on Suse 8.2
goshoo is offline   Reply With Quote
Old 05-15-03, 04:46 AM   #22
leibold
Registered User
 
Join Date: May 2003
Posts: 66
Default

krtek, the main difference is that apci gets disabled in failsafe mode (a few other things as well, but apci=off seems to solve a number of issues).

goshoo, it sounds like your X server is complaining because none of the modelines in the XF86Config file match the specified resolutions and the vertical&horizontal refresh rates. If you still have the modelines you used with Redhat you should be able to simply add them to the XF86Config file in SuSE.
leibold is offline   Reply With Quote
Old 05-16-03, 10:25 AM   #23
Eljefe62
Registered User
 
Join Date: May 2003
Location: Houston TX
Posts: 10
Default

PROBLEM FIXED!!!!
I had another monitor attached to the dvi-port on the card, unattached it, ran sax2 and everything worked beautifully!
Thanks for all the suggestions, guys!
Eljefe62 is offline   Reply With Quote
Old 05-17-03, 10:43 AM   #24
spurious
Registered User
 
Join Date: May 2003
Posts: 5
Default

sax2 is a problem if you are running over 1280x1024. On my desktop machine the highest resolution it will work at is 1400x1050. On my notebook it gets me to 1600x1200 virtual desktop but the machine is really running at 800x600 ( yes, it has a 1600x1200 display ). If you have a working XF86Config, make sure you save it somewhere safe before upgrading your driver.
spurious is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 01:54 AM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 09:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 10:31 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 12:19 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 11:48 AM

All times are GMT -5. The time now is 03:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.