Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-20-08, 02:10 AM   #1
bgreen
Registered User
 
Join Date: Apr 2004
Posts: 1
Default GeForce 9800 GX2 and TwinView

Hello,

Is it possible to use TwinView with the GeForce 9800 GX2?

It is not working for me, but it may be a hardware problem.
I do not have the MultiGPU or SLI options enabled.
The XServer log does not report a problem with enabling TwinView, but it instead reports that only one display was found.

I have two displays connected to the card, though the status light for the second DVI connector is yellow rather than green. The TwinView-enabled xorg.conf configuration I am using works fine when a GeForce 8800 is plugged in.

My nvidia-bug-report.log is attached.
Attached Files
File Type: log nvidia-bug-report.log (138.3 KB, 143 views)
bgreen is offline   Reply With Quote
Old 06-24-08, 04:39 AM   #2
holashh
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: GeForce 9800 GX2 and TwinView

Hi, I have the same problem, but I use nvidia-xconfig "--enable-all-gpus --twinview --sli-Off --multigpu=Off" and I have 2 monitors output, but if I start aplication which I need to run, it`s not like twinview, but desktop has this behavior.

Please some advice . It`s drive me crazy
holashh is offline   Reply With Quote
Old 06-24-08, 09:39 AM   #3
holashh
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: GeForce 9800 GX2 and TwinView

Quote:
Originally Posted by holashh View Post
Hi, I have the same problem, but I use nvidia-xconfig "--enable-all-gpus --twinview --sli-Off --multigpu=Off" and I have 2 monitors output, but if I start aplication which I need to run, it`s not like twinview, but desktop has this behavior.

Please some advice . It`s drive me crazy
Hi I SOLVED it, it was big battle, but i won.
My xorg.conf is bellow, it`s working for me
Attached Files
File Type: txt xorg.conf.txt (3.1 KB, 438 views)
holashh is offline   Reply With Quote
Old 06-24-08, 09:41 AM   #4
holashh
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: GeForce 9800 GX2 and TwinView

Quote:
Originally Posted by holashh View Post
Hi, I have the same problem, but I use nvidia-xconfig "--enable-all-gpus --twinview --sli-Off --multigpu=Off" and I have 2 monitors output, but if I start aplication which I need to run, it`s not like twinview, but desktop has this behavior.

Please some advice . It`s drive me crazy
Hi I SOLVED it, it was big battle, but i won.
My xorg.conf is bellow, it`s working for me

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon May 19 00:33:37 PDT 2008

Section "ServerLayout"
Identifier "Default Layout"
# Identifier "Multihead layout"
Screen 0 "Screen0"
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "glx"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
Option "Xinerama" "on
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9800 GX2"
BusID "PCI:3:0:0"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9800 GX2"
BusID "PCI:4:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
# Option "TwinView" "True"
# Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
Option "MultiGPU" "Off"
Option "SLI" "Off"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
# Option "TwinView" "True"
# Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
Option "MultiGPU" "Off"
Option "SLI" "Off"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
holashh is offline   Reply With Quote
Old 04-30-09, 11:21 PM   #5
ubuntu-addict
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: GeForce 9800 GX2 and TwinView

this xorg.conf doesn't give me twinview :s
It's like if I use nvidia-settings and use "xinerama" in Separate X screen. So... still no twinview!
ubuntu-addict is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.