Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-22-08, 12:10 PM   #1
farvardin
Registered User
 
Join Date: Jun 2007
Posts: 21
Default screen 1 pixel high (at 1280x1024 only)

Hello,

I couldn't run the latest nvidia driver with the latest debian kernel, due to a bug in the debian kernel (they put some unnecessary xen things into it). Thanks to this post, I managed to get it work on the computer at my job:
http://blog.creonfx.com/linux/how-to...ernel-with-xen

But now at home (2.6.25-2-686) I have a problem, for running it (NVIDIA-Linux-x86-173.14.09-pkg1.run)

At 1280x1024 (the native resolution of my screen), I get only a screen with 1 pixel high, at the top. The rest is blank. It seems to respond anyway, and correspond to the bottom of the desktop (I can highlight some parts with my mouse). At 1024x768 or 1280x960, it's working correctly.

If I remove my xorg.conf, the screen works at 640x480 only. If I use my old xorg.conf (see attachment...) which was working for every previous nvidia driver, I can't get the 1280x1024 (screen 1 pixel high), and if I remove the xorg.conf and generate a new one with the nvidia installer, it's the same. Starting with 1024x768 and trying to use nvidia-setting for increasing the screen resolution is not better (1 px high).

I have another odd problem too, I get a "out of range 80.8 khz / 65 hz" with my screen (LG L1919S) when the resolution is 800x600. I must force the refresh to 66 hz for making it work.
I put in the xorg.conf the vendor's definitions ( HorizSync 30-83 / VertRefresh 56-75) but with or without it it's the same.

note : with the "nv" driver and the same xorg.conf, I can run 1280x1024 without any problem...
Attached Files
File Type: gz farvardin_nvidia-bug-report.log.tar.gz (31.9 KB, 188 views)
farvardin is offline   Reply With Quote
Old 06-22-08, 12:53 PM   #2
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: screen 1 pixel high (at 1280x1024 only)

You could try adding this:
Option "ModeValidation" "NoXServerModes"
pe1chl is offline   Reply With Quote
Old 06-23-08, 06:50 AM   #3
farvardin
Registered User
 
Join Date: Jun 2007
Posts: 21
Default Re: screen 1 pixel high (at 1280x1024 only)

I've tried this, but it doesn't work for me (I get only a resolution of 480x640 if I remember well)
farvardin is offline   Reply With Quote
Old 06-23-08, 12:19 PM   #4
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: screen 1 pixel high (at 1280x1024 only)

(--) NVIDIA(0): Connected display device(s) on GeForce 6100 at PCI:0:5:0:
(--) NVIDIA(0): LG L1919S (CRT-0)
(--) NVIDIA(0): LG L1919S (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1024x768"
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768

The driver thinks your screen is 1024x768.
Remove the HorizSync and VertRefresh lines from the config.
When that does not help, make the bugreport as indicated in the sticky post.
(including the logverbose option)
pe1chl is offline   Reply With Quote
Old 06-23-08, 01:59 PM   #5
farvardin
Registered User
 
Join Date: Jun 2007
Posts: 21
Default Re: screen 1 pixel high (at 1280x1024 only)

hello,

thank you for your advices. I've uploaded a new bug report file. I've disabled the composite extensions too (it was not working either without them)
Attached Files
File Type: gz farvardin_nvidia-bug-report23062008.log.tar.gz (35.8 KB, 166 views)
farvardin is offline   Reply With Quote
Old 06-23-08, 02:40 PM   #6
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: screen 1 pixel high (at 1280x1024 only)

Now the logfile says the mode 1280x1024 has been accepted.
I would not know why it still does not work...
You could try using 1280x1024_75 to force 75 Hz (which your monitor seems to prefer)
Or again try the Option "ModeValidation" "NoXServerModes" to get rid of all those guessed modes that maybe don't work.
pe1chl is offline   Reply With Quote
Old 06-23-08, 03:34 PM   #7
farvardin
Registered User
 
Join Date: Jun 2007
Posts: 21
Default Re: screen 1 pixel high (at 1280x1024 only)

1280x1024_75 was not working either.

I had to switch back to the latest working version of the nvidia driver:
NVIDIA-Linux-x86-169.12-pkg1.run

This one could run with a 2.6.25 kernel if I used a patch found on this forum.
I post as attachment this version of the bug report, if it can be of any use to the dev. team.

all the other versions of this driver are giving the same screen error, with the 1 pixel row only display : NVIDIA-Linux-x86-173.08-pkg1.run NVIDIA-Linux-x86-173.14.05-pkg1.run NVIDIA-Linux-x86-173.14.09-pkg1.run

Thank you for the support pe1chl !
Attached Files
File Type: gz farvardin_169-12-working-nvidia-bug-report.log.tar.gz (31.6 KB, 155 views)
farvardin is offline   Reply With Quote
Old 07-07-08, 09:47 AM   #8
spengy
Registered User
 
Join Date: Nov 2004
Posts: 1
Default Re: screen 1 pixel high (at 1280x1024 only)

I am also having this problem. I am running on an onboard Geforce 6100. My monitor is an Acer AL1717 LCD. Its native resolution is 1280x1024 @ 75Hz. I run Arch Linux - I'm on a 2.6.25 kernel.

With any of the newest Nvidia drivers I get a screen one pixel high at 1280x1024. This single pixel line appears at the very top of the screen. The rest of the screen is black. If I switch from X11 to a terminal I can see a brief flash of what the screen should look like.

Any resolution lower than 1280x1024 seems to work fine. I checked the X log and didn't see anything obviously wrong...

For now I have reverted back to 169.12, which does not seem to have this problem.

I just thought I would post so that people would know that this is not an isolated issue.
spengy is offline   Reply With Quote

Old 07-08-08, 06:08 PM   #9
tzp
Registered User
 
tzp's Avatar
 
Join Date: Sep 2007
Location: Hungary
Posts: 92
Default Re: screen 1 pixel high (at 1280x1024 only)

I also have problems with the NVIDIA-Linux-x86-173.14.09-pkg1.run, although not the 1 pixel high screen.
Namely, I have a Fujitsu-Siemens 19" LCD with a native resolution of 1440*900.
That was configured in my xorg.conf, and Xorg.0.log contained that the nvidia driver set it to 1440*900. (I had a modeline for that.)
However, in reality the resolution is set to 1152*850 for some reason (according to the OSD menu of the monitor.)

The GPU is an onboard 6150SE with nForce 430 chipset. The kernel is 2.6.22.6.
It was working fine with NVIDIA-Linux-x86-169.09-pkg1.run. For me this seems not to be related to the new kernel but rather to the new NVIDIA driver.
tzp is offline   Reply With Quote
Old 08-09-08, 08:20 AM   #10
master2001
Registered User
 
Join Date: Sep 2006
Posts: 13
Default Re: screen 1 pixel high (at 1280x1024 only)

Having exaclty the same Proble here with the latest drivers.
master2001 is offline   Reply With Quote
Old 08-24-08, 08:31 AM   #11
master2001
Registered User
 
Join Date: Sep 2006
Posts: 13
Default Re: screen 1 pixel high (at 1280x1024 only)

Hi All,

just tested with latest driver (177.68), but still the Problem exists.

@Nvidia: Did you already recognize this Bug? There are several threads about this issue (all of them have also the Bugreport for you to analyze attached)
http://www.nvnews.net/vbulletin/showthread.php?t=116946
http://www.nvnews.net/vbulletin/showthread.php?t=115209
http://www.nvnews.net/vbulletin/showthread.php?t=114346

The Problem appeared after the 169.12 Driver-Version. What all of the users, who seem to have this Problem, have in common:
1. They are using 64Bit Drivers
2. They use an embedded Nvidia GPU (6xxx as far as I understood right)
3. It only happens when chhoosing a resolution of 1280x1024

With theses Inforamtions the Problem should be reproducible. I'd really appreciate, if this Problem was fixed, since my workaround (using the old 169.12 drivers), doesn't work with the recent Kernel-Versions (cannot compile).

I'd appreciate if someone would post another workaround, or if nvidia would confirm that the have taken notice of this bug.

Thanks a lot and kind regards
Michael
master2001 is offline   Reply With Quote
Old 08-24-08, 06:59 PM   #12
farvardin
Registered User
 
Join Date: Jun 2007
Posts: 21
Default Re: screen 1 pixel high (at 1280x1024 only)

for my part I only have 2 and 3: while my computer is amd64, my linux distro and the nvidia drivers are fully 32 bits.
farvardin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: High Schoolers Build Supercomputer in Ontario News Archived News Items 0 06-01-12 01:10 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 07:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 04:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM

All times are GMT -5. The time now is 11:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.