Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-03, 01:46 AM   #1
Spirit[Si]
Registered User
 
Join Date: May 2003
Posts: 7
Question X goes black and utilizes 100% CPU

Greetings,

I've got a problem in my hands that I seem to be unable to fix.

When I use the nvidia graphics driver, my X will not launch properly. When I type "startx" it starts up and my screen turns black. X utilzes 100% CPU at this time and my console is completely wasted. I have to log on using ssh and reboot from there.

My hardware is:
AMD Athlon XP 2400+ CPU
Abit NF7 Motherboard ( nForce2 based )
Gainward Geforce4 MX460 Graphics
1 GB of RAM.

My software is:
Gentoo Linux 1.4_r4, 2.4.20-gentoo-r4 kernel
nvidia driver 1.0-4363 (I've also tried 4349 with the same results)
nvidia kernel modeule loaded

My /var/log/XFree86.0.log is attached and my /etc/X11/XF86Config will come in my next post.

I got some assistance from some guy on the Gentoo user mailing list, so, from what I know the next thing in this log should be 2D support starting up, but it never does.

Any assistance you might be able to give would be really helpful.

cheers,
Andreas
Attached Files
File Type: log xfree86.0.log (24.1 KB, 160 views)
Spirit[Si] is offline   Reply With Quote
Old 05-09-03, 01:47 AM   #2
Spirit[Si]
Registered User
 
Join Date: May 2003
Posts: 7
Question

And here is my XF86Config..

cheers,
Andreas
Attached Files
File Type: txt xf86config.txt (2.4 KB, 164 views)
Spirit[Si] is offline   Reply With Quote
Old 05-09-03, 01:49 AM   #3
Spirit[Si]
Registered User
 
Join Date: May 2003
Posts: 7
Question

Of course, I forgot to mention a couple of things..

agpart and dri support is not compiled into my kernel. I've also tried compiling completely without framebuffer support but that didn't make a difference either.

cheers,
Andreas

Last edited by Spirit[Si]; 05-09-03 at 01:57 AM.
Spirit[Si] is offline   Reply With Quote
Old 05-09-03, 08:19 AM   #4
Martigen
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

I have exactly the same problem, only on a nforce2 based Shuttle SFF PC.

Also using Gentoo 1.4 and tried various driver versions.

Andy, any ideas? I thought the drivers would be right at home on nforce2 hardware!

Martigen
Martigen is offline   Reply With Quote
Old 05-09-03, 10:22 AM   #5
Martigen
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

Just thought I'd post and say problem solved -- the 'IgnoreDisplayDevices' option worked perfectly.

Martigen
Martigen is offline   Reply With Quote
Old 05-09-03, 11:09 AM   #6
Spirit[Si]
Registered User
 
Join Date: May 2003
Posts: 7
Default

Just tried that option, nu luck. Still the same problem.

regards,
Andreas
Spirit[Si] is offline   Reply With Quote
Old 05-09-03, 11:47 PM   #7
Martigen
Registered User
 
Join Date: Apr 2003
Posts: 5
Default

As an update -- I actually used the 'IgnoreDisplayDevices' and another fix at the same time and through experimentation discovered I need both to get X to work on my Nforce2 system.

To the line that boots your kernel add: pci=noacpi pci=biosirq

I found this in these forums, thanks to other Nvidia Linux users.

Andy, it might be worth adding this to the FAQ.

Martigen
Martigen is offline   Reply With Quote
Old 05-11-03, 10:03 AM   #8
Spirit[Si]
Registered User
 
Join Date: May 2003
Posts: 7
Default

Thanks Martigen, this worked for me too You're the man !!

Now to the next step.. lets try some games

regards,
Andreas
Spirit[Si] is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.