Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-17-08, 04:50 AM   #1
Mcent
Registered User
 
Join Date: Jul 2008
Posts: 3
Unhappy Help:Installing nFORCE drivers on Debian etch(4.0r3)

My motherboard is Gigabyte GA-73PVM-S2H(nforce 630i /7100)

i want to install the nForce driver ,but not success ,please anyone help me,thx!

Here is the nvidia-nforce-installer.log file:

================================

nforce-installer log file '/var/log/nvidia-nforce-installer.log'
creation time: Thu Jul 17 17:21:03 2008

option status:
license pre-accepted : false
expert : false
uninstall : false
driver info : false
no precompiled interface : false
no ncurses color : false
no questions : false
silent : false
Installer install prefix : /usr
kernel source path : (not specified)
net kernel install path : (not specified)
audio kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp

Using: nvidia-installer ncurses user interface
-> Found package NVIDIA network driver for Linux-x86
-> Found package NVIDIA audio driver for Linux-x86
-> Please select packages for installation:
Selections:
NVIDIA audio driver for Linux-x86 (1.0-7)
-> Starting install of NVIDIA audio driver for Linux-x86
-> Checking for loaded module nvsound
-> Checking for loaded module nvaudio
-> License accepted.
-> Skipping check for conflicting rpms.
-> /proc/version is Linux version 2.6.18-6-686 (Debian 2.6.18.dfsg.1-18etch1)
(waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian
4.1.1-21)) #1 SMP Sun Feb 10 22:11:31 UTC 2008
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.6.18-6-686/build'
-> Kernel output path: '/lib/modules/2.6.18-6-686/build'
-> Performing cc_version_check with CC="cc".
-> running command /bin/grep "^PATCHLEVEL ="
/lib/modules/2.6.18-6-686/build/Makefile | /usr/bin/cut -d " " -f 3
-> Kernel module filename is nvsound.ko
Cleaning kernel module build directory.
executing: 'cd ./nvsound/main; make clean'...
rm -f *.ko *mod.* *.cmd nv*.o *~ core
-> Building kernel module:
executing: 'cd ./nvsound/main; make module SYSSRC=/lib/modules/2.6.18-6-686/
build SYSOUT=/lib/modules/2.6.18-6-686/build'...
make -C /lib/modules/2.6.18-6-686/build \
KBUILD_SRC=/usr/src/linux-headers-2.6.18-6-686 \
KBUILD_EXTMOD="/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main"
-f /usr/src/linux-headers-2.6.18-6-686/Makefile modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \
echo; \
/bin/false)
mkdir -p /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_ve
rsions
rm -f /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_versi
ons/*
make -f /usr/src/linux-headers-2.6.18-6-686/scripts/Makefile.build obj=/tmp/
selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main
cc -Wp,-MD,/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.nv
alinux.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.1/include -D_
_KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-headers-2.6.18-6-686/include
-include include/linux/autoconf.h -I/tmp/selfgz2371/NFORCE-Linux-x86-1.0-03
10-pkg1/nvsound/main -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-s
trict-aliasing -fno-common -Os -pipe -msoft-float -mpreferred-stack-boundary
=2 -march=i686 -mregparm=3 -ffreestanding -I/usr/src/linux-headers-2.6.18-6-
686/include/asm-i386/mach-default -Iinclude/asm-i386/mach-default -fomit-fra
me-pointer -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-s
ign -I/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main -Wall -Wi
mplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpo
inter-arith -Wno-multichar -Werror -O -MD -Wno-cast-qual -Wno-error -DNV_CHA
NGE_PAGE_ATTR_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUIL
D_STR(nvalinux)" -D"KBUILD_MODNAME=KBUILD_STR(nvsound)" -c -o /tmp/selfgz23
71/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_nvalinux.o /tmp/selfgz23
71/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main
/nvalinux.c
In file included from include/linux/list.h:8,
from include/linux/lockdep.h:12,
from include/linux/spinlock_types.h:12,
from include/linux/spinlock.h:78,
from include/linux/capability.h:45,
from include/linux/sched.h:44,
from include/linux/module.h:9,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvalinux.c:19:
include/linux/prefetch.h: In function ‘prefetch_range’:
include/linux/prefetch.h:62: warning: pointer of type ‘void *’ used in a
rithmetic
In file included from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvalinux.c:25:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:245: warning: wrong type argument to increment
cc -Wp,-MD,/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.nv
mixer.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.1/include -D__
KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-headers-2.6.18-6-686/include
-include include/linux/autoconf.h -I/tmp/selfgz2371/NFORCE-Linux-x86-1.0-03
10-pkg1/nvsound/main -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-s
trict-aliasing -fno-common -Os -pipe -msoft-float -mpreferred-stack-boundary
=2 -march=i686 -mregparm=3 -ffreestanding -I/usr/src/linux-headers-2.6.18-6-
686/include/asm-i386/mach-default -Iinclude/asm-i386/mach-default -fomit-fra
me-pointer -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-s
ign -I/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main -Wall -Wi
mplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpo
inter-arith -Wno-multichar -Werror -O -MD -Wno-cast-qual -Wno-error -DNV_CHA
NGE_PAGE_ATTR_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUIL
D_STR(nvmixer)" -D"KBUILD_MODNAME=KBUILD_STR(nvsound)" -c -o /tmp/selfgz237
1/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_nvmixer.o /tmp/selfgz2371
/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmixer.c
In file included from include/linux/list.h:8,
from include/linux/lockdep.h:12,
from include/linux/spinlock_types.h:12,
from include/linux/spinlock.h:78,
from include/linux/capability.h:45,
from include/linux/sched.h:44,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvhw.h:29,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvmixer.c:14:
include/linux/prefetch.h: In function ‘prefetch_range’:
include/linux/prefetch.h:62: warning: pointer of type ‘void *’ used in a
rithmetic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:564,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvhw.h:35,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvmixer.c:14:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:245: warning: wrong type argument to increment
cc -Wp,-MD,/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.nv
main.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.1/include -D__K
ERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-headers-2.6.18-6-686/include -
include include/linux/autoconf.h -I/tmp/selfgz2371/NFORCE-Linux-x86-1.0-031
0-pkg1/nvsound/main -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-st
rict-aliasing -fno-common -Os -pipe -msoft-float -mpreferred-stack-boundary=
2 -march=i686 -mregparm=3 -ffreestanding -I/usr/src/linux-headers-2.6.18-6-6
86/include/asm-i386/mach-default -Iinclude/asm-i386/mach-default -fomit-fram
e-pointer -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-si
gn -I/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main -Wall -Wim
plicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpoi
nter-arith -Wno-multichar -Werror -O -MD -Wno-cast-qual -Wno-error -DNV_CHAN
GE_PAGE_ATTR_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD
_STR(nvmain)" -D"KBUILD_MODNAME=KBUILD_STR(nvso
und)" -c -o /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp
_nvmain.o /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain
.c
In file included from include/linux/list.h:8,
from include/linux/lockdep.h:12,
from include/linux/spinlock_types.h:12,
from include/linux/spinlock.h:78,
from include/linux/capability.h:45,
from include/linux/sched.h:44,
from include/linux/module.h:9,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvmain.c:27:
include/linux/prefetch.h: In function ‘prefetch_range’:
include/linux/prefetch.h:62: warning: pointer of type ‘void *’ used in a
rithmetic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:564,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvhw.h:35,
from /tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main/nvmain.c:29:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:245: warning: wrong type argument to increment
/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c: In fun
ction ‘Nvaudio_mmap’:
/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c:991: wa
rning: implicit declaration of function ‘remap_page_range’
/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c: At top
level:
/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c:2191: e
rror: expected ‘)’ before string constant
make[4]: *** [/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nv
main.o] Error 1
make[3]: *** [_module_/tmp/selfgz2371/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound
/main] Error 2
make[2]: *** [modules] Error 2
-> Error.
ERROR: The NVIDIA kernel module was not created.
ERROR: Installation of the audio driver has failed. Please see the file
'/var/log/nvidia-nforce-installer.log' for details. You may find
suggestions on fixing installation problems in the README available on
the Linux driver download page at www.nvidia.com.
Mcent is offline   Reply With Quote
Old 07-17-08, 04:57 AM   #2
Mcent
Registered User
 
Join Date: Jul 2008
Posts: 3
Default Re: Help:Installing nFORCE drivers on Debian etch(4.0r3)

i disable the lan card ,i just want the sound card can run ,pls help me!

dmesg info:

===========================
Linux version 2.6.18-6-686 (Debian 2.6.18.dfsg.1-18etch1) (waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Sun Feb 10 22:11:31 UTC 2008
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000006f000000 (usable)
BIOS-e820: 000000006f000000 - 000000007f000000 (reserved)
BIOS-e820: 000000007f000000 - 000000007fdf0000 (usable)
BIOS-e820: 000000007fef0000 - 000000007fef3000 (ACPI NVS)
BIOS-e820: 000000007fef3000 - 000000007ff00000 (ACPI data)
BIOS-e820: 00000000e0000000 - 00000000e2000000 (reserved)
BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
1149MB HIGHMEM available.
896MB LOWMEM available.
found SMP MP-table at 000f4cf0
On node 0 totalpages: 523760
DMA zone: 4096 pages, LIFO batch:0
Normal zone: 225280 pages, LIFO batch:31
HighMem zone: 294384 pages, LIFO batch:31
DMI 2.4 present.
ACPI: RSDP (v000 GBT ) @ 0x000f6600
ACPI: RSDT (v001 GBT GBTUACPI 0x42302e31 GBTU 0x01010101) @ 0x7fef3040
ACPI: FADT (v001 GBT GBTUACPI 0x42302e31 GBTU 0x01010101) @ 0x7fef30c0
ACPI: HPET (v001 GBT GBTUACPI 0x42302e31 GBTU 0x00000098) @ 0x7fef85c0
ACPI: MCFG (v001 GBT GBTUACPI 0x42302e31 GBTU 0x01010101) @ 0x7fef8640
ACPI: MADT (v001 GBT GBTUACPI 0x42302e31 GBTU 0x01010101) @ 0x7fef84c0
ACPI: SSDT (v001 PmRef CpuPm 0x00003000 INTL 0x20040311) @ 0x7fef8ce0
ACPI: DSDT (v001 GBT GBTUACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 6:15 APIC version 20
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
Processor #1 6:15 APIC version 20
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] disabled)
ACPI: LAPIC (acpi_id[0x03] lapic_id[0x03] disabled)
ACPI: LAPIC_NMI (acpi_id[0x00] dfl dfl lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] dfl dfl lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x02] dfl dfl lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x03] dfl dfl lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: INT_SRC_OVR (bus 0 bus_irq 14 global_irq 14 high edge)
ACPI: INT_SRC_OVR (bus 0 bus_irq 15 global_irq 15 high edge)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
ACPI: IRQ14 used by override.
ACPI: IRQ15 used by override.
Enabling APIC mode: Flat. Using 1 I/O APICs
ACPI: HPET id: 0x10de8201 base: 0xfeff0000
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 80000000 (gap: 7ff00000:60100000)
Detected 1800.015 MHz processor.
Built 1 zonelists. Total pages: 523760
Kernel command line: root=/dev/hdb1 ro
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
spurious 8259A interrupt: IRQ7.
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 1807344k/2095040k available (1541k kernel code, 24304k reserved, 580k data, 196k init, 915392k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
hpet0: at MMIO 0xfeff0000 (virtual 0xf8800000), IRQs 2, 8, 31
hpet0: 3 32-bit timers, 25000000 Hz
Using HPET for base-timer
Calibrating delay using timer specific routine.. 3603.88 BogoMIPS (lpj=7207763)
Security Framework v1.0.0 initialized
SELinux: Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000e39d 00000000 00000001
CPU: After vendor identify, caps: bfebfbff 20100000 00000000 00000000 0000e39d 00000000 00000001
monitor/mwait feature present.
using mwait in idle threads.
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
CPU: After all inits, caps: bfebfbff 20100000 00000000 00000940 0000e39d 00000000 00000001
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
ACPI: Core revision 20060707
CPU0: Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz stepping 0d
SMP alternatives: switching to SMP code
Booting processor 1/1 eip 3000
Initializing CPU#1
Calibrating delay using timer specific routine.. 3600.05 BogoMIPS (lpj=7200116)
CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000e39d 00000000 00000001
CPU: After vendor identify, caps: bfebfbff 20100000 00000000 00000000 0000e39d 00000000 00000001
monitor/mwait feature present.
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
CPU: After all inits, caps: bfebfbff 20100000 00000000 00000940 0000e39d 00000000 00000001
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
CPU1: Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz stepping 0d
Total of 2 processors activated (7203.93 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
..MP-BIOS bug: 8254 timer not connected to IO-APIC
...trying to set up timer (IRQ0) through the 8259A ... failed.
...trying to set up timer as Virtual Wire IRQ... failed.
...trying to set up timer as ExtINT IRQ... works.
checking TSC synchronization across 2 CPUs: passed.
Brought up 2 CPUs
migration_cost=52
checking if image is initramfs... it is
Freeing initrd memory: 4385k freed
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using MMCONFIG
Setting up standard PCI resources
mtrr: your CPUs had inconsistent fixed MTRR settings
mtrr: probably your BIOS does not setup all CPUs.
mtrr: corrected configuration.
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:00:10.0
PCI: Transparent bridge - 0000:00:0a.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.HUB0._PRT]
ACPI: PCI Interrupt Link [LNK1] (IRQs 5 7 9 10 *11 14 15)
ACPI: PCI Interrupt Link [LNK2] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK3] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK4] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK5] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK6] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK7] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK8] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LP2P] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LIGP] (IRQs 5 7 9 *10 11 14 15)
ACPI: PCI Interrupt Link [LUBA] (IRQs 5 7 9 10 *11 14 15)
ACPI: PCI Interrupt Link [LUB2] (IRQs 5 *7 9 10 11 14 15)
ACPI: PCI Interrupt Link [LU1B] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LU2B] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LMAC] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LAZA] (IRQs *5 7 9 10 11 14 15)
ACPI: PCI Interrupt Link [LPMU] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LSMB] (IRQs 5 7 9 *10 11 14 15)
ACPI: PCI Interrupt Link [LIDE] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LSID] (IRQs 5 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [APC1] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [APC2] (IRQs 17) *0, disabled.
ACPI: PCI Interrupt Link [APC3] (IRQs 18) *0, disabled.
ACPI: PCI Interrupt Link [APC4] (IRQs 19) *0, disabled.
ACPI: PCI Interrupt Link [APC5] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [APC6] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [APC7] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [APC8] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [AIGP] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [AUBA] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [AUB2] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [AU1B] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [AU2B] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCH] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APMU] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [AAZA] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCS] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCM] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCZ] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APSI] (IRQs 20 21 22 23) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 11 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
pnp: 00:01: ioport range 0x1000-0x107f could not be reserved
pnp: 00:01: ioport range 0x1080-0x10ff has been reserved
pnp: 00:01: ioport range 0x1400-0x147f has been reserved
pnp: 00:01: ioport range 0x1480-0x14ff could not be reserved
pnp: 00:01: ioport range 0x1800-0x187f has been reserved
pnp: 00:01: ioport range 0x1880-0x18ff has been reserved
PCI: Bridge: 0000:00:0a.0
IO window: d000-dfff
MEM window: e3000000-e4ffffff
PREFETCH window: 80000000-800fffff
PCI: Bridge: 0000:00:0b.0
IO window: c000-cfff
MEM window: disabled.
PREFETCH window: disabled.
PCI: Bridge: 0000:00:0c.0
IO window: b000-bfff
MEM window: disabled.
PREFETCH window: disabled.
PCI: Bridge: 0000:00:0d.0
IO window: a000-afff
MEM window: disabled.
PREFETCH window: disabled.
PCI: Setting latency timer of device 0000:00:0a.0 to 64
PCI: Setting latency timer of device 0000:00:0b.0 to 64
PCI: Setting latency timer of device 0000:00:0c.0 to 64
PCI: Setting latency timer of device 0000:00:0d.0 to 64
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
audit: initializing netlink socket (disabled)
audit(1216315220.128:1): initialized
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
PCI: Setting latency timer of device 0000:00:0b.0 to 64
pcie_portdrv_probe->Dev[056e:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:0b.0cie00]
Allocate Port Service[0000:00:0b.0cie03]
PCI: Setting latency timer of device 0000:00:0c.0 to 64
pcie_portdrv_probe->Dev[056f:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:0c.0cie00]
Allocate Port Service[0000:00:0c.0cie03]
PCI: Setting latency timer of device 0000:00:0d.0 to 64
pcie_portdrv_probe->Dev[056f:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:0d.0cie00]
Allocate Port Service[0000:00:0d.0cie03]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard as /class/input/input0
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 8
NET: Registered protocol family 20
Starting balanced_irq
Using IPI No-Shortcut mode
ACPI: (supports S0 S1 S4 S5)
Freeing unused kernel memory: 196k freed
Time: tsc clocksource has been installed.
ACPI (exconfig-0455): Dynamic SSDT Load - OemId [ PmRef] OemTableId [ Cpu0Ist] [20060707]
ACPI (exconfig-0455): Dynamic SSDT Load - OemId [ PmRef] OemTableId [ Cpu1Ist] [20060707]
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not present [20060707]
ACPI: Getting cpuindex for acpiid 0x2
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not present [20060707]
ACPI: Getting cpuindex for acpiid 0x3
usbcore: registered new driver usbfs
usbcore: registered new driver hub
Mcent is offline   Reply With Quote
Old 07-17-08, 04:59 AM   #3
Mcent
Registered User
 
Join Date: Jul 2008
Posts: 3
Default Re: Help:Installing nFORCE drivers on Debian etch(4.0r3)

continue:

via-rhine.c:v1.10-LK1.4.1 July-24-2006 Written by Donald Becker
ACPI: PCI Interrupt Link [APC1] enabled at IRQ 16
ACPI: PCI Interrupt 0000:01:05.0[A] -> Link [APC1] -> GSI 16 (level, low) -> IRQ 201
eth0: VIA Rhine III at 0x1d000, 00:0f:3d:81:56:c1, IRQ 201.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt Link [AUBA] enabled at IRQ 23
ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [AUBA] -> GSI 23 (level, low) -> IRQ 209
PCI: Setting latency timer of device 0000:00:04.0 to 64
ohci_hcd 0000:00:04.0: OHCI Host Controller
ohci_hcd 0000:00:04.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:04.0: irq 209, io mem 0xe7004000
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 10 ports detected
ACPI: PCI Interrupt Link [AUB2] enabled at IRQ 22
ACPI: PCI Interrupt 0000:00:04.1[b] -> Link [AUB2] -> GSI 22 (level, low) -> IRQ 217
PCI: Setting latency timer of device 0000:00:04.1 to 64
ehci_hcd 0000:00:04.1: EHCI Host Controller
ehci_hcd 0000:00:04.1: new USB bus registered, assigned bus number 2
ehci_hcd 0000:00:04.1: debug port 1
PCI: cache line size of 32 is not supported by device 0000:00:04.1
ehci_hcd 0000:00:04.1: irq 217, io mem 0xe7005000
ehci_hcd 0000:00:04.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 10 ports detected
SCSI subsystem initialized
libata version 2.00 loaded.
Probing IDE interface ide0...
hdb: SAMSUNG SP0822N, ATA DISK drive
Probing IDE interface ide1...
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdb: max request size: 512KiB
hdb: Host Protected Area detected.
current capacity is 156365903 sectors (80059 MB)
native capacity is 156368016 sectors (80060 MB)
hdb: Host Protected Area disabled.
hdb: 156368016 sectors (80060 MB) w/2048KiB Cache, CHS=16383/255/63
hdb: cache flushes supported
hdb: hdb1 hdb2 < hdb5 > hdb3
Attempting manual resume
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
input: PC Speaker as /class/input/input1
input: ImPS/2 Generic Wheel Mouse as /class/input/input2
ts: Compaq touchscreen protocol output
Adding 995988k swap on /dev/hdb5. Priority:-1 extents:1 across:995988k
EXT3 FS on hdb1, internal journal
loop: loaded (max 8 devices)
ieee1394: Initialized config rom entry `ip1394'
ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
ieee1394: sbp2: Try serialize_io=0 for better performance
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
lp: driver loaded but no devices found
ppdev: user-space parallel port driver
eth1: no IPv6 routers present
Mcent is offline   Reply With Quote
Old 07-17-08, 05:18 AM   #4
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Help:Installing nFORCE drivers on Debian etch(4.0r3)

I don't think you need the nforce drivers any more for audio and lan since they are supported in the linux kernel but it is possible that debian etch since it uses a bit older drivers etc doesn't have these drivers.

To be honest I would use debian testing for a workstation which is very stable and it more up to date.
gbil is offline   Reply With Quote
Old 08-07-08, 12:55 AM   #5
jocko
Registered User
 
Join Date: Aug 2006
Posts: 7
Default Re: Help:Installing nFORCE drivers on Debian etch(4.0r3)

If you're still looking for help with this, I have a thread on the Ubuntu forums with instructions for installing nvsound on kernels 2.6.16 or newer, up to the current 2.6.26 kernel.

One little warning, though: If your distro uses a pulseaudio version newer than 0.9.6, activating the oss module in pulseaudio will cause a complete system freeze (I'm told by the pulseaudio developers this is most likely a bug in nvidia's driver, but that is very unlikely to ever be fixed).
Etch should not be affected by this, as the pulseaudio version in the repos is still at 0.9.5, so you should be safe.

Edit: I checked the specifications of your motherboard, and it does not have SoundStorm, so I doubt the nvsound driver will improve anything for you.
The only reason for installing nvsound instead of using the open source alsa driver is that nvsound can use the hardware mixer and on-the-fly dolby digital encoding capabilities that were part of the soundstorm audio processor in some old nforce2 motherboards. As your sound chip lacks such advanced functionality, it should be fully supported by the alsa drivers.
jocko is offline   Reply With Quote
Old 08-07-08, 07:07 PM   #6
feld
Registered User
 
Join Date: Dec 2005
Posts: 9
Default Re: Help:Installing nFORCE drivers on Debian etch(4.0r3)

Don't use the nFORCE drivers. I didnt know anyone used those in the past 6 years .....


Drop ALSA and Pulseaudio and get Opensound OSS. I bet your sound will work fine then.

http://opensound.com
feld is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 08:34 PM
Debian + Nvidia drivers, bad compilation Prodigy NVIDIA Linux 16 09-10-02 07:13 PM
Debian Woody 3.0r0 and Problems with Geforce drivers vogt NVIDIA Linux 3 09-09-02 02:07 PM
Detonator Drivers (40.xx) and nForce. Philibob NVIDIA Windows Graphics Drivers 1 09-07-02 12:49 PM
nvidea drivers on 2.4.18 Debian (3.0 woody) thor NVIDIA Linux 2 08-20-02 02:51 PM

All times are GMT -5. The time now is 02:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.