Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-23-08, 02:56 PM   #1
tzp
Registered User
 
tzp's Avatar
 
Join Date: Sep 2007
Location: Hungary
Posts: 92
Question NVPerfKit startup difficulties

I'm running kernel 2.6.22.6.
I just installed the PerfKit 6 for Linux 32 that comes with the beta version driver NVIDIA-Linux-x86-173.13-NVPerfKit.runpkg1.run.

I call NVPMInit() that returns 0 (=NVPM_OK). However, immediately after that my NVPM* calls return 3 (=NVPM_ERROR_NOT_INITIALIZED). (I called NVPMEnumCounters resp. NVPMShutdown and both return 3.)

I attached the C source for that and the bug report logs.

Did anyone see the same problem ?
What did I do wrong ?
Is there any specific Linux kernel version that PerfKit should be used with ?

(PS. I posted this on the developer forums but the chance to get a response there seems to be quite low Maybe here... Maybe someone from nVidia...)
Attached Files
File Type: gz nvidia-bug-report.log.gz (42.0 KB, 154 views)
File Type: gz nvcounters.c.gz (458 Bytes, 140 views)
tzp is offline   Reply With Quote
Old 08-04-08, 05:37 PM   #2
chris2718
Registered User
 
Join Date: Aug 2008
Posts: 5
Default Re: NVPerfKit startup difficulties

I have the same problem you have described. I am running ubuntu hardy,
linux 2.6.24-16-generic on 64-bit.

I bypassed the enum and tried to iterate through the counters, there are none returned.
My c++ code also runs on Windows Vista 32 bit, and it works. (gets 200+ counters)

If I try running ./OGLPerfHarness in the samples directory, and press "p", analysis "not available".

I looked into the source code of the nvidia kernel driver, and I didn't see any instrumentation-specific code. Looks like a problem with the closed-source nvidia opengl libraries.
chris2718 is offline   Reply With Quote
Old 08-26-08, 02:59 PM   #3
nemecb
Registered User
 
Join Date: Jan 2005
Location: Rochester, MN
Posts: 4,018
Default Re: NVPerfKit startup difficulties

Just a quick "me too" on this. I tried to use the instrumented driver with Bugle, but it throws an error every time I try to use an NV:* statistic.

I guess this is progress though since the last time I tried the instrumented driver it wouldn't compile without modifications on newer kernels and hung X when I started it.
nemecb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Circuit: FCC chairman on Hopper, data caps; Google-Motorola closes; Startup Act 2 News Archived News Items 0 05-24-12 04:40 AM
Facial detection startup changes privacy policy after Friday launch News Archived News Items 0 05-20-12 05:30 PM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM
Slow XP startup after upgrade.... Ramshambo2001 Microsoft Windows XP And Vista 10 10-10-02 01:35 AM
X startup i_yalovoy NVIDIA Linux 3 09-27-02 12:00 PM

All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.