Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-14-08, 02:09 PM   #1
coffeboy
Registered User
 
Join Date: Aug 2008
Posts: 6
Default GeForce 8200 and Ubuntu 8.04

Hello,

I've bought the Asrock K10N78FullHD-hSLI R3.0 with an integrated GeForce 8200 Graphic-Chip. I've installed Ubuntu 8.04 32bit, downloaded NVIDIA-Linux-x86-173.14.12-pkg1.run and installed the driver. Now I'm able to select the 1680x1050 that my TFT runs. But the screen flashes from time to time. Especially when I enable 3d effects or watch a video (not in fullscreen). I've also tried the 64 bit version of Ubuntu and openSuse 11.0. They all have these flashing. I've also tried to reduce the resolution to 1280x1024. The flashing screen kept. Using vesa shows no flashing screen. So the hardware seems to be ok. Unfortunately Vesa does not support the 1680x1050 of my TFT so I need the NVidia driver to get working without flashing. I haven't found any errors in /var/log/Xorg.0.log.
Has anybody any idea what else I could try? Is the driver for the 8200 stable or beta? Is there any release of a new driver planned?

regards

joerg
coffeboy is offline   Reply With Quote
Old 08-14-08, 03:20 PM   #2
jcornwall
Registered User
 
Join Date: Aug 2007
Location: Austin, TX
Posts: 120
Default Re: GeForce 8200 and Ubuntu 8.04

That's caused by a bug in Powermizer stepping up/down the GPU clocks to save power.

I don't have a solution (other than forcing the performance mode to Maximum, but that's horrible in terms of battery/heat on a laptop), I'm just living with it on my laptop in the hope that a future driver fixes it.
jcornwall is offline   Reply With Quote
Old 08-15-08, 03:11 PM   #3
coffeboy
Registered User
 
Join Date: Aug 2008
Posts: 6
Unhappy Re: GeForce 8200 and Ubuntu 8.04

Thanks for the info. I've found a lot of hits at google for the powermixer. Neither
Option "RegistryDwords" "PowerMizerLevel=0x1"
nor
Option "Coolbits" "1" (I've tried to reduce the clock speed but it always flipped back to 500.
or
options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=44 NVreg_DeviceFileMode=0660i NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"
helped me. The flashing is still there.
Since I've got a desktop I wouldn't even care about running the gpu at full speed. But it seem that there is no way to turn off the powermizer.
Boy, I'll just want to get away the flashing.
I've even tried these endless loop quering nvidia-settings or glx-info. Both didn't help (or at least it wasn't visibile).

regards

joerg
coffeboy is offline   Reply With Quote
Old 08-15-08, 08:00 PM   #4
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: GeForce 8200 and Ubuntu 8.04

Have you tried another driver version? Like 177 beta or better yet, 169.12?
ledoc is offline   Reply With Quote
Old 08-17-08, 03:41 PM   #5
coffeboy
Registered User
 
Join Date: Aug 2008
Posts: 6
Default Re: GeForce 8200 and Ubuntu 8.04

Quote:
Originally Posted by ledoc View Post
Have you tried another driver version? Like 177 beta or better yet, 169.12?
The 169 didn't recongize my graphic cip. I've got no screen at all. The 173 and 177 recongize my graphic chip but both have this awful flashing.
coffeboy is offline   Reply With Quote
Old 08-17-08, 04:27 PM   #6
Resqguy
Registered User
 
Join Date: Aug 2008
Posts: 4
Default Re: GeForce 8200 and Ubuntu 8.04

I'm not sure if it is the same problem but my 8200 flashed and would cause breakup in the audio. I'm using an IDE drive and still had my SAT controller enabled. After going into the BIOS and disabling everything that wasn't present (Floppy, SATA) the problem went away.
Resqguy is offline   Reply With Quote
Old 08-18-08, 02:56 PM   #7
coffeboy
Registered User
 
Join Date: Aug 2008
Posts: 6
Default Re: GeForce 8200 and Ubuntu 8.04

It's getting stranger every day. Yesterday I've written a bug report to nvidia. I used google webmail. I did not nothing except typing this damn mail and the flashing increased steadily.
Today I've downloaded a doom3 demo, played it at the highest detail level for about 15 to 30 minutes (I had pauses due to sound problems). The game felt a little bit slow (I guess the 8200 hasn't enough power for it) but there was no flashing. Now it gets even stranger. I hadn't a flashing for the last one and a half hour. I could surf on the web without flashing. I'm very curious what happens when I start the computer tomorrow.
coffeboy is offline   Reply With Quote
Old 08-19-08, 03:31 PM   #8
coffeboy
Registered User
 
Join Date: Aug 2008
Posts: 6
Default Re: GeForce 8200 and Ubuntu 8.04

After booting the system today the flashing was back (what a suprise) but playing five minutes doom3 at highest detail level and the flashing got away until now (about 1 hour).
coffeboy is offline   Reply With Quote

Old 08-23-08, 12:38 PM   #9
coffeboy
Registered User
 
Join Date: Aug 2008
Posts: 6
Smile Re: GeForce 8200 and Ubuntu 8.04

Hello all,

NVIDIA-Linux-x86-177.67-pkg1 seems to fix the problem for me on the 32 bit version of ubuntu. I have turned on not special flags, I've justed installed the driver.
coffeboy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.