Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-11-08, 05:16 PM   #1
noheip
Registered User
 
Join Date: Jul 2008
Posts: 11
Default xorg crashes with xinerama + crashes with compsite and OpenGL

Dear all,

before trying to downgrade and do a try'n'error search I wanted to ask if somebody else has problems with the 173.14.09 driver and xinerama. I have one 7300GS and use two seperate screens. As soon as I enable xinerama xorg core dumps. Without xinerama it's running fine.

Another, unrelated, problem is that xorg also crashes when I start an OpenGL game with XFCEs compositor enabled. I'm sure I had running OpenGL games with compositor enabled under KDE. I can't imagin that's a matter of the compositor.

System is RELENG_7/i386@core2/1GB and xorg 7.3 (server 1.4.0), driver 173.14.09

Best regards,

-Harry
noheip is offline   Reply With Quote
Old 07-14-08, 11:39 AM   #2
noheip
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

Compostite Crash:
I figured out that drivers 169.12 and 100.14.19 doesn't crash xorg if I start an OpenGL game with compositor enabled.
With the 173.14.09 driver only fullscreen (with overlay rendering enabled in the compositor) mode works.
If I run cube windowed xorg dies, so for sure there's a regression in the new driver.

Regarding the Xinerama problem I couldn't find a regressen, it doesn't work with the older versions too
Since I have a triple head setup twinview isn't an option for me.
Possibly xorg itself has the bug. Any hints how to determine what the reason could be that xinerama doesn't work for me? (needless to say that I don't get anything out of xorg.log)

Thanks,

-Harry
noheip is offline   Reply With Quote
Old 07-14-08, 03:27 PM   #3
noheip
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

Quote:
Originally Posted by noheip View Post
*snip*

Regarding the Xinerama problem I couldn't find a regressen, it doesn't work with the older versions too
Since I have a triple head setup twinview isn't an option for me.
Possibly xorg itself has the bug
Ok, the Xinerama Problem is also identified. Thanks to that thread:
http://www.nvnews.net/vbulletin/showthread.php?t=99016

I disabled the composite option (in xorg.conf, not just not running a compostitor!) and now xinerama is working fine with my two 7300GT and 3 screens.

Seems compositing is a big issue for the nvidia driver.
I'd love to know the problems beeing recognized/working on
I don't want transperency - vista like - just for eye candy, but for real transparent (inactive) consoles for example. Eye candy of dropdown shadows are also welcome of course! I'd so much like to have a composite compatible nvidia driver
Could AaronP perhaps leave a comment? Or Zander? Thanks in advance!

Best regards,

-Harry
noheip is offline   Reply With Quote
Old 07-15-08, 08:15 AM   #4
gnemmi
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

Would be good if any of or both of them could leave a message on most of the latest threads ...
gnemmi is offline   Reply With Quote
Old 08-02-08, 02:48 PM   #5
jnr
Registered User
 
Join Date: Aug 2008
Posts: 16
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

This has bitten me as well, in fact this is what I came to post about.

I'm running the newest xorg and nvidia driver in Ports as of today (7.3 and 173.14.09) on FreeBSD 7.0 i386 with two displays in TwinView. My configuration file has not changed, and everything worked perfectly with a previous release.

I was pulling my hair out trying to get GL apps working, so now I'm just running with Composite disabled and with Metacity instead of compiz. It wouldn't be so bad if the GL apps themselves just crashed, but it takes down my entire x server.

Edit: I installed ports-mgmt/portdowngrade, rolled back to 169.12 from April, and all is well.
jnr is offline   Reply With Quote
Old 08-08-08, 06:53 AM   #6
noheip
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

I updated to the latest driver (173.14.12) and now the Composite extension magically vanishes when I enable Xinerama (xdpyinfo)
Is this the nvidia way of fixing bugs?

OpenGL game cube still crashes when Composite is enabled. But it doesn't matter because I need Xinerama and as soon as the driver detects Xinerama it unloads Composite extension, so no crash any more

Best regards,

-noheip
noheip is offline   Reply With Quote
Old 08-08-08, 11:48 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

The X.Org X server does not support Xinerama and COMPOSITE at the same time; please also see other threads on this topic, e.g. http://www.nvnews.net/vbulletin/showthread.php?t=108300.
zander is offline   Reply With Quote
Old 08-08-08, 12:17 PM   #8
jnr
Registered User
 
Join Date: Aug 2008
Posts: 16
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

Does TwinView count? I have Option "Xinerama" "0" but TwinView enabled for my two displays.
jnr is offline   Reply With Quote

Old 08-13-08, 03:25 AM   #9
HenryHu
Registered User
 
Join Date: Aug 2008
Posts: 24
Default Re: xorg crashes with xinerama + crashes with compsite and OpenGL

I have the same problem, and I've submitted a PR:
http://www.freebsd.org/cgi/query-pr.cgi?pr=124638

Composite and OpenGL works in 169.12, but they don't work with 173.09
I've tried 177.13 and it also crashes.
I'll try 173.12. I don't hope it is usable.
By the way, I found that glxgears FPS goes from 8000 ~ 8500 to 4000 ~ 4500 after upgrading to 177.13.
I've tested with kwin4 with Desktop Effects enabled, and it also failed.
HenryHu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:26 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.