Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-20-08, 02:17 PM   #1
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

I have a Dell Inspiron 8200 Laptop that I am running xubuntu on. I got Compiz Fusion installed but it will not replace the current desktop manager because the 3D graphics accelerator is not enabled. I installed the driver and enabled it. It says it requires a restart, so I do that. And once I hit the login page, the screen goes black. I know it has to be a video problem...

I do not understand why the 3D accelerator will not work but I NEED IT. If you can help, PLEASE DO.

Thanks!

Shawn
belikeyeshua is offline   Reply With Quote
Old 08-20-08, 02:20 PM   #2
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

Sorry, this is long but this is what the /var/log/Xorg.0.log file says.



(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.1
(II) NVIDIA GLX Module 96.43.05 Tue Jan 22 20:11:30 PST 2008
(II) Loading extension GLX
(II) LoadModule: "v4l"
(II) Loading /usr/lib/xorg/modules/drivers//v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 0.1.1
ABI class: X.Org Video Driver, version 2.0
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.4.0.90, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
compiled for 4.3.99.902, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 1.2.3
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 1.2.2
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) v4l driver for Video4Linux
(II) NVIDIA dlloader X Driver 96.43.05 Tue Jan 22 19:38:46 PST 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"(II) Module "ramdac" already built-in
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/lib/xorg/modules//libxaa.so
(II) Module xaa: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.2.0
ABI class: X.Org Video Driver, version 2.0
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xf8ff8000 - 0xf8ffbfff (0x4000) MX[b]
[5] -1 0 0xf8fff000 - 0xf8fff7ff (0x800) MX[b]
[6] -1 0 0xf8fffc00 - 0xf8fffc7f (0x80) MX[b]
[7] -1 0 0x40000000 - 0x400003ff (0x400) MX[b]
[8] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[9] -1 0 0xd8000000 - 0xd801ffff (0x20000) MX[b](B)
[10] -1 0 0xdff80000 - 0xdfffffff (0x80000) MX[b](B)
[11] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[12] -1 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b](B)
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[15] -1 0 0x0000ec80 - 0x0000ecff (0x80) IX[b]
[16] -1 0 0x0000dc00 - 0x0000dc7f (0x80) IX[b]
[17] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[18] -1 0 0x0000dc80 - 0x0000dcbf (0x40) IX[b]
[19] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[20] -1 0 0x0000bfa0 - 0x0000bfaf (0x10) IX[b]
[21] -1 0 0x00000374 - 0x00000374 (0x1) IX[b]
[22] -1 0 0x00000170 - 0x00000177 (0x8) IX[b]
[23] -1 0 0x000003f4 - 0x000003f4 (0x1) IX[b]
[24] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[b]
[25] -1 0 0x0000bf20 - 0x0000bf3f (0x20) IX[b]
[26] -1 0 0x0000bf80 - 0x0000bf9f (0x20) IX[b]
(II) resource ranges after probing:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xf8ff8000 - 0xf8ffbfff (0x4000) MX[b]
[5] -1 0 0xf8fff000 - 0xf8fff7ff (0x800) MX[b]
[6] -1 0 0xf8fffc00 - 0xf8fffc7f (0x80) MX[b]
[7] -1 0 0x40000000 - 0x400003ff (0x400) MX[b]
[8] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[9] -1 0 0xd8000000 - 0xd801ffff (0x20000) MX[b](B)
[10] -1 0 0xdff80000 - 0xdfffffff (0x80000) MX[b](B)
[11] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[12] -1 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b](B)
[13] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[14] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[15] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[17] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[18] -1 0 0x0000ec80 - 0x0000ecff (0x80) IX[b]
[19] -1 0 0x0000dc00 - 0x0000dc7f (0x80) IX[b]
[20] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[21] -1 0 0x0000dc80 - 0x0000dcbf (0x40) IX[b]
[22] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[23] -1 0 0x0000bfa0 - 0x0000bfaf (0x10) IX[b]
[24] -1 0 0x00000374 - 0x00000374 (0x1) IX[b]
[25] -1 0 0x00000170 - 0x00000177 (0x8) IX[b]
[26] -1 0 0x000003f4 - 0x000003f4 (0x1) IX[b]
[27] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[b]
[28] -1 0 0x0000bf20 - 0x0000bf3f (0x20) IX[b]
[29] -1 0 0x0000bf80 - 0x0000bf9f (0x20) IX[b]
[30] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[31] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(**) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) NVIDIA(0): NVIDIA GPU GeForce4 440 Go at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.17.00.55.c2
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 440 Go at PCI:1:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0)
(--) NVIDIA(0): CRT-0: 350.0 MHz maximum pixel clock
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): 224.0 MHz maximum pixel
(--) NVIDIA(0): clock
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1600x1200@85"
(II) NVIDIA(0): "1792x1344@75"
(II) NVIDIA(0): "1600x1200@70"
(II) NVIDIA(0): "1792x1344@60"
(II) NVIDIA(0): "1600x1200@75"
(II) NVIDIA(0): "1856x1392@60"
(II) NVIDIA(0): "1600x1200@60"
(II) NVIDIA(0): "1920x1440@60"
(II) NVIDIA(0): "1600x1200@65"
(II) NVIDIA(0): "2048x1536@60"
(II) NVIDIA(0): "1400x1050@75"
(II) NVIDIA(0): "1400x1050@60"
(II) NVIDIA(0): "1280x960@75"
(II) NVIDIA(0): "1280x1024@60"
(II) NVIDIA(0): "1280x1024@85"
(II) NVIDIA(0): "1280x960@85"
(II) NVIDIA(0): "1280x960@60"
(II) NVIDIA(0): "1280x1024@75"
(II) NVIDIA(0): "1152x864@75"
(II) NVIDIA(0): "1024x768@60"
(II) NVIDIA(0): "1024x768@70"
(II) NVIDIA(0): "1024x768@75"
(II) NVIDIA(0): "1024x768@85"
(II) NVIDIA(0): "832x624@75"
(II) NVIDIA(0): "800x600@60"
(II) NVIDIA(0): "800x600@85"
(II) NVIDIA(0): "800x600@75"
(II) NVIDIA(0): "800x600@72"
(II) NVIDIA(0): "800x600@56"
(II) NVIDIA(0): "640x480@85"
(II) NVIDIA(0): "640x480@75"
(II) NVIDIA(0): "640x480@72"
(II) NVIDIA(0): "640x480@60"
(**) NVIDIA(0): Virtual screen size configured to be 2048 x 1536
(WW) NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) NVIDIA(0): from CRT-0's EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xdff80000 - 0xdfffffff (0x80000) MX[b]
[1] 0 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b]
[2] 0 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b]
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[7] -1 0 0xf8ff8000 - 0xf8ffbfff (0x4000) MX[b]
[8] -1 0 0xf8fff000 - 0xf8fff7ff (0x800) MX[b]
[9] -1 0 0xf8fffc00 - 0xf8fffc7f (0x80) MX[b]
[10] -1 0 0x40000000 - 0x400003ff (0x400) MX[b]
[11] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[12] -1 0 0xd8000000 - 0xd801ffff (0x20000) MX[b](B)
[13] -1 0 0xdff80000 - 0xdfffffff (0x80000) MX[b](B)
[14] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[15] -1 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b](B)
[16] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[17] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[18] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[19] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[20] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[21] -1 0 0x0000ec80 - 0x0000ecff (0x80) IX[b]
[22] -1 0 0x0000dc00 - 0x0000dc7f (0x80) IX[b]
[23] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[24] -1 0 0x0000dc80 - 0x0000dcbf (0x40) IX[b]
[25] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[26] -1 0 0x0000bfa0 - 0x0000bfaf (0x10) IX[b]
[27] -1 0 0x00000374 - 0x00000374 (0x1) IX[b]
[28] -1 0 0x00000170 - 0x00000177 (0x8) IX[b]
[29] -1 0 0x000003f4 - 0x000003f4 (0x1) IX[b]
[30] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[b]
[31] -1 0 0x0000bf20 - 0x0000bf3f (0x20) IX[b]
[32] -1 0 0x0000bf80 - 0x0000bf9f (0x20) IX[b]
[33] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[34] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Setting mode "1600x1200@85"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
Atom 4, CARD32 4, unsigned long 4
(II) Synaptics touchpad driver version 0.14.6 (1406)
(--) Synaptics Touchpad auto-dev sets device to /dev/input/event8
(**) Option "Device" "/dev/input/event8"
(**) Option "HorizEdgeScroll" "0"
(--) Synaptics Touchpad touchpad found
(**) Option "SendCoreEvents" "true"
(**) Synaptics Touchpad: always reports core events
(WW) Configured Mouse: No Device specified, looking for one...
(II) Configured Mouse: Setting Device option to "/dev/input/mice"
(--) Configured Mouse: Device: "/dev/input/mice"
(==) Configured Mouse: Protocol: "Auto"
(**) Option "CorePointer"
(**) Configured Mouse: always reports core events
(==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Configured Mouse: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) Generic Keyboard: always reports core events
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
belikeyeshua is offline   Reply With Quote
Old 08-20-08, 02:21 PM   #3
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Generic Keyboard: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(II) evaluating device (Generic Keyboard)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) evaluating device (Configured Mouse)
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) evaluating device (Synaptics Touchpad)
(II) XINPUT: Adding extended input device "Synaptics Touchpad" (type: MOUSE)
(--) Configured Mouse: PnP-detected protocol: "ExplorerPS/2"
(II) Configured Mouse: ps2EnableDataReporting: succeeded
(--) Synaptics Touchpad auto-dev sets device to /dev/input/event8
(**) Option "Device" "/dev/input/event8"
(--) Synaptics Touchpad touchpad found
belikeyeshua is offline   Reply With Quote
Old 08-20-08, 11:39 PM   #4
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

BUMP!

I have not yet got a response. I really need to get this working... let me know if anyone can be of any help.

God bless you all!
belikeyeshua is offline   Reply With Quote
Old 08-21-08, 06:39 AM   #5
memeyou
Registered User
 
Join Date: May 2008
Posts: 74
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

Quote:
Originally Posted by belikeyeshua View Post
I got Compiz Fusion installed but it will not replace the current desktop manager because the 3D graphics accelerator is not enabled.
From your log composite is running just fine. Why do you think your "accelerator is not enabled"? Are you even running compiz? How are you running compiz? What is the output of "compiz --replace"?
memeyou is offline   Reply With Quote
Old 08-21-08, 06:52 AM   #6
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

Reread his original post:

Quote:
And once I hit the login page, the screen goes black.
As I understand it, X starts up but is not visible as long as he's using the nvidia driver. On another forum I walked him through grabbing a copy of the log file by switching to the console with control+alt+f1 and copying it to his desktop.

Adam
adamk75 is offline   Reply With Quote
Old 08-21-08, 07:14 AM   #7
memeyou
Registered User
 
Join Date: May 2008
Posts: 74
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

so is this not a compiz issue? sorry, i was misled by the red herring in the title. I'm pretty sure the window manager (compiz in this case?) isn't enabled until after login...

are the monitor settings unsupported by the display (1600x1200@85)? i notice the virtual screen size is a bit larger than the actual... but that is the only thing that seems out of place. what is the output of nvidia-bug-report.sh?
memeyou is offline   Reply With Quote
Old 08-21-08, 08:03 AM   #8
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

I think its got to be something with the 3D accelerator driver... EVERYTIME I enable it, and restart, tcreen goes blank at login.

With typing Compiz --replace, in the terminal... I get this: shawn@ubuntu:~$ compiz --replace
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: true
no true found, exiting
shawn@ubuntu:~$


I think it is not a compiz problem... it has to be a graphics problem, and that was why I posted this thread, here. I installed compiz using the directions for ubunto on the compiz fusion website... it went smoothly.

God bless,
Shawn
belikeyeshua is offline   Reply With Quote

Old 08-21-08, 08:10 AM   #9
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

Read the stickies on how to report problems.

In your Xorg.log it seems that the nvidia driver fails to get the EDID out of your monitor, which would provide the driver with informations on what modes and frequencies are sane.

Even without the EDID he validates some modes, which lets me think that you try to run the monitor with frequencies or a resolution which is not supported.

Please provide a nvidia-bug-report. You should still be able to switch to a VT (CTRL+ALT+F1), log in and run sudo nvidia-bug-report.sh.

Else we don't have enough information to help you, besides guessing, which doesn't help at all usually.

Fuchs
NvFuchs is offline   Reply With Quote
Old 08-21-08, 10:08 AM   #10
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

OK......

I enabled the 3D driver, again....

Then types in sudo nvidia-bug-report.sh, to which it said the bug report has been created, and it send something about emailing it to a certain address....

No idea how to fix this one. When I reconfigure the xserver, I restart it, then I get a message that it is running in low graphics mode, and that I need to manually configure the monitor... So I do, and restart, then graphics works... just without 3D aceleration and without compiz.
belikeyeshua is offline   Reply With Quote
Old 08-21-08, 10:43 AM   #11
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

Quote:
Originally Posted by belikeyeshua View Post
OK......

I enabled the 3D driver, again....

Then types in sudo nvidia-bug-report.sh, to which it said the bug report has been created, and it send something about emailing it to a certain address....
You should now have a file called "nvidia-bug-report.log", probably lying around in your $HOME folder, or wherever you did run nvidia-bug-report.sh.

Please attach the log (you might have to compress it because of size limits) to a posting in this forum.


Fuchs
NvFuchs is offline   Reply With Quote
Old 08-21-08, 10:51 AM   #12
belikeyeshua
Registered User
 
Join Date: Aug 2008
Posts: 11
Send a message via Yahoo to belikeyeshua
Default Re: NVIDIA 3D Graphics Driver Problem --Cant use Compiz under xubuntu 8.04

Quote:
Originally Posted by NvFuchs View Post
You should now have a file called "nvidia-bug-report.log", probably lying around in your $HOME folder, or wherever you did run nvidia-bug-report.sh.

Please attach the log (you might have to compress it because of size limits) to a posting in this forum.


Fuchs
How can I do that...? The file is 46 Pages long.
belikeyeshua is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 09:43 AM

All times are GMT -5. The time now is 07:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.