Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-21-08, 06:11 AM   #1
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default How to disable powermizer?

Hi,

How can I disable powermizer? Currently it's underclocking my graphic card to the level it's completely unusable. All settings seems to be read only.

Code:
Attribute 'GPUCurrentClockFreqs' (rob4300:0.0): 169,100.
    'GPUCurrentClockFreqs' is a packed integer attribute.
    'GPUCurrentClockFreqs' is a read-only attribute.

 Attribute 'GPUAdaptiveClockState' (rob4300:0.0): 1.
    'GPUAdaptiveClockState' is an integer attribute.
    'GPUAdaptiveClockState' is a read-only attribute.

also changing 2D Freq doesn't work (3D seems to work though)
Code:
Attribute 'GPU2DClockFreqs' (rob4300:0.0): 169,100.
queen6 is offline   Reply With Quote
Old 08-21-08, 06:28 AM   #2
kernelOfTruth
Gentoo Linux addict
 
Join Date: Nov 2007
Location: Vienna, Austria; Germany; hello world :)
Posts: 202
Default Re: How to disable powermizer?

see http://wiki.archlinux.org/index.php/...for_laptops.29
__________________
2.6.30-rc3-zen0+ w. compcache, reiser4 + ccreg40 (lzo-compression + checksumming)
gcc version 4.4.0-pre9999 built 20090425 (prerelease) rev. 146764 (Gentoo SVN)
gcc version 4.4.0 (Gentoo Hardened 4.4.0-r1, espf-0.2.1)
Ubuntu Jaunty/9.04 x86_64 Dell XPS M1330
kernelOfTruth is offline   Reply With Quote
Old 08-21-08, 09:37 AM   #3
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: How to disable powermizer?

Thanks for the hint. Tried it and it doesn't work
queen6 is offline   Reply With Quote
Old 08-21-08, 09:41 AM   #4
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: How to disable powermizer?

Depending on your distro, this may work for you: http://ubuntuforums.org/showthread.php?t=828369
shaundennie is offline   Reply With Quote
Old 08-21-08, 09:48 AM   #5
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: How to disable powermizer?

This

Code:
#!/bin/sh

while true; do
    
    powerstate=`cat /proc/acpi/ac_adapter/AC/state | awk '{print $2}'`
    
    if [ $powerstate = "on-line"  ]; then
       nvidia-settings -q all > /dev/null
    fi
    sleep 25;
done
should be distribution independent, and by removing the powerstate, if and fi line it should keep powermizer on the highest level, independent of the power state of the notebook.

Another possibility would be to use the module parameters, that'd be the more clean solution. However, it is not as flexible as the solution posted above.

Fuchs
NvFuchs is offline   Reply With Quote
Old 08-21-08, 10:07 AM   #6
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: How to disable powermizer?

well the script assumes that "nvidia-settings -q all" will actually change the clocks to maximum ones. On my machine no matter what I do once powermizer hits level 0 it stays like that. The output is always:

Attribute 'GPUCurrentClockFreqs' (rob4300:0.0): 169,100.

(instead of 400,400)

Any official way how to turn it off?
queen6 is offline   Reply With Quote
Old 08-21-08, 02:31 PM   #7
kernelOfTruth
Gentoo Linux addict
 
Join Date: Nov 2007
Location: Vienna, Austria; Germany; hello world :)
Posts: 202
Default Re: How to disable powermizer?

use the google, luke !

https://bugs.launchpad.net/ubuntu/+s...24/+bug/164589
http://ubuntuforums.org/showpost.php...6&postcount=57
http://ubuntuforums.org/showthread.php?t=855400

Quote:

I've found this thread in NVNews.net forums:
http://www.nvnews.net/vbulletin/showthread.php?t=96673

From the thread:
"Did you already try to set the mysterious PerfLevelSrc option?
/etc/modprobe.d/options:
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

It's never been explained by nvidia what it does, but it's evident that it helps some people (including me) to avoid flickering and XID errors.
It seems to disable adjustment of clock frequencies and helped in my case to avoid the flickering on a 7900 Go GS (Dell 9400). Of course the GPU gets hotter without clocking down so use it with care."

From another user:
"options nvidia NVreg_DeviceFileMode=432 NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=27 NVreg_ModifyDeviceFiles=1 NVreg_SoftEDIDs=0 NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"

And specifically for Ubuntu users:
"Anyway, so in ubuntu you'd have to add this:
Code:

options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"

in /etc/modprobe.d/nvidia-kernel-nkc
Mobile is probably not needed but I like having it to check that the arguments actually worked.

Finally I can use my card! Thanks to everyone involved."

I'm currently trying this out. Maybe someone is interested, so this is why I share these comments here.
Quote:
Adding the "options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"" line lets it know its a mobile card - if you look at the line closely, you can see its setting the NVreg_Mobile nVidia option to '1' or 'True'. This is what fixed it for me - without this, your system doesn't know it is working with a mobile card - the only cards with Powermizer, therefor the only cards that the PerfLevelSrc options apply to...
(did this work for you ?)
__________________
2.6.30-rc3-zen0+ w. compcache, reiser4 + ccreg40 (lzo-compression + checksumming)
gcc version 4.4.0-pre9999 built 20090425 (prerelease) rev. 146764 (Gentoo SVN)
gcc version 4.4.0 (Gentoo Hardened 4.4.0-r1, espf-0.2.1)
Ubuntu Jaunty/9.04 x86_64 Dell XPS M1330
kernelOfTruth is offline   Reply With Quote
Old 08-21-08, 04:57 PM   #8
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: How to disable powermizer?

I wouldn't come here seeking for help if I wouldn't google and try every dirty trick first my master

Honestly I'm looking for official, nvidia way to disable this feature.
queen6 is offline   Reply With Quote

Old 08-21-08, 05:30 PM   #9
tier
Registered User
 
Join Date: Sep 2007
Posts: 118
Default Re: How to disable powermizer?

iirc NVreg_Mobile just determined the vendor or something like that..
tier is offline   Reply With Quote
Old 08-22-08, 05:32 PM   #10
dxx
Registered User
 
Join Date: Nov 2007
Posts: 490
Default Re: How to disable powermizer?

Hang on, 169MHz / 100MHz - is that a 440MX you're packing there? I vaguely recall my old laptop having very similar speeds.
dxx is offline   Reply With Quote
Old 08-26-08, 04:25 AM   #11
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: How to disable powermizer?

Quote:
Originally Posted by dxx View Post
Hang on, 169MHz / 100MHz - is that a 440MX you're packing there? I vaguely recall my old laptop having very similar speeds.
Code:
lspci:
01:00.0 VGA compatible controller: nVidia Corporation Device 042d (rev a1)

from X log:
(II) NVIDIA(0): NVIDIA GPU Quadro FX 360M (G86GL) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 60.86.47.00.02
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on Quadro FX 360M at PCI:1:0:0:
I bet 440MX would work much better ^^


as long as the card has 400/400 settings I've got 60+ fps
once it switches itself to 169/100 (few sec after you start X) I've got 0.5 fps. Try to do some work with such framerate.
queen6 is offline   Reply With Quote
Old 08-29-08, 05:31 AM   #12
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: How to disable powermizer?

bump.

Can I please have an official nVidia replay?
queen6 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 Video Cards -- Disable Open GL on single? amites NVIDIA Linux 5 05-30-12 03:51 PM
Powermizer problem, nvidia 9500m gs ubuntu backtoback NVIDIA Linux 3 05-25-12 12:13 PM
Problem with powermizer, nvidia 9500m gs backtoback NVIDIA GeForce 7, 8, And 9 Series 0 05-18-12 02:10 PM
Disable Kernel Messages? xniper NVIDIA Linux 2 08-12-02 01:57 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 04:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.