Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-24-08, 04:06 PM   #1
robotangel
Registered User
 
Join Date: Aug 2008
Posts: 6
Default World of Warcraft on Arch 64 (Dual TMU)

Hello,

I'm having a problem when I try to run World of Warcraft on my Arch Linux x86_64 box. The problem seems completly usual for this distribution (I googled a bit through the web and many others seemed to have this problem too, mostly people using Arch Linux - the other ones just had forgotten to install the 32bit librarys through their package management ;-) ).

First of all: It's World of Warcraft which says I should insert a 3d-card with "Dual-TMU"-Support. Well, I think my 8600 should have this .

I think it has something to do with the nvidia installer and Arch's directory scheme (/usr/lib for 32bit librarys and /usr/lib64 for 64bit), this already made some problems when I tried to compile amarok 2 by myself. When I googled around, some people told to use LD_PRELOAD to load the correct nvidia-libraries, I tried it, but it didn't work (well, I don't know much about all this library stuff so I'm pretty sure it's just my fault, would be very nice if someone could give me the correct command line [usually WoW is started via "wine Wow.exe -opengl"] ).

Well, that's all I can say, nvidia-bug-report is attached of course (it seemed to have some minor problems [just a warning] during installation, the rest of the system is working just fine and accelerated [well, just fine as long as KDE4 can work just fine with 8000er chips ].

Thank you very much in advance and I hope I'll get an answer soon.

Bye

PS: I've never installed any nvidia drivers through my package management so I'm sure that's not the problem.
I use the latest beta drivers btw, so you don't have to look into the report for this information
Attached Files
File Type: gz nvidia-bug-report.log.gz (27.1 KB, 110 views)
robotangel is offline   Reply With Quote
Old 08-25-08, 12:07 AM   #2
memeyou
Registered User
 
Join Date: May 2008
Posts: 74
Default Re: World of Warcraft on Arch 64 (Dual TMU)

results from "dual tmu" wine nvidia on google give me...

Quote:
Originally Posted by mooninite View Post
I found that the issue was the 32-bit libraries are not being linked correctly.

I'm having to put the nVidia libraries in LD_PRELOAD before I run "wine wow -opengl".

Works now on Wine 0.9.41 and nVidia 100.14.11 but I'm not sure why they are not linked. I've run ldconfig and prelink without any success... ldd reports that wine is linked to the nvidia libs. *scratches head*

EDIT: Removing the 32-bit "mesa-libGL" package took care of the library problem... This doesn't sit with me well. Unless anyone has any ideas, I don't have any more time to investigate this.
memeyou is offline   Reply With Quote
Old 08-25-08, 12:20 AM   #3
memeyou
Registered User
 
Join Date: May 2008
Posts: 74
Default Re: World of Warcraft on Arch 64 (Dual TMU)

and oddly enough an arch linux user posted in the fedora forums

Quote:
Originally Posted by jazz452
I just installed lib32 utils in arch 64 bit and works fine so make sure you install the 32bit nvidia files im sure this is the problem * yum install xorg-x11-drv-nvidia-libs.i386* and any dependencies
memeyou is offline   Reply With Quote
Old 08-25-08, 07:54 AM   #4
robotangel
Registered User
 
Join Date: Aug 2008
Posts: 6
Default Re: World of Warcraft on Arch 64 (Dual TMU)

Hi there,

first of all: thank you for your reply

I found the same solution via Google, just didn't read this post right or something (because I found it, too). Removing the lib32 mesa librarys really solved the problem. It seems I need to build a NVidia package instead of using the nvidia-installer (because wine depends on lib32-mesa) or edit the wine PKGBUILD not to depend on lib32-mesa anymore. Because I used the nvidia-installer (beta isnt available afaik via the repos) there are no addidtional lib32 librarys I had to install, of course.

Anyway, thanks, it works now.

Bye
robotangel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony World Photography Awards 2013 Competition With a 3D Category News Archived News Items 0 06-02-12 03:00 AM
Level Cap: World of Warcraft Subscribers Hold Steady News Archived News Items 0 05-10-12 05:40 AM

All times are GMT -5. The time now is 06:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.