Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-08-07, 10:47 AM   #1
runlinux
Registered User
 
Join Date: Jan 2007
Posts: 7
Default How to disable Full GPU Scaling on X startup

With my AL1916W, i had issues getting my native resolution set correctly, but now i have another issue. Every time X starts, everything on the screen is kinda blurry. when i start the NVIDIA X Server Settings, it becomes crisp and clear. when i enable Force Full GPU Scaling, the screen becomes blurry again. how do i go about fixing this?

here is the device section of my xorg.conf

Code:
Section "Device"
	Identifier	"nVidia Corporation G80 [GeForce 8800 GTS]"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Option "ExactModeTimingsDVI"
	Option "ModeValidation" "NoDFPNativeResolutionCheck"
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (35.7 KB, 173 views)
runlinux is offline   Reply With Quote
Old 06-08-07, 11:07 AM   #2
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: How to disable Full GPU Scaling on X startup

Quote:
Originally Posted by runlinux
With my AL1916W, i had issues getting my native resolution set correctly
I had the same display and had to set the modeline manually, this is a problem with the specific display since it doesn't give the correct info through edit.

Unfortunately since I changed display I haven't kept the xorg.conf file for that display, but I never had any problems with 'blurry' display.
gbil is offline   Reply With Quote
Old 06-08-07, 11:58 AM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: How to disable Full GPU Scaling on X startup

See "FlatPanelProperties" in Appendix D of the README
AaronP is offline   Reply With Quote
Old 06-08-07, 08:55 PM   #4
runlinux
Registered User
 
Join Date: Jan 2007
Posts: 7
Default Re: How to disable Full GPU Scaling on X startup

Thank you very much!

Option "FlatPanelProperties" "Scaling = Native"

that fixed it for me.
runlinux is offline   Reply With Quote
Old 10-20-07, 12:51 PM   #5
felipe1982
Registered User
 
Join Date: Jul 2007
Posts: 9
Default Re: How to disable Full GPU Scaling on X startup

Quote:
Originally Posted by runlinux
Thank you very much!

Option "FlatPanelProperties" "Scaling = Native"

that fixed it for me.
"where" in my xorg.conf do I put this? In Device?
felipe1982 is offline   Reply With Quote
Old 01-20-08, 10:55 AM   #6
bradmontgomery
Registered User
 
Join Date: Jan 2008
Location: Memphis, TN
Posts: 1
Default Re: How to disable Full GPU Scaling on X startup

I've got a 19" Rosewill Monitor (Model R912E) and an Geforce 8600GT, and I had the dreaded, floating "input not supported" message, though my xorg.conf had correct resolution and refresh rates.

Turning off the "Full GPU Scaling" option fixed the problem for me.
So, thanks to runlinux's post for finding how to disable this by default!
The pertinent part of my xorg.conf is as follows:

Quote:
Section "Monitor"
Identifier "Failsafe Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 64.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection

Section "Device"
Identifier "Failsafe Device"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce 8 Series"
Screen 0
Option "FlatPanelProperties" "Scaling = Native"
EndSection
bradmontgomery is offline   Reply With Quote
Old 09-10-08, 10:15 PM   #7
bigadel
Registered User
 
Join Date: Sep 2008
Posts: 1
Default Re: How to disable Full GPU Scaling on X startup

Hi all !

I have a dual screen configuration with a normal flat panel plugged on the first DVI out of my GeForce 8800 GTS and an DVI to SDI adaptator plugged on the second output.
The converter need a 720x576 50Hz output resolution. I configured my xorg to do so.
But when the Full GPU Scalling is enabled, then I didn't get any image trough the interface.
So, I need to start nvidia-settings and then unchecked the corresponding box (Full GPU scalling) sothat the image come back.

Here is my xorg.conf... I don't get why the hell nvidia-settings always put Full GPU Scalling ON.


Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Thu Jun  5 09:27:12 UTC 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Thu Feb 14 18:13:41 PST 2008
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard" "CoreKeyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "oss"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "NUL TV-2003"
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 80.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS 512"
    Option         "ExactModTimingsDVI"
    Option         "ModeValidation" "NoDFPNativeResolutionCheck"
#    Option         "FlatPanelProperties" "Scaling = Native" 
    Option         "FlatPanelProperties" "Scaling = DFP"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinViewOrientation" "Clone"
    Option         "SecondMonitorHorizSync" "30-50"
    Option         "SecondMonitorVertRefresh" "50"
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: 1024x768 +0+0, DFP: 720x576_50 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Thank you a lot !!!!
bigadel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPU Scaling Enverex NVIDIA Linux 13 06-27-12 10:06 AM
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 08:18 AM
Choosing The Right GPU To Take Adobe Workflows To The Max News Archived News Items 0 05-29-12 06:40 PM
GPU Tech Conference Off to a Fast Start in San Jose News Archived News Items 0 05-14-12 06:00 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 02:50 PM

All times are GMT -5. The time now is 11:50 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.