Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-03-08, 08:24 PM   #1
zetaexmachina
Registered User
 
Join Date: Sep 2008
Posts: 4
Default even VIM runs slowly with KDE 4.1/NVIDIA

I never thought the day would come. VIM runs slow on my current system:

2.5ghz dual core
nvidia quadro FX 570M
2GB memory
KDE4.1.1 / Kubuntu

By slow I mainly mean slow scrolling, and not nearly as smooth as my pentium II downstairs. This is particularly noticeable when doing vsplit.

For those interested in reproducing the result, you can try running the following as non-sudo so you don't screw things up, but just to see what I mean:

1. vim /etc/X11/xorg.conf
2. type ":vsplit /etc/X11/xorg.conf"
3. use "ctrl-w-w" to hop between the split views
4. up/down arrow keys to scroll up and down to see what I mean
5. type ":q!" to quit

What's even weirder is that this only occurs during vsplit (vertical split), but not split (which defaults to horizontal split). Anyone?



zetaexmachina
zetaexmachina is offline   Reply With Quote
Old 09-04-08, 04:00 AM   #2
RazZziel
Registered User
 
Join Date: Aug 2008
Posts: 15
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

Try the temporal solutions propposed here, it works fine for me right now with latest .70 driver and no special tricks (with an uptime of only 20 minutes)
RazZziel is offline   Reply With Quote
Old 09-04-08, 04:14 AM   #3
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

@zetaexmachina: do you use Xrender for graphical effects?
For me console is slow when using Xrender, switching to openGL or disabling effects resolves this problem.
Also apply tweaks included in sticky post with newest beta drivers.
kriko is offline   Reply With Quote
Old 09-04-08, 10:46 PM   #4
zetaexmachina
Registered User
 
Join Date: Sep 2008
Posts: 4
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

How do I switch konsole to use Xrender as opposed to opengl?
zetaexmachina is offline   Reply With Quote
Old 09-04-08, 11:09 PM   #5
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

In systemsettings->Desktop->Effects/Advanced->Compositing type you can switch between OpenGL and XRender.
ledoc is offline   Reply With Quote
Old 09-05-08, 07:43 AM   #6
zetaexmachina
Registered User
 
Join Date: Sep 2008
Posts: 4
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

I'm not even using any desktop effects. Would turning it on actually make it faster? O_o
zetaexmachina is offline   Reply With Quote
Old 09-05-08, 07:56 AM   #7
Bearclaw
Guest
 
Posts: n/a
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

Wait... So Bigman runs slow? Not possible. Try rebooting him.
  Reply With Quote
Old 09-05-08, 09:43 PM   #8
zetaexmachina
Registered User
 
Join Date: Sep 2008
Posts: 4
Default Re: even VIM runs slowly with KDE 4.1/NVIDIA

What exactly is bigman?
zetaexmachina is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.