Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-09-08, 03:30 AM   #1
danierrr
Registered User
 
Join Date: Sep 2008
Posts: 5
Unhappy X will not start with >nvidia-drivers-173.08

Hi,

I'd like to file a bug report.

Description: Upon upgrading to *any* nvidia-drivers package above
173.08 (this includes 177.70, 173.14.12, 173.14.09, 173.14.05), X will
not start, instead giving me this backtrace:

"Backtrace:
0: X(xf86SigHandler+0x65) [0x4a0475]
1: /lib/libc.so.6 [0x7f52c479a170]
2: /usr/lib/tls/libnvidia-tls.so.1 [0x7f52c692b67e]

Fatal server error:
Caught signal 11. Server aborting"

The version of xorg-server I use was 1.4.2; I tried upgrading to 1.5.0
to see if that worked any better, and it didn't.

The Xorg.0.log file, xorg.conf I use, and nvidia-bug-report.log file
are attached.

Let me know if I can provide any further information! I'm running a
Gentoo Linux system, ~amd64, otherwise completely up-to-date. No weird USE flags or ricer config settings. The system itself is an Athlon 64 3300+ with 1GB of RAM, and an nVidia
GeForce 6200AX AGP8x video card [NV44a, if I'm not mistaken].

Daniel
Attached Files
File Type: log Xorg.0.log (14.3 KB, 108 views)
File Type: txt xorg.conf.txt (2.4 KB, 106 views)
File Type: bz2 nvidia-bug-report.log.tar.bz2 (26.1 KB, 114 views)
danierrr is offline   Reply With Quote
Old 09-09-08, 05:29 PM   #2
corrosivemisery
Registered User
 
Join Date: Jun 2008
Posts: 2
Default Re: X will not start with >nvidia-drivers-173.08

Just to add to this -

I'm getting this too, exact same error only with 177.70 on my Quadro NVS 140M which is supported in 177.67 (according to the supported products list).

Later today I plan to check it out on my 8500 GT desktop chipset, I'll post back on that.

-Corr
corrosivemisery is offline   Reply With Quote
Old 09-12-08, 09:55 PM   #3
danierrr
Registered User
 
Join Date: Sep 2008
Posts: 5
Cool Re: X will not start with >nvidia-drivers-173.08

Any ideas, anyone? What did you find out, corrosivemisery?

Would playing around with libc (version changes or USE flags) help at all? Also, is the libnvidia-tls part of nvidia-drivers, or part of some other TLS program (like GNUtls?)

I'd love to play around with my PC and get to the bottom of this, if only I knew what a Signal 11 / 0x65 meant!
danierrr is offline   Reply With Quote
Old 09-13-08, 12:42 AM   #4
corrosivemisery
Registered User
 
Join Date: Jun 2008
Posts: 2
Default Re: X will not start with >nvidia-drivers-173.08

177.70 works on my desktop (Geforce 8500 GT) but not the Quadro mobile. I was able to get the 177.67 to work on the Quadro mobile chip.

SO, I'd try 177.67...173.x is legacy. No idea why 177.70 doesn't work for the Quadro and 177.67 does, so I am venturing a guess that it's a bug. I also noticed that Nvidia hasn't created a page on the driver search for 177.70 so perhaps they are aware it's broken.

Aside from that....what was the last version that worked for you? I honestly can't tell what driver supports your chip from the supported products list.
corrosivemisery is offline   Reply With Quote
Old 09-13-08, 02:58 AM   #5
danierrr
Registered User
 
Join Date: Sep 2008
Posts: 5
Thumbs down Re: X will not start with >nvidia-drivers-173.08

OK, I went ahead and tried the only three drivers I hadn't (177.68, 177.67, 177.13) and none of them worked. The backtrace was slightly different... offset was 0x6a instead of 0x65... dunno how significant that is.

So, in summary, EVERY DRIVER >173.08 doesn't work and EVERY DRIVER <=173.08 works Hopefully someone can get to the bottom of this -- Corr says 173.x is legacy already!

GeForce 6200AX should work for all these drivers.

ALSO, Gentoo Linux applies patches to the drivers, although I have no idea which they are or what they do.

Attached are new Xorg.0.logs for each of the three failed driver checks, and an nvidia-big-report.log file after all three failures. Enjoy!
Attached Files
File Type: bz2 nvidia-bug-report.log.tar.bz2 (24.8 KB, 111 views)
File Type: log Xorg.0.177.13.log (20.7 KB, 113 views)
File Type: log Xorg.0.177.67.log (20.7 KB, 97 views)
File Type: log Xorg.0.177.68.log (20.7 KB, 107 views)
danierrr is offline   Reply With Quote
Old 09-27-08, 10:11 PM   #6
danierrr
Registered User
 
Join Date: Sep 2008
Posts: 5
Default Re: X will not start with >nvidia-drivers-173.08

bump -- anyone have any ideas? I was able to bisect the problem to between 173.08 and 173.14.05, which is the most I can do.

Xorgserver 1.5.0 is out and I cannot upgrade until the newer drivers work. Being doomed to 173.08 for the rest of my computer's life would really, really suck

Let me know if I can be of further assistance!
danierrr is offline   Reply With Quote
Old 09-28-08, 12:41 PM   #7
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: X will not start with >nvidia-drivers-173.08

Try this

sh NVIDIA-Linux-x86-177.78-pkg0.run --force-tls=new

;-)
artem is offline   Reply With Quote
Old 09-28-08, 01:47 PM   #8
danierrr
Registered User
 
Join Date: Sep 2008
Posts: 5
Default Re: X will not start with >nvidia-drivers-173.08

artem,

Your suggestion worked like a charm!! Thank you so much!!

I will file a bug with Gentoo to get this beta driver into Portage, and allow setting that --force-tls=new flag.

Please close this thread as RESOLVED FIXED
danierrr is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok pbc2520 NVIDIA Linux 7 10-01-12 02:32 PM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 11:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.