Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-09-08, 09:21 PM   #1
Silverbak
Registered User
 
Join Date: Jun 2007
Posts: 47
Default Debian (Lenny) Xen Problem, Require a Workaround

Hi,

I've got a machine with Debian (Lenny) and am unable to install the driver from NVIDIA.com due to previously discussed conflict between the Xen guest options in the stock Lenny kernel and the NVIDIA installer.

I've been using the VESA driver for weeks as it's faster than the NV driver (!!) on my 8800GT and really need to get full acceleration working again, preferably with 177.70.

Could any kind soul share their workaround?
--
Silverbak
Silverbak is offline   Reply With Quote
Old 09-09-08, 11:00 PM   #2
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Debian (Lenny) Xen Problem, Require a Workaround

If CC=gcc-4.1 IGNORE_XEN_PRESENCE=1 doesn't work, Debian's xen.patch for 173.14.09 may still apply. Otherwise you'll have to do something about the kernel - use their .config from 2.6.25 to build something XEN-free, upgrade to unstable (sid) or try installing 2.6.26 from unstable, which does away with the XEN configuration.
logan is offline   Reply With Quote
Old 09-10-08, 05:41 AM   #3
Silverbak
Registered User
 
Join Date: Jun 2007
Posts: 47
Default Re: Debian (Lenny) Xen Problem, Require a Workaround

Thanks for the tips logan. Lenny is already using 2.6.26 and that still uses the XEN configuration. I've read various bug reports in the Debian BTS however they all indicate that the XEN configuration options are going to stay.

I've exported the CC= switch however it seems that it wants me to provide configured kernel sources, which may take a little while to compile and I'll see if I can convince the driver to install with those sources, all the while the stock kernel is installed
Silverbak is offline   Reply With Quote
Old 09-10-08, 09:02 AM   #4
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Debian (Lenny) Xen Problem, Require a Workaround

I don't see anything:
Quote:
-(~) grep XEN /boot/config-2.6.26-1-686
CONFIG_NETXEN_NIC=m
-(~)
logan is offline   Reply With Quote
Old 09-10-08, 10:08 AM   #5
Silverbak
Registered User
 
Join Date: Jun 2007
Posts: 47
Default Re: Debian (Lenny) Xen Problem, Require a Workaround

Well blow it it worked straight off the bat!

I thought there was still an issue here but clearly it's problem solved!

I guess this thread can be closed
Silverbak is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Riva TNT 2 - Debian (Woody) chipset problem sindra NVIDIA Linux 4 08-26-02 03:21 AM

All times are GMT -5. The time now is 07:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.