Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-14-08, 10:24 PM   #1
jsumners
Registered User
 
Join Date: Sep 2008
Location: Fairburn, GA
Posts: 5
Default No sound in X when connected via HDMI

First, a description of my configuration:

I have a C-Media Electronics Inc CM8738 sound card. This sound card is connected to my television via the front channels output. In addition, the SPDIF/out is connected to my GeForce 8500GT. My GeForce 8500GT is then connected to my television via an HDMI cable.

Now for the problem:

Prior to a recent upgrade, sound was being delivered to my television via the analog out on my sound card. I am sure I was using a 169.xx version of the nVidia drivers before the upgrade. So there was no way for audio to be delivered via the HDMI cable. I was unaware at the time I upgraded that this feature had been implemented in the 173.xx drivers[1]. Upon discovering this, I un-muted the IEC958 device on my sound card via alsamixer. This, however, did not give me sound.

As it stands, I am able to play sound on the console before starting X. E.G.:
Code:
mplayer -ao alsa:device=default /usr/share/sounds/alsa/Front_Center.wav
When I start X and try to execute the same command I get no sound. My default sound device is routed as so:
Code:
ctl.!default {
        type hw
        card 0
}

pcm.!default{
        type plug
        slave {
                pcm "spdif"
                rate 48000
                format S16_LE
        }
}
I have tried driver version 173.14 (as packaged by Arch Linux), 177.67, and 177.70 (the latter two being downloaded directly from nVidia). I cannot revert to the 169.xx drivers because the proc_root_driver interface has been removed from the 2.6.26 kernel, and the 169.xx drivers rely on it.

I do not want to use a VGA connection to "solve" this problem. The picture is blurry, and the picture shifts to the left or right when X is initializing. That is, if I connect via VGA I cannot see the whole picture because the display is not detecting properly.

I need a solution to this audio of HDMI problem. Please, I have run out of ideas on what to try.


[1] -- http://www.nvnews.net/vbulletin/show...4&postcount=39

Note: please ignore the errors about "mythlogin" in the bug report log. They are completely irrelevant to the problem, and are a result of a programming error I made earlier today.
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.5 KB, 232 views)

Last edited by jsumners; 09-14-08 at 10:41 PM. Reason: Attaching bug report log
jsumners is offline   Reply With Quote
Old 09-15-08, 04:58 PM   #2
jsumners
Registered User
 
Join Date: Sep 2008
Location: Fairburn, GA
Posts: 5
Default Re: No sound in X when connected via HDMI

I have "resolved" this problem by using the instructions at
http://www.nvnews.net/vbulletin/show...18&postcount=6
and
http://www.nvnews.net/vbulletin/show...26&postcount=1

However, I do not see this as a solution. There needs to be an option that allows us to disable audio over HDMI. Blindly assuming that it will work, even if the system is setup for it to work (as mine is!), is unacceptable.
jsumners is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Latest Tech And Game Headlines 0 06-28-12 05:40 PM
Blu-ray 3D Movie Playback With PC on a 3D HDTV Using HDMI 1.4 News Latest Tech And Game Headlines 0 05-16-12 03:30 AM
HDMI audio ELD weirdness RockHound NVIDIA Linux 0 05-11-12 03:45 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 01:50 AM

All times are GMT -5. The time now is 02:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.