Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-15-08, 01:57 PM   #1
bram
Registered User
 
Join Date: Nov 2003
Posts: 17
Default Disabling sound over HDMI ?

Hello,

When using 169.xxx my TV could display a HDMI vid feed, and analog audio feed.

When going to 173.xxx and 177.xxx I no longer get the analog sound from my TV.
This is because with the 17x.xxx series, audio over HDMI has been implemented.
However, I rely on analog audio.

Is there any method available to disable the audio over HDMI in the 17x.xxx drivers?

Note that my TV plays the audio if:
* I do not start X
* I unplug the DVI cable
* I switch TV inputs.... I will hear sound for 0.5 seconds, after which it mutes again

It is nice nvidia implements new features, but audio-over-HDMI hurts existing users that rely on analog sound.

Thank you,

Bram
bram is offline   Reply With Quote
Old 09-15-08, 02:33 PM   #2
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Disabling sound over HDMI ?

I believe you need to adjust the settings in your TV.

Include the usual bug report or this post will most likely be ignored. Per your previous posts you use a DVI->HDMI cable. This is information you need to include here.

Since nVidia has not released any documentation about audio over HDMI, none of us will be able to really help.
mooninite is offline   Reply With Quote
Old 09-15-08, 02:59 PM   #3
jsumners
Registered User
 
Join Date: Sep 2008
Location: Fairburn, GA
Posts: 5
Default Re: Disabling sound over HDMI ?

It is especially bad when they don't give us any way to configure it or even mention it being implemented. I am having the same problem[1] and it looks like the DVI->HDMI cable I bought at lunch isn't going to fix it[2].

[1] -- http://www.nvnews.net/vbulletin/showthread.php?t=119420
[2] -- http://www.nvnews.net/vbulletin/showthread.php?t=118691
jsumners is offline   Reply With Quote
Old 09-15-08, 03:23 PM   #4
bram
Registered User
 
Join Date: Nov 2003
Posts: 17
Default Re: Disabling sound over HDMI ? SOLVED

Quote:
Originally Posted by mooninite View Post
I believe you need to adjust the settings in your TV.

Include the usual bug report or this post will most likely be ignored. Per your previous posts you use a DVI->HDMI cable. This is information you need to include here.

Since nVidia has not released any documentation about audio over HDMI, none of us will be able to really help.
My TV, Sony XBR-4 has no setting for this.

And there are people who are able to help out, ankh just solved it for me:
http://www.nvnews.net/vbulletin/show...18&postcount=6

Sound-over-HDMI is disabled if you do
"UseEDID" "False"

This, however, has nasty side effects, so the best course of action (until nvidia implements a driver option) is to use "CustomEDID".
In short, you need to remove the extended block from the EDID you get from your TV.

Bram
bram is offline   Reply With Quote
Old 09-15-08, 03:35 PM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Disabling sound over HDMI ? SOLVED

Quote:
Originally Posted by bram View Post
My TV, Sony XBR-4 has no setting for this.

And there are people who are able to help out, ankh just solved it for me:
http://www.nvnews.net/vbulletin/show...18&postcount=6

Sound-over-HDMI is disabled if you do
"UseEDID" "False"

This, however, has nasty side effects, so the best course of action (until nvidia implements a driver option) is to use "CustomEDID".
In short, you need to remove the extended block from the EDID you get from your TV.

Bram
OK, but wouldn't you think there should be an

Code:
Option    "HDMIAudio" "disable"
flag in your xorg.conf file? Or a checkbox in nvidia-settings? We don't know that though. Glad you found a workaround, but I sure hope there are less strenuous means of stopping audio over HDMI for less techno-savy users.
mooninite is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 05:40 PM
HDMI audio ELD weirdness RockHound NVIDIA Linux 0 05-11-12 03:45 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 01:50 AM
nForce - BattleField 1942 demo - Sound cuts out rtz General Hardware 3 09-05-02 12:48 PM

All times are GMT -5. The time now is 08:38 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.