Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-08, 10:01 PM   #1
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Corruption in 177.78 BETA driver

I'm seeing image corruption in my buttons and other screen features running KDE 4.1. I have seen in the linux forum that this might be an issue with the damage events occuring before the buffer is filled and ready. Is anyone else seeing this and NVIDIA, are you working on fixing this before releasing the next driver?

Thanks!
Rusty Nejdl
rnejdl is offline   Reply With Quote
Old 10-01-08, 10:39 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Corruption in 177.78 BETA driver

Please provide more information on what kind of corruption you're seeing, with which hardware you're seeing it and how to reproduce the problem (see http://www.nvnews.net/vbulletin/showthread.php?t=46678). Please also check the 'NVIDIA Linux' forum to see if other users reported similar problems.
zander is offline   Reply With Quote
Old 10-01-08, 09:20 PM   #3
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Corruption in 177.78 BETA driver

I've attached a bug report as well as an image showing the image corruption in the menu of my paint program. If I try to save a document and then I move my mouse over the buttons, the buttons corrupt or I get some corruption of the text in the menus. I haven't seen this in the other betas. I am running IPP=2. I've seen other reports of corruption but I cannot tell if this is exactly the same issue or something else. I'll try some more testing tonight to see what I can find.

Thanks!
Rusty Nejdl
Attached Thumbnails
Click image for larger version

Name:	image_corruption.jpg
Views:	177
Size:	101.6 KB
ID:	33384  
Attached Files
File Type: log nvidia-bug-report.log (69.1 KB, 146 views)
rnejdl is offline   Reply With Quote
Old 10-02-08, 10:05 PM   #4
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Corruption in 177.78 BETA driver

I saw some comments in the linux form and tried these settings in xorg.conf:

Option "RenderAccel" "true"
Option "UseEvents" "false"
Option "TripleBuffer" "True"
Option "DamageEvents" "True"
Option "BackingStore" "True"
Option "AllowIndirectPixmaps" "true"
Option "AddARGBGLXVisuals" "True"
Option "PixmapCacheSize" "1000000"
Option "AllowSHMPixmaps" "False"

I am no longer seeing any artifacts. I'm not sure what is going to be made default but I was running a very clean setup earlier with just:

Option "AddARGBGLXVisuals" "True"
Option "PixmapCacheSize" "3000000"
Option "AllowSHMPixmaps" "0"

So, it appears that one of those options has corrected this for me that I had not explicitly mentioned earlier.

Rusty
rnejdl is offline   Reply With Quote
Old 11-03-08, 03:30 AM   #5
marlll
Registered User
 
Join Date: Oct 2008
Posts: 2
Default Re: Corruption in 177.78 BETA driver

Hard topic


Used Cargo Container
marlll is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
304.48 Beta driver out shteve NVIDIA Windows Graphics Drivers 14 06-29-12 07:14 AM
New GeForce 304.48 Beta Driver Gets You Ready For Summer Gaming News Archived News Items 0 06-18-12 06:30 PM
NVIDIA R302.80 Beta Driver for Windows 8, New OpenGL Extensions News Archived News Items 0 06-15-12 10:30 AM
Download GeForce GTX 690 Beta Driver 301.34 Here - http://www.nvnews.net#driver MikeC Archived News Items 0 05-03-12 10:39 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM

All times are GMT -5. The time now is 01:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.