Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-04-08, 09:40 AM   #1
iro
Registered User
 
Join Date: Mar 2007
Posts: 58
Default No more black terminals after starting X!!!!

I have solved my problem with black terminals (i.e. Ctrl+Alt+F1) after X starts. All I did was to set to 0 the NVreg_UseVBios nvidia kernel module parameter. On my distro (Gentoo) I modified /etc/modprobe.d/nvidia and rebooted.

Hope this can help others who have the same problem!

EDIT: I forgot to say that I'm using 177.78 but I think the version doesn't matter

you can see if the parameter is setted correctly by cat'ing /proc/driver/nvidia/registry
iro is offline   Reply With Quote
Old 10-04-08, 10:57 AM   #2
martini
Registered User
 
Join Date: Aug 2005
Location: Munich, Germany
Posts: 31
Default Re: No more black terminals after starting X!!!!

great! this also works for me!
thanx a lot!
martini is offline   Reply With Quote
Old 10-04-08, 12:03 PM   #3
hvw59601
Registered User
 
Join Date: Oct 2004
Posts: 34
Default Re: No more black terminals after starting X!!!!

But how did you figure it out?

Hugo
hvw59601 is offline   Reply With Quote
Old 10-04-08, 12:04 PM   #4
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: No more black terminals after starting X!!!!

What does this variable do? There isn't much in nv-reg.h:
Code:
/* 
 * Option: UseVBios
 *
 * Description:
 *
 * Use Video BIOS int10 code
 *
 * Default value: 1
 */
Maybe that's all there is to say, but it doesn't mean anything to me.
logan is offline   Reply With Quote
Old 10-04-08, 12:12 PM   #5
iro
Registered User
 
Join Date: Mar 2007
Posts: 58
Default Re: No more black terminals after starting X!!!!

Quote:
Originally Posted by hvw59601 View Post
But how did you figure it out?
Did it help you?

I was playing with module parameters to enable the experimental MSI support I've read about in a recent release announcement. Since I couldn't find any info about it on the Internet I did
"modinfo nvidia" that showed me that interesting VBios option, so I simply tried and it worked
iro is offline   Reply With Quote
Old 10-04-08, 12:16 PM   #6
GiorgosKo
Registered User
 
Join Date: Aug 2008
Posts: 9
Default Re: No more black terminals after starting X!!!!

Quote:
Originally Posted by logan View Post
Maybe that's all there is to say, but it doesn't mean anything to me.
http://en.wikipedia.org/wiki/INT_10
GiorgosKo is offline   Reply With Quote
Old 10-04-08, 12:34 PM   #7
hvw59601
Registered User
 
Join Date: Oct 2004
Posts: 34
Default Re: No more black terminals after starting X!!!!

I have a different "black terminal" problem: sometime after starting X I cannot switch tty anymore because of a segfault of the v86d uvesafb companion piece: segfault: Trying to access an unsupported memory region

That happens with 173.14.12 and 96.43.07 and an GeForce 6200 AGP.

I then went back to my prior MX 4000 AGP that I just replaced but never had that failure.

I haven't tried 177.78 yet but I don't see NVreg_UseVBios in 96.43.07 that I am now running with.

Hugo
hvw59601 is offline   Reply With Quote
Old 10-04-08, 12:43 PM   #8
iro
Registered User
 
Join Date: Mar 2007
Posts: 58
Default Re: No more black terminals after starting X!!!!

That's definitely a different problem... But why do you inflict yourself the pain of having another userspace program messing around with your video device in addition to Xorg (that already does a load of ****ty things)? I think they call it masochism
iro is offline   Reply With Quote

Old 10-04-08, 04:19 PM   #9
mrkslack
Registered User
 
Join Date: Sep 2008
Posts: 5
Default Re: No more black terminals after starting X!!!!

No luck for me!
Code:
$ cat /proc/driver/nvidia/registry
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0
Mobile: 4294967295
ResmanDebugLevel: 4294967295
RmLogonRC: 1
ModifyDeviceFiles: 1
DeviceFileUID: 0
DeviceFileGID: 0
DeviceFileMode: 438
RemapLimit: 0
UpdateMemoryTypes: 4294967295
UseVBios: 0
RMEdgeIntrCheck: 1
UsePageAttributeTable: 4294967295
EnableMSI: 0
terminals remains black with 9600GT and 177.70 or 177.78
mrkslack is offline   Reply With Quote
Old 10-04-08, 05:29 PM   #10
martini
Registered User
 
Join Date: Aug 2005
Location: Munich, Germany
Posts: 31
Default Re: No more black terminals after starting X!!!!

logan:

usually the driver is setting the video mode by writing to the registers on the graphic card directly.

every graphic card also implements the int10 bios hooks (some of this interrupts are usually called if your pc is booting the first seconds with a black background) where you can e.g. set some different graphic modes by calling the interrupt 10 with some specific values in the cpu registers. this interrupt call executes a piece of code copied from the graphic card (this has nothing to do with the driver and is not part of the driver) to the main memory at boot time and sets (obviously) the correct mode.

so instead of writing the gpu registers directly by the driver, the driver just calls interrupt 10 with some specific parameters to set the mode.

therefore i think if the bios code on the graphic card is able to switch to the correct mode, the driver itself missed to write to some registers or to write the correct values.

---

edit: i just saw that this parameter switches off using the bios mode. therefore the driver code is used to set the mode instead the bios code which means that the bios code is broken.
martini is offline   Reply With Quote
Old 10-05-08, 12:02 PM   #11
hvw59601
Registered User
 
Join Date: Oct 2004
Posts: 34
Default Re: No more black terminals after starting X!!!!

Quote:
Originally Posted by iro View Post
That's definitely a different problem... But why do you inflict yourself the pain of having another userspace program messing around with your video device in addition to Xorg (that already does a load of ****ty things)? I think they call it masochism
Long story! Using the Debian Sid kernels I cannot get framebuffers with the standard vesafb, only with uvesafb. So using 'vga=791' does nothing with a Debian post 2.6.24 kernel. But when I compile the kernel from kernel.org it *does* work.

But my problem of the "black terminal" does not occur when I use my older MX4000 AGP. Figure that.

Hugo
hvw59601 is offline   Reply With Quote
Old 10-26-08, 07:03 PM   #12
mrkslack
Registered User
 
Join Date: Sep 2008
Posts: 5
Default Re: No more black terminals after starting X!!!!

Quote:
Originally Posted by hvw59601 View Post
Long story! Using the Debian Sid kernels I cannot get framebuffers with the standard vesafb, only with uvesafb.
thanks hvw59601.
I solved my black console problem: I simply recompiled the kernel replacing the vesafb with uvesafb.
Non only I solved the problem but now I can use the right resolution for my monitor because uvesafb haven't the limit of 1024x768
mrkslack is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD FX-8120 Black Edition CPU Review (with Asus M5A99X EVO) News Archived News Items 0 06-21-12 09:30 AM
Black Mesa Invites You To Look At Its Bowels News Archived News Items 1 06-12-12 02:05 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
What Happened To Black Mesa: Source? Part Two News Archived News Items 0 05-10-12 08:47 AM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM

All times are GMT -5. The time now is 07:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.