Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-09-08, 12:48 PM   #1
beardo41186
Registered User
 
Join Date: Dec 2008
Posts: 11
Default Flicker in openoffice

Hi,

I'm running the NVIDIA GeForce FX5200 on opensuse 11 with KDE 4.1 using the latest drivers provided in the opensuse 11 repo. (173.14.xx).

However, when I open openoffice, the taskbar, compiz fusion windows, and other things start to uncontrollably flicker.

Only closing the window seems to fix the problem.

Apparently, my GPU is not supported by the latest driver (177.80), so is there another way for me to fix this problem, like a patch or something?

Thanks in advance for any assistance.
beardo41186 is offline   Reply With Quote
Old 12-09-08, 03:00 PM   #2
Neuro
Registered User
 
Join Date: Aug 2008
Posts: 21
Default Re: Flicker in openoffice

The latest beta drivers of the series (180.x) fixed the issue. However, there is a problem with plasma memory leak with 180.11 so I'd advise 180.08.
Neuro is offline   Reply With Quote
Old 12-09-08, 04:35 PM   #3
beardo41186
Registered User
 
Join Date: Dec 2008
Posts: 11
Default Re: Flicker in openoffice

Do these drivers support the FX5200, because I couldn't install 177.80.

On a side note, where can I get the beta version?

Thanks for your prompt response
beardo41186 is offline   Reply With Quote
Old 12-10-08, 12:36 AM   #4
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Flicker in openoffice

I'm not seeing such flicker in Fedora 10. I'm using Gnome though. FX5200, 173.14.15 driver.
mooninite is offline   Reply With Quote
Old 12-10-08, 01:18 PM   #5
fhj52
Registered User
 
Join Date: Jan 2005
Posts: 135
Default Re: Flicker in openoffice

Quote:
Originally Posted by beardo41186 View Post
...
On a side note, where can I get the beta version?
ftp://download.nvidia.com/XFree86 and drill down to your choice of poison.
__________________
When two people meet and exchange gifts, each has one object.
When two people meet and exchange ideas, each has two ideas.
... Open Source. Just do it.

---------------------------------
System: BFG GTX260^2 graphics but has ** TERRIBLE BLINKING OS **
SuperMicro H8DCi+AMI BIOS;dual Opt'285;8GB;LSI 320-2x w/ 6xU320 Fuji' MAXs in RAID 10; 4xSATAII on LSI 3041E for backup. Multi-boot Mandriva Linux, openSUSE, WinXPx64 & Win2k-AS; Creative Audigy2-Digital audio.
Gigabyte GA-2CEWH & NVRAID are GONE ... Finally!!
fhj52 is offline   Reply With Quote
Old 12-10-08, 07:53 PM   #6
beardo41186
Registered User
 
Join Date: Dec 2008
Posts: 11
Default Re: Flicker in openoffice

I take it that v180.xx is not supported by the FX5200.

I've already tried installing 177.80, but installer said my card isn't supported.

That being said, is there any other way, any other settings I could do to make the flicker go away.

Here is my xorg.conf

Code:
# /.../
# SaX generated X11 config file
# Created on: 2008-11-16T18:38:42-0500.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "glx"
  Load         "type1"
  Load         "extmod"
  Load         "dbe"
  Load         "freetype"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  312 234
  HorizSync    30-70
  Identifier   "Monitor[0]"
  ModelName    "SAMSUNG SYNCMASTER"
  Option       "DPMS"
  Option       "PreferredMode" "1280x1024"
  VendorName   "SAM"
  VertRefresh  43-160
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1024x768" 94 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "GeForce FX 5200"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVIDIA"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
Once again, I appreciate your time and assistance. Thanks in advance
beardo41186 is offline   Reply With Quote
Old 12-10-08, 07:55 PM   #7
beardo41186
Registered User
 
Join Date: Dec 2008
Posts: 11
Default Re: Flicker in openoffice

Quote:
Originally Posted by fhj52 View Post
ftp://download.nvidia.com/XFree86 and drill down to your choice of poison.

What's the difference between *pkg0.run and *pkg1.run?

Which one do I use?


Thanks.
beardo41186 is offline   Reply With Quote
Old 12-11-08, 11:56 AM   #8
fhj52
Registered User
 
Join Date: Jan 2005
Posts: 135
Default Re: Flicker in openoffice

Quote:
Originally Posted by beardo41186 View Post
What's the difference between *pkg0.run and *pkg1.run?

Which one do I use?


Thanks.
Iterations ithink but IIRC, it can vary how the driver is applied.
Look up at the top of this NVIDIA Linux forum thread and there should be some explanations(they used to be there ...) if there is some important diff.
Use pkg2, .



(or pkg1 for 32-bit ...)
__________________
When two people meet and exchange gifts, each has one object.
When two people meet and exchange ideas, each has two ideas.
... Open Source. Just do it.

---------------------------------
System: BFG GTX260^2 graphics but has ** TERRIBLE BLINKING OS **
SuperMicro H8DCi+AMI BIOS;dual Opt'285;8GB;LSI 320-2x w/ 6xU320 Fuji' MAXs in RAID 10; 4xSATAII on LSI 3041E for backup. Multi-boot Mandriva Linux, openSUSE, WinXPx64 & Win2k-AS; Creative Audigy2-Digital audio.
Gigabyte GA-2CEWH & NVRAID are GONE ... Finally!!

Last edited by fhj52; 12-19-08 at 11:20 AM. Reason: Rosemary
fhj52 is offline   Reply With Quote

Old 12-16-08, 04:26 PM   #9
beardo41186
Registered User
 
Join Date: Dec 2008
Posts: 11
Default Re: Flicker in openoffice

Anybody have anything?

I have already tried to install 173.14.15, and the flicker still persists.

I would really like some suggestions please and thank you
beardo41186 is offline   Reply With Quote
Old 12-16-08, 06:51 PM   #10
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: Flicker in openoffice

Did you try changing your gtk theme (OO uses gtk under KDE). I
had serious problems with gtk-qt theme which is a known problem.
What theme are you using?
sambo57u is offline   Reply With Quote
Old 12-19-08, 01:12 PM   #11
fhj52
Registered User
 
Join Date: Jan 2005
Posts: 135
Default Re: Flicker in openoffice

Quote:
Originally Posted by beardo41186 View Post
Anybody have anything?

I have already tried to install 173.14.15, and the flicker still persists.

I would really like some suggestions please and thank you
IF flicker is only happening when using openOffice.org ap then the issue is most likely with it.
UNinstall it. REinstall the latest version for openSUSE 11.0.

While installing, get XFCE4.
CHECK that KDE 4.1 is not the cause by using XFCE4 as user, then if it still flickers make sure it is not some permissions issue created from openSUSE by briefly using oo.org as superuser(root).

KLDE 4.1 is buggy as all heck & is, IMO, dangerous to use. It is not suitable for an everyday DE, especially where work is being done. If you *must* have KDE, I rec' to install KDE 3.5.*(latest version) and use it.
KDE4 is surely purty ... and if all things go as normal, KDE4 should be ready for prime time sometime in 2010. Really. I wouldn't even begin to consider KDE4 as stable before 4.3. ... if you want to test KDE4 for them, by all means do, .

I don't see driver 173.14.15 for FX5200 @ 32-bit.
173.14.12 is the latest released driver for FX5200 @32-bit Linux.
BETA/other can be found here: http://www.nvidia.com/Download/Find.aspx?lang=en-us
177.67 is the last BETA for FX5200 @32-bit.

You have to build those, or at least, IMO, it is BEST if you build them. SAX is not a "great" ap ...
Build the nvidia kernel too.

Check the specifications for your monitor & make sure they are correct in the xorg.conf file.
Read /var/log/Xorg.0.log and find & eliminate the causes of all warnings and errors in the xorg.conf file. Since SAXSUKS, there will be quite a few, however none of them s/b cause of "flickering" of display unless SAX got the EDID & it is wrong(EDID from monitors are sometimes wrong = manufacturers lie, ).

If there is one application that is causing problems, don't initially think it is the driver to blame. If everything else works as expected, IMO, it is probably a local application at fault.

In this case, if I were a betting man: compiz fusion.
__________________
When two people meet and exchange gifts, each has one object.
When two people meet and exchange ideas, each has two ideas.
... Open Source. Just do it.

---------------------------------
System: BFG GTX260^2 graphics but has ** TERRIBLE BLINKING OS **
SuperMicro H8DCi+AMI BIOS;dual Opt'285;8GB;LSI 320-2x w/ 6xU320 Fuji' MAXs in RAID 10; 4xSATAII on LSI 3041E for backup. Multi-boot Mandriva Linux, openSUSE, WinXPx64 & Win2k-AS; Creative Audigy2-Digital audio.
Gigabyte GA-2CEWH & NVRAID are GONE ... Finally!!
fhj52 is offline   Reply With Quote
Old 12-20-08, 09:21 PM   #12
beardo41186
Registered User
 
Join Date: Dec 2008
Posts: 11
Default Re: Flicker in openoffice

I initially thought it was office too, because the problem only occurs with oo writer, not calc, or the other programs, however uninstalling and reinstalling did not fix the problem.

I posted on the suse forums, and they directed me here.

I'm fairly sure 173.14.15 is the latest beta version of the driver that supports the FX5200, because the supported devices for anything later start with the GeForce 6200.

Disabling compiz fusion does NOT fix the problem, the kde 4 taskbar still flickers when oo is opened.

However, a suggestion to change the gtk theme seems to have reduced the flickering somewhat. Currently I am using the precompiled driver from the repo, I'll take a whack at 173.14.15 again, and see if that makes a difference.


Thanks for your assistance
beardo41186 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.