Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-15-08, 07:17 AM   #1
Kynde
Registered User
 
Join Date: Oct 2008
Posts: 5
Default UseEDID FALSE with NoDFPNativeResolutionCheck

I keep trying to get a 1920x1200 DFP mode running without using EDID information.

It works fine with the dvi cable:
Option "ConnectedMonitor" "DFP-0"
Option "UseEDID" "TRUE"

It even works with the vga cable and a custom mode line (according to the monitor's EDID information) :
Modeline "1920x1200_ml" 154.0 1920 1968 2000 2080 1200 1202 1208 1235 -hsync +vsync
...
Option "UseEDID" "FALSE"
Option "ConnectedMonitor" "CRT-1"
Option "ModeValidation" "NoMaxPClkCheck, NoHorizSyncCheck, NoVertRefreshCheck"

But with the dvi cable and the same modeline :
Option "UseEDID" "FALSE"
Option "ConnectedMonitor" "DFP-0"
Option "ModeValidation" "NoDFPNativeResolutionCheck"

I get the following:

(II) NVIDIA(0): Native backend timings for DFP-0:
(II) NVIDIA(0): 640 x 480 @ 60 Hz
(II) NVIDIA(0): Pixel Clock : 25.175 MHz
(II) NVIDIA(0): HRes, HSyncStart : 640, 656
(II) NVIDIA(0): HSyncEnd, HTotal : 752, 800
(II) NVIDIA(0): VRes, VSyncStart : 480, 490
(II) NVIDIA(0): VSyncEnd, VTotal : 492, 525
(II) NVIDIA(0): H/V Polarity : -/-
(II) NVIDIA(0):
(II) NVIDIA(0): Validating Mode "1920x1200_ml":
(II) NVIDIA(0): 1920 x 1200 @ 60 Hz
(II) NVIDIA(0): Mode Source: X Configuration file ModeLine
(II) NVIDIA(0): Pixel Clock : 154.00 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1920, 1968
(II) NVIDIA(0): HSyncEnd, HTotal : 2000, 2080
(II) NVIDIA(0): VRes, VSyncStart : 1200, 1202
(II) NVIDIA(0): VSyncEnd, VTotal : 1208, 1235
(II) NVIDIA(0): H/V Polarity : -/+
(WW) NVIDIA(0): Unable to use mode "1920x1200_ml" for DFP-0; cannot
(WW) NVIDIA(0): compute backend DFP timings (mode is larger than
(WW) NVIDIA(0): native backend 640 x 480).
(WW) NVIDIA(0): Mode is rejected: Unable to determine BestFit backend DFP
(WW) NVIDIA(0): timings.


I've even tried with:
Option "ModeValidation" "NoMaxPClkCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoWidthAlignmentCheck, NoVirtualSizeCheck, NoVesaModes, NoEdidModes, NoTotalSizeCheck"

But somehow the native resolution is 640x480 and it won't get past it. And only the 640x480 modes are in the modelist and that's it. Am I missing an option or something?

I will gladly post the xorg.conf whole and whatever further information is necesasry.

Why you may ask? Well, I need to get the system up and running regardless of the monitor being powered or not.

Drivers are 177.80 and the card is a GeForce 7300 SE, but same thing with 8400 GS and I suspect with others, too...
Kynde is offline   Reply With Quote
Old 11-19-08, 07:25 AM   #2
huguesdk
Registered User
 
Join Date: Oct 2005
Posts: 4
Default Re: UseEDID FALSE with NoDFPNativeResolutionCheck [SOLVED]

You will probably like the "ExactModeTimingsDVI" option then. Set it to true to get the behavior you want.

From the nVIDIA drivers README.txt:

Option "ExactModeTimingsDVI" "boolean"

Forces the initialization of the X server with the exact timings specified
in the ModeLine. Default: false (for DVI devices, the X server initializes
with the closest mode in the EDID list).

This also works with modes internal to the X server, so if a ModeLine is declared with the same name than a mode from the X server, the ModeLine will be renamed (usually, a "_0" is appended) and to select the ModeLine, the new name has to be used. Launching X with the -logverbose 5 or higher option will give all the needed information.

Hugues De Keyzer
huguesdk is offline   Reply With Quote
Old 11-19-08, 07:55 AM   #3
Tub
Registered User
 
Join Date: Nov 2006
Posts: 95
Default Re: UseEDID FALSE with NoDFPNativeResolutionCheck

Quote:
Why you may ask? Well, I need to get the system up and running regardless of the monitor being powered or not.
there's an easier way. Instead of manually entering all that information, just provide the whole raw EDID info.

run nvidia-settings and hit "Aquire EDID" to save your monitor's EDID info to a file. Copy it somewhere safe.

Add something like this to your screen section:
Code:
Option     "CustomEDID" "DFP-0:/etc/X11/245B.edid; DFP-1:/etc/X11/214T.edid"
and done.
Tub is offline   Reply With Quote
Old 11-19-08, 08:11 AM   #4
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: UseEDID FALSE with NoDFPNativeResolutionCheck

I have been able to completely disable EDID (so it will only use the modes I provide it) using the following lines in my device section:

Option "UseEDID" "FALSE"
Option "ModeValidation" "AllowNon60HzDFPModes, NoEdidModes, NoEdidDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoMaxSizeCheck, NoDFPNativeResolutionCheck"

I used this to get 33.7 Hz @ 3840x2400 on my ViewSonic VP2290b monitor.
Xevious is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 09:27 AM

All times are GMT -5. The time now is 04:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.