Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-27-08, 06:01 PM   #25
alex88
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by towo| View Post
U should show us the /var/log/nvidia-installer.log
when i install the drivers under the 2.6.27 or under 2.6.28? because the install end without any problem.
alex88 is offline   Reply With Quote
Old 10-27-08, 06:02 PM   #26
towo|
Registered User
 
Join Date: Feb 2007
Posts: 113
Default Re: Kernel 2.6.28 support?

Under 2.6.28
towo| is offline   Reply With Quote
Old 10-27-08, 06:20 PM   #27
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Kernel 2.6.28 support?

Actually, if the installation itself succeeds on Linux 2.6.28, please generate and attach an nvidia-bug-report.log file after the problem has reproduced.
zander is offline   Reply With Quote
Old 10-27-08, 06:21 PM   #28
alex88
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: Kernel 2.6.28 support?

So, booted into 2.6.28, trying to install nvidia driver using the custom patched installer, created nvidia-installer.log and nvidia-bug-report, tried to start gdm, black screen..No way to reopen terminal...
Booted into 2.6.27, black screen, ctrl-alt-F1 to open terminal, created nvidia-bug-report2 (if it helps) and reinstalled nvidia-drivers (custom patched installer), working. Uploaded nvidia-installer2.log

Maybe it would help,

i've compiled the kernel downloading the bz2 from the kernel.org site, then make xconfig, loaded 2.6.27-7-generic config, make-kpkg clean, fakeroot make-kpkg --initrd --append-to-version=-extreme kernel_image kernel_headers, installed 2 .deb files, headers and image.
Attached Files
File Type: log nvidia-installer.log (51.0 KB, 132 views)
File Type: bz2 nvidia-bug-report.log.tar.bz2 (34.2 KB, 121 views)
File Type: bz2 nvidia-bug-report2.log.tar.bz2 (32.6 KB, 124 views)
File Type: log nvidia-installer2.log (46.3 KB, 124 views)

Last edited by alex88; 10-27-08 at 06:55 PM. Reason: Improvement
alex88 is offline   Reply With Quote
Old 10-27-08, 11:42 PM   #29
gavron
Registered User
 
Join Date: Apr 2008
Posts: 49
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by zander View Post
Actually, if the installation itself succeeds on Linux 2.6.28, please generate and attach an nvidia-bug-report.log file after the problem has reproduced.

No problem on 2.6.28-rc2.

E
gavron is offline   Reply With Quote
Old 10-28-08, 04:46 AM   #30
alex88
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: Kernel 2.6.28 support?

In the nvidia-installer.log on 2.6.28 i've seen this:

echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \

should i do

make oldconfig && make prepare

and recompile the kernel??
alex88 is offline   Reply With Quote
Old 10-28-08, 02:14 PM   #31
cdrw
Registered User
 
Join Date: Mar 2006
Posts: 59
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by zander View Post
The adventurous of you are also welcome to try the patch below (provided as-is, please use it at your own risk). It can be applied using the .run installer's --apply-patch option.
Thank you!
My (at least) problems are fixed with your patch
cdrw is offline   Reply With Quote
Old 10-28-08, 06:14 PM   #32
alex88
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by cdrw View Post
Thank you!
My (at least) problems are fixed with your patch
How have you compiled the kernel? Have you followed a guide? if yes, what guide?

Thanks in advance
alex88 is offline   Reply With Quote

Old 10-29-08, 10:45 AM   #33
cdrw
Registered User
 
Join Date: Mar 2006
Posts: 59
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by alex88 View Post
How have you compiled the kernel? Have you followed a guide? if yes, what guide?

Thanks in advance
yes, i alway compile my own kernel.
Not sure about guide? First time I compiled kernel was very long time ago. So I don't use any specific guide.
There is a lot of guides how to compile custom kernel on the internet. Because this is nvidia forum, I don't think that it would be appropriate for me to explain in detail how to build custom kernel on the site dedicated to nvidia. However I would suggest to keep always working kernel copy, so make sure that your custom kernel has different name than the original working kernel. If custom kernel fail, you can always boot to working one and adjust custom kernel and try compile again.

Good luck
cdrw is offline   Reply With Quote
Old 10-29-08, 10:54 AM   #34
alex88
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by cdrw View Post
yes, i alway compile my own kernel.
Not sure about guide? First time I compiled kernel was very long time ago. So I don't use any specific guide.
There is a lot of guides how to compile custom kernel on the internet. Because this is nvidia forum, I don't think that it would be appropriate for me to explain in detail how to build custom kernel on the site dedicated to nvidia. However I would suggest to keep always working kernel copy, so make sure that your custom kernel has different name than the original working kernel. If custom kernel fail, you can always boot to working one and adjust custom kernel and try compile again.

Good luck
yes, now i've nvidia working, but not in the boot screen, when it says "loading files needed to boot"..i've added "vga=791" at the kernel boot line, it works in 2.6.27-7 but not in 2.6.28..But nvidia works perfect on 2.6.28 in gdm
alex88 is offline   Reply With Quote
Old 11-09-08, 09:19 AM   #35
kim.bratlie
Registered User
 
Join Date: Nov 2008
Posts: 4
Default Re: Kernel 2.6.28 support?

Hello,

Has anyone tried to compile the nvidia driver-177.80 on a x86_64 system with 2.6.28-rc2-mm1 ?

Code:
*** Unable to determine target kernel version. ***
make: *** [select_makefile] Error 1
I would appreciate any help in debugging this.

Thanks.
kim.bratlie is offline   Reply With Quote
Old 11-09-08, 09:34 AM   #36
cthulhu
Great Old One
 
cthulhu's Avatar
 
Join Date: Sep 2002
Posts: 124
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by kim.bratlie View Post
Hello,

Has anyone tried to compile the nvidia driver-177.80 on a x86_64 system with 2.6.28-rc2-mm1 ?

Code:
*** Unable to determine target kernel version. ***
make: *** [select_makefile] Error 1
I would appreciate any help in debugging this.

Thanks.
Did you make the symlink as described in #3 and #11?
__________________
Desktop: Asus P5B Deluxe, Core2Duo E8500, 2GB Corsair 800MHz CL4, Gigabyte GTX460 1024MB
HTPC: Asus P5B-E, Core2Duo 6300, 1GB Corsair 533MHz, Asus 9500GT w/ 512MB DDR3
Server: Gigabyte D510UD, Atom D510, 2GB Corsair 800MHz, Hauppauge NOVA-T500 dual DVB-T tuner, 4x 2TB Samsung F3EG (RAID5)
Laptop: Asus U6V, Core2Duo P8400, 3GB DDR2, 9300M GS
OS on all: Gentoo Linux

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
cthulhu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 04:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 11:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 09:22 PM

All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.