Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-09-08, 08:54 AM   #37
kim.bratlie
Registered User
 
Join Date: Nov 2008
Posts: 4
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by cthulhu View Post
Did you make the symlink as described in #3 and #11?
Yes, I tried that but it did not work. I think the mm-sources are a bit different.
http://http://kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.28-rc2/2.6.28-rc2-mm1/2.6.28-rc2-mm1.bz2
kim.bratlie is offline   Reply With Quote
Old 11-10-08, 04:30 AM   #38
cthulhu
Great Old One
 
cthulhu's Avatar
 
Join Date: Sep 2002
Posts: 124
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by kim.bratlie View Post
Yes, I tried that but it did not work. I think the mm-sources are a bit different.
http://http://kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.28-rc2/2.6.28-rc2-mm1/2.6.28-rc2-mm1.bz2
Have you tried moving the 2 files in include/asm-x86 to arch/x86/include/asm/, rmdir include/asm-x86 and then symlinking arch/x86/include/asm/ to include/asm-x86?

It may also be necesarry to symlink include/asm-x86 to include/asm.
__________________
Desktop: Asus P5B Deluxe, Core2Duo E8500, 2GB Corsair 800MHz CL4, Gigabyte GTX460 1024MB
HTPC: Asus P5B-E, Core2Duo 6300, 1GB Corsair 533MHz, Asus 9500GT w/ 512MB DDR3
Server: Gigabyte D510UD, Atom D510, 2GB Corsair 800MHz, Hauppauge NOVA-T500 dual DVB-T tuner, 4x 2TB Samsung F3EG (RAID5)
Laptop: Asus U6V, Core2Duo P8400, 3GB DDR2, 9300M GS
OS on all: Gentoo Linux

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
cthulhu is offline   Reply With Quote
Old 11-11-08, 01:10 AM   #39
kim.bratlie
Registered User
 
Join Date: Nov 2008
Posts: 4
Default Re: Kernel 2.6.28 support?

Still no luck. I'll try 2.6.28-rc4 later today.

EDIT: I made a small mistake when creating the symlinks,
but that fixed the driver will not compile on 2.6.28-rc4.
I get the following errors:
Code:
ar/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c: In function 'nv_acpi_add':
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c:161: error: invalid lvalue in assignment
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c:178: warning: passing argument 4 of 'acpi_evaluate_integer' from incompatible pointer type
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c: In function 'nv_acpi_event':
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c:319: warning: passing argument 4 of 'acpi_evaluate_integer' from incompatible pointer type
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c:334: warning: passing argument 4 of 'acpi_evaluate_integer' from incompatible pointer type
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c:349: warning: passing argument 4 of 'acpi_evaluate_integer' from incompatible pointer type
/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.c:364: warning: passing argument 4 of 'acpi_evaluate_integer' from incompatible pointer type
make[4]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv/nvacpi.o] Error 1
make[3]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/work/NVIDIA-Linux-x86_64-177.80-pkg2/usr/src/nv] Error 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
kim.bratlie is offline   Reply With Quote
Old 11-11-08, 03:29 PM   #40
kim.bratlie
Registered User
 
Join Date: Nov 2008
Posts: 4
Default Re: Kernel 2.6.28 support?

I fixed it. Adding the patch posted earlier by zander did the trick. :-)
kim.bratlie is offline   Reply With Quote
Old 11-12-08, 06:30 PM   #41
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: Kernel 2.6.28 support?

Will 177.82 compile against 2.6.28-rc? without patch? Did anyone try?
ledoc is offline   Reply With Quote
Old 11-12-08, 06:33 PM   #42
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Kernel 2.6.28 support?

I wouldn't expect it to. The patch I posed for 177.80 should still work, though.
zander is offline   Reply With Quote
Old 11-12-08, 11:48 PM   #43
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Default Re: Kernel 2.6.28 support?

zander: patch fails on 177.82 just FYI, but overall, thanks for your great patches, they make my life much more pleasant.

patching file usr/src/nv/Makefile.kbuild
Hunk #1 succeeded at 185 (offset -4 lines).
patching file usr/src/nv/Makefile.nvidia
Hunk #1 succeeded at 59 (offset -4 lines).
patching file usr/src/nv/conftest.sh
patching file usr/src/nv/nvacpi.c
Hunk #1 FAILED at 136.
Hunk #2 succeeded at 158 (offset 1 line).
Hunk #3 succeeded at 304 with fuzz 2 (offset 1 line).
1 out of 3 hunks FAILED -- saving rejects to file usr/src/nv/nvacpi.c.rej

By the way, is it my imagination or did something in 177.82 make for much improved 2d desktop and window painting speed? It was quite noticeable.
gfxdrone is offline   Reply With Quote
Old 11-13-08, 02:00 AM   #44
towo|
Registered User
 
Join Date: Feb 2007
Posts: 113
Default Re: Kernel 2.6.28 support?

I adapted zanders patch, so now it works with 177.82
Attached Files
File Type: txt NVIDIA_kernel-177.82.diff.txt (5.9 KB, 2395 views)
towo| is offline   Reply With Quote

Old 11-13-08, 02:46 AM   #45
plun
Registered User
 
Join Date: Jan 2007
Posts: 30
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by towo| View Post
I adapted zanders patch, so now it works with 177.82
Thanks ! Works just fine with 2.6.28-RC4
plun is offline   Reply With Quote
Old 11-26-08, 08:52 AM   #46
bouba_diop
Registered User
 
Join Date: Nov 2008
Posts: 1
Default Re: Kernel 2.6.28 support?

Quote:
Originally Posted by towo| View Post
I adapted zanders patch, so now it works with 177.82
yeaaahhhhh thanks! with your patch i've installed 177.82 on my debian 2.6.28-rc5!
before patching it allways says : "can't find kernel source bla bla bla"

good job!

bye!
bouba_diop is offline   Reply With Quote
Old 01-19-09, 01:06 PM   #47
amdfanatyk
self-compiled user
 
Join Date: Jun 2008
Posts: 32
Default Re: Kernel 2.6.28 support?

Now I have 177.82 running with kernel 2.6.28. Thanks for the patch!!
__________________
Palit GF 7300GT Sonic 400/1000 256MB DDR3 AGPX8
Fedora Core 4, 2.6.28.7-grsec, X.Org 7.2.0, Qt 3.3.8, KDE 3.5.5, GCC 4.2.3
amdfanatyk is offline   Reply With Quote
Old 01-19-09, 02:20 PM   #48
firecat53
Registered User
 
Join Date: Jan 2009
Posts: 2
Default Re: Kernel 2.6.28 support?

Is there a patch available for x86_64 for the latest 177 drivers running with 2.6.28? I'm having frequent freezes with the new 180.22 drivers, so I'd like to downgrade for now, as the 177 drivers worked great. I tried the x86 patch above, but, obviously , that did not work for the x86_64 drivers!

Thanks!
Scott
firecat53 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 12:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.