Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-20-09, 05:40 AM   #25
fingAU
Registered User
 
Join Date: Nov 2008
Location: Australia
Posts: 9
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

I cannot upgrade my ubuntu box from hardy to intrepid until 71.86.07 is fixed. I have the same mobo as dr_asfak and I have the same problem with 96.43.xx series, that is, even though the nvidia readme says that 96.43.09 will work with my GeForce2 Integrated GPU, IT NEVER HAS WORKED. Only 71.86.xx series have worked.
fingAU is offline   Reply With Quote
Old 01-21-09, 09:55 PM   #26
legends
Legends Dev
 
Join Date: Jan 2009
Posts: 12
Thumbs up Re: Please make >71.86.07 compatible with xorg-server 1.5.x

I also would like to see 71.xx updated for X Server 1.5+
I spent a long time trying to get 3D acceleration working in Xubuntu 8.10 until I realised it was not possible. No one knows a simple console command to downgrade X server to 1.4, so this is causing a dead end.
Makes it hard to develop games for old tech when you can't test it out on a recent OS release.
legends is offline   Reply With Quote
Old 01-27-09, 09:48 PM   #27
fingAU
Registered User
 
Join Date: Nov 2008
Location: Australia
Posts: 9
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

An update.
The latest release 71.86.08 still has not work with Ubuntu 8.10. See snips from xorg log.

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux ubuntu 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686
Build Date: 24 October 2008 08:00:16AM
xorg-server 2:1.5.2-2ubuntu3 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) NVIDIA GLX Module 71.86.08 Sat Jan 24 20:46:30 PST 2009
(II) Loading extension GLX
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found
fingAU is offline   Reply With Quote
Old 01-28-09, 09:22 AM   #28
mhall119
Registered User
 
Join Date: Oct 2006
Posts: 1
Unhappy Re: Please make >71.86.07 compatible with xorg-server 1.5.x

I'm running a charity that donates second-hand PCs to special needs kids using a custom Ubuntu OS. Most of our computers are 5 to 10 years old, some have TNT2 cards in them. I want to run educational programs like Celestia or Stellarium, but without 3D acceleration, I can't.

Just because a card is 10 years old, doesn't mean people aren't using them. Please get the 71.x drivers upgraded. If it's a question of time & labor, I'm sure someone in the community would be willing to do it under a non-disclosure agreement.
mhall119 is offline   Reply With Quote
Old 01-28-09, 10:53 AM   #29
dr_asfak
Registered User
 
Join Date: Jun 2008
Posts: 20
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

is 71.86.08 compatible with xorg 1.5 and 1.599 ? No mention of xorg compatibility on changelog
dr_asfak is offline   Reply With Quote
Old 01-28-09, 01:52 PM   #30
ZYV
Registered User
 
Join Date: Nov 2008
Posts: 6
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

No, it's not.
ZYV is offline   Reply With Quote
Old 01-29-09, 08:27 PM   #31
legends
Legends Dev
 
Join Date: Jan 2009
Posts: 12
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

Now a bunch of security vulnerabilities make 8.04, 7.10, 6.06 a risk to use. http://www.ubuntu.com/usn/usn-714-1
__________________
http://legendsthegame.net/ - freeware Online multiplayer FPS with jetpacks, like Tribes! for Linux/Windows (one day Mac too)
legends is offline   Reply With Quote
Old 02-03-09, 09:49 PM   #32
valdis
Registered User
 
Join Date: Apr 2003
Posts: 48
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

I wonder how many of the "please make it 1.5 compatible" people realize that there's a *very* good chance that 1.6 is gonna get released before NVidia ships the 1.5 compat..
valdis is offline   Reply With Quote

Old 02-04-09, 03:41 AM   #33
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

Has anyone tried hacking xorg or editing xorg.conf to get it to work ?

Code:
su
mv /usr/bin/Xorg /usr/bin/Xorg.save
echo 'exec /usr/bin/Xorg.save -ignoreABI "$@"' > /usr/bin/Xorg
chmod +x /usr/bin/Xorg

or adding this to xorg.conf


Code:
Section "ServerFlags"
# Needed for "nvidia" driver on new Xorg
        Option       "IgnoreABI" "true"
EndSection



P.S it isn't reasonable to expect Nvidia to support these antique card's forever !
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 02-04-09, 03:57 AM   #34
ZYV
Registered User
 
Join Date: Nov 2008
Posts: 6
Thumbs down Re: Please make >71.86.07 compatible with xorg-server 1.5.x

If they can't afford supporting it, then they should release the specs / drivers for the Nouveau guys to pick them up. What people want nowadays is a warranty that you are not going to be left behind with the old stuff because someone deems unreasonable to continue to support you.

Go Intel
ZYV is offline   Reply With Quote
Old 02-05-09, 12:30 AM   #35
mess_enger_guy
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

71.86.08 released!

ftp://download.nvidia.com/XFree86/Linux-x86/71.86.08/

Can anybody confirm if its compatible with the latest xorg?
mess_enger_guy is offline   Reply With Quote
Old 02-05-09, 02:52 AM   #36
ZYV
Registered User
 
Join Date: Nov 2008
Posts: 6
Default Re: Please make >71.86.07 compatible with xorg-server 1.5.x

http://www.nvnews.net/vbulletin/showthread.php?t=126955

No, it's not.
ZYV is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Rumor: Sony Cloud Deal Will Make PS3 Backwards Compatible, Stream PS2/PS1 games News Archived News Items 0 06-01-12 12:10 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 07:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.