Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-08, 07:57 PM   #241
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: mplayer vdpau

Great to hear people working on it, keep it up !
Duran is offline   Reply With Quote
Old 12-07-08, 05:59 AM   #242
speedsix
Registered User
 
Join Date: Dec 2006
Posts: 7
Default Re: mplayer vdpau

Hi all,

I'm just about to purchase a new motherboard for my HTPC, I can't decide if it's worth the extra for a board with the 9300 IGP or just getting a 7100 based mainboard and picking up a separate VC-1 compatible PCI-e card at a later date (probably cheaper than the extra for a 9300 IGP board)

Is the 9300 IGP likely to support VC-1 assistance at some point?
speedsix is offline   Reply With Quote
Old 12-08-08, 10:49 AM   #243
bogey
Registered User
 
Join Date: Feb 2004
Posts: 15
Default Re: mplayer vdpau

Quote:
Originally Posted by speedsix View Post
Is the 9300 IGP likely to support VC-1 assistance at some point?
That's my question also, will the Linux driver support VC-1 for 9300 / 730i?
The PureVideo HD chart (http://sg.nvidia.com/object/IO_43029.html) shows that 9300 IGP supports VC-1 Decode Acceleration. Does the GPU support VC-1 decoding in hardware? What does "acceleration" mean in this case? What would be the cpu usage compared to H.264?

If you check from the Windows driver nv4_disp.inf, 9300 / nForce 730i is listed having C79 core, not G98...
bogey is offline   Reply With Quote
Old 12-08-08, 11:31 AM   #244
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: mplayer vdpau

Quote:
Originally Posted by bogey View Post
That's my question also, will the Linux driver support VC-1 for 9300 / 730i?
The PureVideo HD chart (http://sg.nvidia.com/object/IO_43029.html) shows that 9300 IGP supports VC-1 Decode Acceleration. Does the GPU support VC-1 decoding in hardware? What does "acceleration" mean in this case? What would be the cpu usage compared to H.264?

If you check from the Windows driver nv4_disp.inf, 9300 / nForce 730i is listed having C79 core, not G98...
Quote:
VC-1 support in NVIDIA's VDPAU implementation currently requires GeForce
9300 GS, GeForce 9200M GS, GeForce 9300M GS, or GeForce 9300M GS.
See http://www.nvnews.net/vbulletin/showthread.php?t=123091
Dragoran is offline   Reply With Quote
Old 12-08-08, 11:34 AM   #245
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: mplayer vdpau

Quote:
Originally Posted by Dragoran View Post
Not very useful information provided you can't find those cards anywhere ...
jyavenard is offline   Reply With Quote
Old 12-08-08, 11:58 AM   #246
bogey
Registered User
 
Join Date: Feb 2004
Posts: 15
Default Re: mplayer vdpau

Quote:
VC-1 support in NVIDIA's VDPAU implementation currently requires GeForce
9300 GS, GeForce 9200M GS, GeForce 9300M GS, or GeForce 9300M GS.
Quote:
Originally Posted by Dragoran View Post
Yes it says currently, my question was will linux driver support VC-1 in 9300 / 730i?

There is at least some hardware support in 9300 for VC-1, see e.g. http://techreport.com/articles.x/15690/8
bogey is offline   Reply With Quote
Old 12-08-08, 12:57 PM   #247
duc
Registered User
 
Join Date: Apr 2006
Posts: 10
Default mplayer vdpau

hello,

i have a new problem not yet posted here.

Code:
# cat /proc/driver/nvidia/cards/0
Model:           GeForce 8200
IRQ:             22
Video BIOS:      62.77.19.00.00
Card Type:       PCI
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    02.00.0
mpeg file:
Code:
./mplayer -vo vdpau -vc ffmpeg12vdpau MPEGIO3MBPS30sec.mpg 
MPlayer dev-SVN-r27960-4.1.2 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) Dual Core Processor 5050e (Family: 15, Model: 107, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
115 audio & 238 video codecs
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing MPEGIO3MBPS30sec.mpg.
MPEG-PS file format detected.
VIDEO:  MPEG2  704x576  (aspect 2)  25.000 fps  3000.0 kbps (375.0 kbyte/s)
==========================================================================
Forced video codec: ffmpeg12vdpau
Cannot find codec matching selected -vo and video format 0x10000002.
Read DOCS/HTML/en/codecs.html!
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   2.8 (02.8) of 29.2 (29.1)  0.3%
h.264 file:
Code:
./mplayer -vo vdpau -vc ffh264vdpau -nolirc /media/usb/FUJITSU_MHZ2500BT_G2_1/Filme/BluRay/Transformers\ \(1080p\).vob 
MPlayer dev-SVN-r27960-4.1.2 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) Dual Core Processor 5050e (Family: 15, Model: 107, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
115 audio & 238 video codecs

Playing /media/usb/FUJITSU_MHZ2500BT_G2_1/Filme/BluRay/Transformers (1080p).vob.
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)!  PROGRAM N. 1
FPS seems to be: 23.976025
==========================================================================
Forced video codec: ffh264vdpau
Cannot find codec matching selected -vo and video format 0x10000005.
Read DOCS/HTML/en/codecs.html!
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 601.2 (10:01.2) of 141145.5 (39:12:25.5)  1.1% 

MPlayer interrupted by signal 2 in module: play_audio
A: 601.3 (10:01.2) of 141145.5 (39:12:25.5)  1.1%
i ran the script checkout-patch-build.sh and had no errors after compiling. but it seems the patches don't work?
any idea?
duc is offline   Reply With Quote
Old 12-08-08, 01:28 PM   #248
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

@duc,

Can you follow the instructions in the VDPAU debugging sticky, and post the debug traces that you get. Thanks.
Stephen Warren is offline   Reply With Quote

Old 12-08-08, 01:46 PM   #249
Drako60
Registered User
 
Join Date: May 2005
Posts: 9
Default Re: mplayer vdpau

duc,

I've had possibly the same issue, i would try running it with,
/usr/local/bin/mplayer -vo help and see if vdpau or /usr/local/bin/mplayer -vc help and see if ffmpeg12vdpau appears.

I'm not sure why but my system isn't updating the paths to reflect a new binary until i restart X, even after installing mplayer-vdpau it was still referring to /usr/bin/mplayer instead of the newer /usr/local/bin/mplayer.

possibly completely unrelated but could help in debugging
Drako60 is offline   Reply With Quote
Old 12-08-08, 01:56 PM   #250
duc
Registered User
 
Join Date: Apr 2006
Posts: 10
Default Re: mplayer vdpau

there's no debug output, sorry. mplayer not even starts playing the file.

i started mplayer directly in the folder where the fresh made mplayer executable resides:
Code:
/usr/local/src/mplayer-vdpau-3139462/mplayer-vdpau# ./mplayer -vc help | grep ffh264
ffh264      ffmpeg    working   FFmpeg H.264  [h264]
no ffh264vdpau.
i controlled some of the patched files, the changes are correctly done. i had no errors after compiling. strange.
configure was called ./configure --disable-x264-lavc --disable-x264 --enable-vdpau as i could read in the script checkout-patch-build.sh
but it seemes that the vdpau extensions were not added to mplayer. why does it work with the -vo vdpau option only?


using only the -vo vdpau option works:
Code:
/usr/local/src/mplayer-vdpau-3139462/mplayer-vdpau# ./mplayer -vo vdpau -nolirc /media/usb/FUJITSU_MHZ2500BT_G2_1/Filme/BluRay/Transformers\ \(1080p\).vob 
MPlayer dev-SVN-r27960-4.1.2 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) Dual Core Processor 5050e (Family: 15, Model: 107, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
115 audio & 238 video codecs

Playing /media/usb/FUJITSU_MHZ2500BT_G2_1/Filme/BluRay/Transformers (1080p).vob.
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)!  PROGRAM N. 1
FPS seems to be: 23.976025
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 800 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x800 => 1920x800 Planar YV12 
A: 603.4 V: 603.6 A-V: -0.148 ct: -0.023  83/ 83 58% 11%  1.0% 9 0
edit
today i installed the new driver version 180.11 and rebooted the computer.
apt-get build-dep mplayer
/usr/local/src/mplayer-vdpau-3139462# rm -rf mplayer-vdpau
/usr/local/src/mplayer-vdpau-3139462# ./checkout-patch-build.sh

no change:
Code:
 
easyVDR:/usr/local/src/mplayer-vdpau-3139462/mplayer-vdpau# ./mplayer -vc help | grep ff

ffkmvc      ffmpeg    problems  ffkmvc  [kmvc]
ffzmbv      ffmpeg    working   FFmpeg Zip Motion-Block Video  [zmbv]
ffmpeg1     ffmpeg    working   FFmpeg MPEG-1  [mpeg1video]
ffmpeg2     ffmpeg    working   FFmpeg MPEG-2  [mpeg2video]
ffmpeg12    ffmpeg    working   FFmpeg MPEG-1/2  [mpegvideo]
ffmpeg12mc  ffmpeg    problems  FFmpeg MPEG-1/2 (XvMC)  [mpegvideo_xvmc]
ffnuv       ffmpeg    working   NuppelVideo  [nuv]
ffbmp       ffmpeg    working   FFmpeg BMP decoder  [bmp]
ffgif       ffmpeg    working   FFmpeg GIF decoder  [gif]
fftiff      ffmpeg    untested  FFmpeg TIFF decoder  [tiff]
ffpng       ffmpeg    working   FFmpeg PNG decoder  [png]
fftga       ffmpeg    untested  FFmpeg TGA decoder  [targa]
ffindeo3    ffmpeg    working   FFmpeg Intel Indeo 3.1/3.2  [indeo3]
fffli       ffmpeg    working   Autodesk FLI/FLC Animation  [flic]
ffaasc      ffmpeg    working   Autodesk RLE decoder  [aasc]
ffloco      ffmpeg    working   LOCO video decoder  [loco]
ffqtrle     ffmpeg    working   QuickTime Animation (RLE)  [qtrle]
ffrpza      ffmpeg    working   QuickTime Apple Video  [rpza]
ffsmc       ffmpeg    working   Apple Graphics (SMC) codec  [smc]
ff8bps      ffmpeg    working   Planar RGB (Photoshop)  [8bps]
ffcyuv      ffmpeg    working   Creative YUV (libavcodec)  [cyuv]
ffmsrle     ffmpeg    working   Microsoft RLE  [msrle]
ffroqvideo  ffmpeg    working   Id RoQ File Video Decoder  [roqvideo]
ffcvid      ffmpeg    working   Cinepak Video (native codec)  [cinepak]
huffyuv     vfw       problems  HuffYUV  [huffyuv.dll]
ffvideo1    ffmpeg    working   Microsoft Video 1 (native codec)  [msvideo1]
ffmszh      ffmpeg    working   AVImszh (native codec)  [mszh]
ffzlib      ffmpeg    working   AVIzlib (native codec)  [zlib]
ffhuffyuv   ffmpeg    working   FFmpeg HuffYUV  [huffyuv]
ffv1        ffmpeg    working   FFV1 (lossless codec)  [ffv1]
ffsnow      ffmpeg    working   FFSNOW (Michael's wavelet codec)  [snow]
ffasv1      ffmpeg    working   FFmpeg ASUS V1  [asv1]
ffasv2      ffmpeg    working   FFmpeg ASUS V2  [asv2]
ffvcr1      ffmpeg    working   FFmpeg ATI VCR1  [vcr1]
ffcljr      ffmpeg    working   FFmpeg Cirrus Logic AccuPak (CLJR)  [cljr]
ffsvq1      ffmpeg    working   FFmpeg Sorenson Video v1 (SVQ1)  [svq1]
ff4xm       ffmpeg    working   FFmpeg 4XM video  [4xm]
ffvixl      ffmpeg    working   Miro/Pinnacle VideoXL codec  [xl]
ffqtdrw     ffmpeg    working   QuickDraw native decoder  [qdraw]
ffindeo2    ffmpeg    working   Indeo 2 native decoder  [indeo2]
ffflv       ffmpeg    working   FFmpeg Flash video  [flv]
fffsv       ffmpeg    working   FFmpeg Flash Screen video  [flashsv]
ffdivx      ffmpeg    working   FFmpeg DivX ;-) (MS MPEG-4 v3)  [msmpeg4]
ffmp42      ffmpeg    working   FFmpeg M$ MPEG-4 v2  [msmpeg4v2]
ffmp41      ffmpeg    working   FFmpeg M$ MPEG-4 v1  [msmpeg4v1]
ffwmv1      ffmpeg    working   FFmpeg M$ WMV1/WMV7  [wmv1]
ffwmv2      ffmpeg    problems  FFmpeg M$ WMV2/WMV8  [wmv2]
ffwmv3      ffmpeg    problems  FFmpeg M$ WMV3/WMV9  [wmv3]
ffvc1       ffmpeg    problems  FFmpeg M$ WVC1  [vc1]
ffh264      ffmpeg    working   FFmpeg H.264  [h264]
ffsvq3      ffmpeg    working   FFmpeg Sorenson Video v3 (SVQ3)  [svq3]
ffodivx     ffmpeg    working   FFmpeg MPEG-4  [mpeg4]
ffwv1f      ffmpeg    working   WV1F MPEG-4  [mpeg4]
ffmjpeg     ffmpeg    working   FFmpeg MJPEG decoder  [mjpeg]
ffmjpegb    ffmpeg    working   FFmpeg MJPEG-B decoder  [mjpegb]
ffi263      ffmpeg    working   FFmpeg I263 decoder  [h263i]
ffh263      ffmpeg    working   FFmpeg H.263+ decoder  [h263]
ffzygo      ffmpeg    untested  FFmpeg ZyGo  [h263]
ffh261      ffmpeg    working   CCITT H.261  [h261]
ffdv        ffmpeg    working   FFmpeg DV decoder  [dvvideo]
ffrv20      ffmpeg    working   FFmpeg RV20 decoder  [rv20]
ffrv10      ffmpeg    working   FFmpeg RV10 decoder  [rv10]
ffvp3       ffmpeg    untested  FFmpeg VP3  [vp3]
fftheora    ffmpeg    untested  FFmpeg Theora  [theora]
ffvp5       ffmpeg    working   FFmpeg VP5 decoder  [vp5]
ffvp6       ffmpeg    working   FFmpeg VP6 decoder  [vp6]
ffvp6f      ffmpeg    working   FFmpeg VP6 Flash decoder  [vp6f]
ffultimotion ffmpeg    working   IBM Ultimotion native decoder  [ultimotion]
ffduck      ffmpeg    working   Duck Truemotion1  [truemotion1]
fftm20      ffmpeg    working   FFmpeg Duck/On2 TrueMotion 2.0  [truemotion2]
ffamv       ffmpeg    working   Modified MJPEG, used in AMV files  [amv]
ffsp5x      ffmpeg    working   SP5x codec - used by Aiptek MegaCam  [sp5x]
ffwnv1      ffmpeg    working   FFmpeg wnv1 native codec  [wnv1]
ffvmnc      ffmpeg    working   FFmpeg VMware video  [VMware video]
ffsmkvid    ffmpeg    working   FFmpeg Smacker Video  [smackvid]
ffcavs      ffmpeg    working   Chinese AVS Video  [cavs]
ffcamtasia  ffmpeg    working   TechSmith Camtasia Screen Codec (native)  [camtasia]
ffcamstudio ffmpeg    working   CamStudio Screen Codec  [camstudio]
fffraps     ffmpeg    working   FFmpeg Fraps  [fraps]
fftiertexseq ffmpeg    working   FFmpeg Tiertex SEQ  [tiertexseqvideo]
ffvmd       ffmpeg    working   FFmpeg Sierra VMD video  [vmdvideo]
ffdxa       ffmpeg    working   FFmpeg Feeble Files DXA video  [dxa]
ffdsicinvideo ffmpeg    working   FFmpeg Delphine CIN video  [dsicinvideo]
ffthp       ffmpeg    working   FFmpeg THP video  [thp]
ffbethsoftvid ffmpeg    problems  FFmpeg Bethesda Software VID  [bethsoftvid]
fftxd       ffmpeg    working   FFmpeg Renderware TeXture Dictionary decoder  [txd]
ffwc3       ffmpeg    problems  FFmpeg XAN wc3  [xan_wc3]
ffidcin     ffmpeg    problems  FFmpeg Id CIN video  [idcinvideo]
ffinterplay ffmpeg    problems  FFmpeg Interplay Video  [interplayvideo]
ffvqa       ffmpeg    problems  FFmpeg VQA Video  [vqavideo]
ffc93       ffmpeg    problems  FFmpeg C93 Video  [c93]
a lot of codecs but NO

ffmpeg12vdpau
ffh264vdpau
ffwmv3vdpau
ffvc1vdpau

why doesn't make build the vdpau codecs?
i have kernel version 2.6.25.4 and gcc version 4.1.2

edit
Attached Files
File Type: log nvidia-bug-report.log (131.0 KB, 109 views)

Last edited by duc; 12-09-08 at 02:16 PM.
duc is offline   Reply With Quote
Old 12-09-08, 05:50 PM   #251
shallpion
Registered User
 
Join Date: Nov 2008
Posts: 9
Default Re: mplayer vdpau

Quote:
Originally Posted by gbil View Post
Well I had some time and compiled mplayer with the given script but I get the following:

VDec: vo config request - 1280 x 720 (preferred colorspace: VC1 ADVANCED VDPAU acceleration)
VDec: using VC1 ADVANCED VDPAU acceleration as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1280x720 => 1280x720 VC1 ADVANCED VDPAU acceleration [zoom]
Error at libvo/vo_vdpau.c:637

and mplayer crashes. Is this because of my gcc version 4.3.2 ?
Yes, I have the exactly same problem, that might be something wrong with the version of gcc, as they said. Hope nvidia or mplayer can solve it soon. ~~
shallpion is offline   Reply With Quote
Old 12-10-08, 05:11 AM   #252
magho
Registered User
 
Join Date: Dec 2005
Posts: 13
Default Re: mplayer vdpau

Quote:
Originally Posted by duc View Post

a lot of codecs but NO

ffmpeg12vdpau
ffh264vdpau
ffwmv3vdpau
ffvc1vdpau

why doesn't make build the vdpau codecs?
i have kernel version 2.6.25.4 and gcc version 4.1.2

edit
Do you have any xorg dev packages installed? Run ./configure --disable-x264-lavc --disable-x264 --enable-vdpau in the mplayer-vdpau directory and check for these lines:

Checking for X11 headers presence ... yes
Checking for X11 ... yes
Checking for Xss screensaver extensions ... no
Checking for DPMS ... yes (using Xdpms 4)
Checking for Xv ... yes
Checking for XvMC ... no
Checking for VDPAU ... yes

I bet you have quite a few no's there.
/Magnus H
magho is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 06:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 08:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 07:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 03:34 PM

All times are GMT -5. The time now is 07:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.