Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-14-08, 08:29 AM   #277
bogey
Registered User
 
Join Date: Feb 2004
Posts: 15
Default Re: mplayer vdpau

Quote:
Originally Posted by bogey View Post
Yes it says currently, my question was will linux driver support VC-1 in 9300 / 730i?
I went and bought Gigabyte GA-E7AUM-DS2H, and it has 9400 IGP instead and I can confirm that VC-1 works with the latest 180.16 driver.
Tested both of these VC-1 test clips and CPU usage is 1% when playing

$ ./mplayer -vo vdpau -vc ffvc1vdpau /data/hd/FlightSimX_720p60_51_15Mbps.wmv -codecs-file etc/codecs.conf
$ ./mplayer -vo vdpau -vc ffwmv3vdpau /data/hd/Amazing_Caves_720.wmv -codecs-file etc/codecs.conf

Also the h264 clips played. However they are a bit choppy.
I have tested some other h264 clips as well, but seems they are very choppy, rewinds and jumps a lot.
bogey is offline   Reply With Quote
Old 12-14-08, 01:09 PM   #278
LauriM
Registered User
 
Join Date: Dec 2008
Posts: 19
Default Re: mplayer vdpau

Quote:
Originally Posted by LauriM View Post
Is tearing with -vo vdpau (with or without using a vdpau codec) a known issue or should I report a bug?
Replying to myself.. In case anybody else is encountering the same, I think I managed to fix this by disabling Composite extension in Xorg.conf (I wasn't using a compositing window manager).

It works better than Xv now. VDPAU doesn't seem to suffer from the CPU hogging issue that Xv has when video frame rate is close to display refresh rate.
LauriM is offline   Reply With Quote
Old 12-14-08, 02:27 PM   #279
heavymetaler
Registered User
 
Join Date: Nov 2006
Posts: 9
Default Re: mplayer vdpau

Quote:
Originally Posted by LauriM View Post
Replying to myself.. In case anybody else is encountering the same, I think I managed to fix this by disabling Composite extension in Xorg.conf (I wasn't using a compositing window manager).

It works better than Xv now. VDPAU doesn't seem to suffer from the CPU hogging issue that Xv has when video frame rate is close to display refresh rate.
Code:
sudo nvidia-xconfig --no-composite
This resolved my tearing also. I assumed disabling the composite manager would be enough but it looks like completely disabling composite in Xorg resolves the tearing issues. One weird thing i've noticed is now mpeg2 HD playback is fairly inconsistent now. I've had the your system is too slow to play this message popup even while using VDPAU.
heavymetaler is offline   Reply With Quote
Old 12-14-08, 02:48 PM   #280
jmpoure
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: mplayer vdpau

I am from Kdenlive (http://www.kdenlive.org) video editor project.

Out of interest, can you play this typical AVCHD camcorder file:
http://www.kdenlive.org/videos/avchd-test-1.mts

Kind regards,
Jean-Michel
jmpoure is offline   Reply With Quote
Old 12-14-08, 03:26 PM   #281
oliwer
Registered User
 
oliwer's Avatar
 
Join Date: Dec 2008
Posts: 1
Question Re: mplayer vdpau

Hi,

Is it planned for VDPAU to support MPEG 4 (XviD,DivX) decoding ? Because they are still the most used codecs.
oliwer is offline   Reply With Quote
Old 12-14-08, 03:44 PM   #282
tyfon
Registered User
 
Join Date: Dec 2008
Posts: 3
Default Re: mplayer vdpau

Quote:
Originally Posted by oliwer View Post
Hi,

Is it planned for VDPAU to support MPEG 4 (XviD,DivX) decoding ? Because they are still the most used codecs.
I don't think there is hardware support for it, and its fairly easy to play back too. Also, I've yet to see any HD video in this format.
tyfon is offline   Reply With Quote
Old 12-14-08, 04:08 PM   #283
duc
Registered User
 
Join Date: Apr 2006
Posts: 10
Default Re: mplayer vdpau

i also tested the new driver and the new patches and now all the movies that crashed also can be played.

great job, thank you!
duc is offline   Reply With Quote
Old 12-14-08, 05:11 PM   #284
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: mplayer vdpau

Quote:
Originally Posted by jmpoure View Post
I am from Kdenlive (http://www.kdenlive.org) video editor project.

Out of interest, can you play this typical AVCHD camcorder file:
http://www.kdenlive.org/videos/avchd-test-1.mts

Kind regards,
Jean-Michel
it seems mplayer can't find the video track:
Playing ./avchd-test-1.mts.
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)! PROGRAM N. 1
FPS not specified in the header or invalid, use the -fps option.
================================================== ========================
Forced audio codec: mad
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
AO: [pulse] Failed to connect to server: Connection refused
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 5.3 (05.3) of 366.9 (06:06.8) 2.2%
Exiting... (Quit)

i've tried either with a vdpau mplayer build and a standard one with the same result

setting an arbitrary fps like suggested by mplayer resulted in serious video corruption and an mplayer crash after not much time (using the standard mplayer)
while with vdpau with the vdpau mplayer build and the -fps setting it played nicely and with zero issues.
weltall is offline   Reply With Quote

Old 12-14-08, 05:33 PM   #285
jmpoure
Registered User
 
Join Date: Oct 2008
Posts: 7
Default Re: mplayer vdpau

ffplay, which is ffmpeg viewer, is able to play the file.
mplayer -fps 25 filename can also play the file.
So AVCHD is supported in legacy mplayer.

I am trying to compile, but I am having problems (see other thread).
jmpoure is offline   Reply With Quote
Old 12-15-08, 12:22 AM   #286
Senor Hubris
Registered User
 
Join Date: Mar 2007
Posts: 45
Default Re: mplayer vdpau

Quote:
Originally Posted by LauriM View Post
Replying to myself.. In case anybody else is encountering the same, I think I managed to fix this by disabling Composite extension in Xorg.conf (I wasn't using a compositing window manager).

It works better than Xv now. VDPAU doesn't seem to suffer from the CPU hogging issue that Xv has when video frame rate is close to display refresh rate.

Very confusing. When I disable Composite I just get a green screen whenever I play anything. I have to enable Composite to get vdpau-mplayer to work.
Senor Hubris is offline   Reply With Quote
Old 12-15-08, 12:26 AM   #287
Senor Hubris
Registered User
 
Join Date: Mar 2007
Posts: 45
Default Re: mplayer vdpau

Has anyone besides myself attempted to play an interlaced video using an interlaced display? I get terrible tearing when I do this. Is nVidia interested in this? Should I submit an nvidia-bug-report.log?

A few more details. I run mythtv and I record over-the-air. I have numerous interlaced (all 1080i) material. I compiled the vdpau-mplayer with the 180.16 driver. Playing 720p material is smooth as can be. Playing 1080i material has lots of tearing.
Senor Hubris is offline   Reply With Quote
Old 12-15-08, 01:32 AM   #288
Drako60
Registered User
 
Join Date: May 2005
Posts: 9
Default Re: mplayer vdpau

disabling Composite helped me with playing my 60fps h.264, playing it with just -vo vdpau its completely smooth, and using ffh264vdpau i'm only encountering the known frame swap bug.

Still encountering the red-checker box, and sometimes solid red overlay with xv using 180.16.
Drako60 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 02:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.