Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-15-08, 02:38 AM   #289
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: mplayer vdpau

Quote:
Originally Posted by Senor Hubris View Post
Has anyone besides myself attempted to play an interlaced video using an interlaced display? I get terrible tearing when I do this. Is nVidia interested in this? Should I submit an nvidia-bug-report.log?

A few more details. I run mythtv and I record over-the-air. I have numerous interlaced (all 1080i) material. I compiled the vdpau-mplayer with the 180.16 driver. Playing 720p material is smooth as can be. Playing 1080i material has lots of tearing.
The mplayer patches do not enable deinterlacing yet.
Dragoran is offline   Reply With Quote
Old 12-15-08, 03:03 AM   #290
darklegion
Registered User
 
Join Date: Oct 2004
Posts: 37
Default Re: mplayer vdpau

I get the same problem as this guy: http://www.nvnews.net/vbulletin/show...1&postcount=46
Same video card, too.

cat /proc/driver/nvidia/cards/0:
Quote:
Model: GeForce 8800 GT
IRQ: 16
Video BIOS: 62.92.16.00.04
Card Type: PCI-E
DMA Size: 40 bits
DMA Mask: 0xffffffffff
Bus Location: 01.00.0
I'd post a bug report but the bug report script was going on forever, without finishing.
I'm using nvidia-drivers 180.16 on x86_64 if that helps.
darklegion is offline   Reply With Quote
Old 12-15-08, 03:19 AM   #291
shinj1eva
Registered User
 
Join Date: Dec 2008
Posts: 1
Default Re: mplayer vdpau

Hi, still having a problem playing back a certain MKV file. Not sure if the video was just created improperly or something else. I've attached the log output below, but the actual error messages is:

Code:
VDPAU nvidia: Error detected 1010 147  28
VDPAU nvidia: Backtrace:
01: /usr/lib/libvdpau_nvidia.so [0x7fa7ef497768]
VDPAU nvidia: Error detected 0 2951 
VDPAU nvidia: Backtrace:
01: /usr/lib/libvdpau_nvidia.so [0x7fa7ef497768]
    -> 25
Error 25 at libvo/vo_vdpau.c:1011
Attached Files
File Type: log error.log (6.2 KB, 113 views)
shinj1eva is offline   Reply With Quote
Old 12-15-08, 08:42 AM   #292
theuni
Registered User
 
Join Date: Nov 2008
Posts: 27
Default Re: mplayer vdpau

Quote:
Originally Posted by shinj1eva View Post
Hi, still having a problem playing back a certain MKV file. Not sure if the video was just created improperly or something else
You're not alone. See here: http://www.nvnews.net/vbulletin/showthread.php?t=124603

TheUni
theuni is offline   Reply With Quote
Old 12-15-08, 11:57 AM   #293
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by LauriM View Post
Is tearing with -vo vdpau (with or without using a vdpau codec) a known issue or should I report a bug?

I'm looking forward to using VDPAU for video output (even without hardware decoding) as it looks like it should be easy to support different color spaces and high quality deinterlacing.
Yes, there some cases where tearing may occur at present. Try turning off the X composite extension and not using SLI for the moment.
Stephen Warren is offline   Reply With Quote
Old 12-15-08, 11:59 AM   #294
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by weltall View Post
yes the first thing fixes it
OK, then it's most likely the issue we know about and are investigating.

Quote:
Originally Posted by weltall View Post
Another little question i can see from 180.16 that vc1 wmv3 playback was fixed in some gpus: it's still based on the precedently released list or it means it allowed also other gpu to work with them?
The same set of GPUs is supported by the new driver. There was just a bug in older drivers where a subset of the supported list would not work.
Stephen Warren is offline   Reply With Quote
Old 12-15-08, 12:03 PM   #295
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by oliwer View Post
Hi,

Is it planned for VDPAU to support MPEG 4 (XviD,DivX) decoding ? Because they are still the most used codecs.
I'm sorry, I can't comment on future features. There are certainly no plans in the 180.xx driver series for this.
Stephen Warren is offline   Reply With Quote
Old 12-15-08, 12:04 PM   #296
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by Senor Hubris View Post
Very confusing. When I disable Composite I just get a green screen whenever I play anything. I have to enable Composite to get vdpau-mplayer to work.
This is probably the same issue that user weltall reported a page or two back.
Stephen Warren is offline   Reply With Quote

Old 12-15-08, 12:07 PM   #297
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by darklegion View Post
I get the same problem as this guy: http://www.nvnews.net/vbulletin/show...1&postcount=46
This was resolved in this post:
http://www.nvnews.net/vbulletin/show...0&postcount=84
Stephen Warren is offline   Reply With Quote
Old 12-15-08, 12:11 PM   #298
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by shinj1eva View Post
Hi, still having a problem playing back a certain MKV file. Not sure if the video was just created improperly or something else. I've attached the log output below, but the actual error messages is:

VDPAU nvidia: Error detected 1010 147 28
This is a known issue; your stream exceeds level 4.1 limits on the number of reference frames. This should be fixed in the next driver (after 180.16). I think I explained in more detail here:

http://www.nvnews.net/vbulletin/showthread.php?t=124603
Stephen Warren is offline   Reply With Quote
Old 12-15-08, 12:18 PM   #299
gentuser
Dott.
 
Join Date: Dec 2008
Posts: 1
Default Re: mplayer vdpau

Hi to everyone.
With geforce 8500 gt , pentium IV 3.6 GHz, 180.16 nvidia-driver,linux 2.6.27-gentoo-r5, playing nature_704x576_25Hz_1500kbits.h264
Using VDPAU
With metacity cpu0 utilization is always under 1% max 2% , cpu1 0% (fantastic !! ).
With compiz or kwin (composit enabled) cpu0 always is over 74% and 1% max 2% cpu1.
Not Using VDPAU
under metacity cpu0 20% max 23% and cpu1 6% max 15%
under metacity cpu0 45% max 50% and cpu1 30% max 36% under compiz.

Last edited by gentuser; 12-15-08 at 12:19 PM. Reason: added kernel info
gentuser is offline   Reply With Quote
Old 12-15-08, 02:03 PM   #300
Senor Hubris
Registered User
 
Join Date: Mar 2007
Posts: 45
Default Re: mplayer vdpau

Quote:
Originally Posted by Dragoran View Post
The mplayer patches do not enable deinterlacing yet.
Why would you need to deinterlace? I'm playing an interlaced source on an interlaced display.
Senor Hubris is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 06:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 08:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 07:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 03:34 PM

All times are GMT -5. The time now is 04:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.