Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-16-08, 03:04 PM   #313
Senor Hubris
Registered User
 
Join Date: Mar 2007
Posts: 45
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
You're probably hitting a known bug.

Do you have 2 displays plugged in, or do you have 2 X screens configured? Try not doing either of those, or using a different display connector on your graphics card may help, or even plugging in another unused display to another connector. Hopefully we'll get this resolved soon.
Single display (television). Single X display. Using a DVI connector. I haven't tried using a
different display connector (yet).
Senor Hubris is offline   Reply With Quote
Old 12-16-08, 05:19 PM   #314
psychok9
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: mplayer vdpau

With 180.16 and "mplayer -vo vdpau -vc ffh264vdpau Grey.ts", I notice video flickering.
Sync to VBlank is enabled on OpenGL and XVideo Settings.

My cpu is Intel Q6600@3.2GHz and my vid is 8800 GT Zotac AMP!.
Ubuntu 8.10 x86_64.
psychok9 is offline   Reply With Quote
Old 12-16-08, 05:40 PM   #315
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

@psychok9,

Can you describe the flickering in more detail. Is it tearing (i.e. what happens if sync-to-vblank isn't enabled for GL/XVideo apps), decode corruption, frames being displayed out of order, or something else?

FYI, the GL/Xv sync-to-vblank settings don't affect VDPAU. Also, the frames-being-displayed-out-of-order is a known issue an being worked on as we speak.
Stephen Warren is offline   Reply With Quote
Old 12-16-08, 05:59 PM   #316
psychok9
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
@psychok9,

Can you describe the flickering in more detail. Is it tearing (i.e. what happens if sync-to-vblank isn't enabled for GL/XVideo apps), decode corruption, frames being displayed out of order, or something else?

FYI, the GL/Xv sync-to-vblank settings don't affect VDPAU. Also, the frames-being-displayed-out-of-order is a known issue an being worked on as we speak.
I think that is the classical tearing, a disjointed image (it is a common thing on games with vsync off).

I've tearing also with Xv output.

p.s. With SMPlayer I get many errors (I think that SMPlayer is incompatible atm, but with a little file.sh, and shortcut key, the use of mplayer isn't a problem for now).

I'm available for all testing you want, I like it
psychok9 is offline   Reply With Quote
Old 12-16-08, 07:38 PM   #317
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
Also, the frames-being-displayed-out-of-order is a known issue an being worked on as we speak.
<3
Big P is offline   Reply With Quote
Old 12-16-08, 08:28 PM   #318
damwid
Registered User
 
Join Date: Nov 2008
Posts: 10
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
@psychok9,

Can you describe the flickering in more detail. Is it tearing (i.e. what happens if sync-to-vblank isn't enabled for GL/XVideo apps), decode corruption, frames being displayed out of order, or something else?

FYI, the GL/Xv sync-to-vblank settings don't affect VDPAU. Also, the frames-being-displayed-out-of-order is a known issue an being worked on as we speak.
Hi Stephen,

Do you have an idea how long will the out-of-order problem be fixed? Currently mplayer-vdpau can play most of my HD videos, so it could be quite usable after the out-of-order problem is resolved.
damwid is offline   Reply With Quote
Old 12-16-08, 10:06 PM   #319
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

@damwind,

It looks like it should be fixed in the next driver/MPlayer-patch release. I can't comment on precisely when that'll be, but it shouldn't be long.
Stephen Warren is offline   Reply With Quote
Old 12-16-08, 10:09 PM   #320
theuni
Registered User
 
Join Date: Nov 2008
Posts: 27
Default Re: mplayer vdpau

Stephen-

Will the current reference frame limit be lifted in the next version as well?

TheUni
theuni is offline   Reply With Quote

Old 12-17-08, 05:31 AM   #321
phaedrusiszen
Registered User
 
Join Date: Dec 2008
Posts: 23
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
@damwind,

It looks like it should be fixed in the next driver/MPlayer-patch release. I can't comment on precisely when that'll be, but it shouldn't be long.
Just wanted to give my thanks to your efforts and those of the driver/programming group that's working on this. I'm glad I bought NVIDIA hardware and will continue to do so and I'll also continue to recommend NVIDIA to those seeking advice on what to buy, even those stuck in Windows land.

Last edited by phaedrusiszen; 12-17-08 at 05:31 AM. Reason: speling eror
phaedrusiszen is offline   Reply With Quote
Old 12-17-08, 06:45 AM   #322
dlknight
Registered User
 
Join Date: Dec 2008
Location: Worcester, UK
Posts: 9
Thumbs up Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
@Senor Hubris,

Tearing is a known issue in some X configurations right now. This will probably end up affecting interlaced output worse than progressive output, since the frame buffer is always "progressive", and hence tearing will affect multiple output fields in subtly odd ways.

You could try disabling the X composite extension to see if that works better for you (also disable SLI and any desktop rotation).
This is a top tip ! and has made my live tv image of BBC HD completely stable now in Mythtv

Many thanks
dlknight is offline   Reply With Quote
Old 12-17-08, 10:17 AM   #323
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by theuni View Post
Will the current reference frame limit be lifted in the next version as well?
Yes.
Stephen Warren is offline   Reply With Quote
Old 12-18-08, 08:28 AM   #324
molten_universe
Registered User
 
Join Date: Dec 2008
Posts: 1
Default Re: mplayer vdpau

Hello,

I have a constantly increasing delay between video and audio when I play a h264 mkv. This happens with all of my files. They are in sync when I play them without vdpau. The video itself is perfectly smooth, without framedrops!

I use nvidia-drivers 180.16 and mplayer built with the script from the mplayer-vdpau-3219724.tar.bz2.
molten_universe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.