Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-10-09, 12:14 PM   #493
zoomdoom
Registered User
 
Join Date: Jan 2009
Posts: 11
Default Re: mplayer vdpau

Some other regression seems to be going on. I used to be able to play the Killa Sampla (Google for it if you have never tried just fine but now it also fails with the same error.
Code:
VD_FFMPEG] Only buffers allocated by vo_vdpau allowed.
mplayer: libmpcodecs/vd_ffmpeg.c:1207: vdpau_get_buffer: Assertion `0' failed.
zoomdoom is offline   Reply With Quote
Old 01-10-09, 01:06 PM   #494
Senor Hubris
Registered User
 
Join Date: Mar 2007
Posts: 45
Default Re: mplayer vdpau

Quote:
Originally Posted by Fandorin View Post
Hi Senor Hubris,
Stephen has already commented on this issue. See here:
http://www.nvnews.net/vbulletin/showthread.php?t=125916

Regards
Thank you. I got into the habit of only watching this thread. Apparently not a good idea.
Senor Hubris is offline   Reply With Quote
Old 01-10-09, 04:22 PM   #495
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: mplayer vdpau

@Stephen Warren ;-)
Quote:
Originally Posted by Stephen Warren View Post
Code:
ps auxww|grep compiz
This will show what command-line arguments are being passed to compiz. My suspicion is that the Gentoo wrapper script is passing "--indirect-rendering" for some reason. This is much less efficient than direct rendering, and could be the cause of X using a lot of CPU.

If anyone else is seeing a problem with high CPU usage with compiz/similar running, please can you also run the above command, and also report exactly which distro you're running.

Thanks.
You are right :
greg 3369 0.4 0.3 127176 14688 tty1 S 23:01 0:04 compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering

I shall ask gentoo why it's this way, thank you very much!!!
Gregoire.Favre is offline   Reply With Quote
Old 01-11-09, 07:21 AM   #496
psofa
Registered User
 
Join Date: Nov 2006
Posts: 1
Default Re: mplayer vdpau

Hello! im using vdr with xine-vdpau on a 9500gt but the same problem appears in mplayer as well.
This clip from a 13E sat channel shows this corruption (see bottom).
Note that a guy with a pv-3 decoder card reports he doesnt see the corruptions while another with a gen2 decoder card confirms it.
Is it possible for an nvidia guy to confirm its a driver issue?
thanks
psofa is offline   Reply With Quote
Old 01-12-09, 12:16 PM   #497
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by zoomdoom View Post
Some other regression seems to be going on. I used to be able to play the Killa Sampla (Google for it if you have never tried just fine but now it also fails with the same error.
Code:
VD_FFMPEG] Only buffers allocated by vo_vdpau allowed.
mplayer: libmpcodecs/vd_ffmpeg.c:1207: vdpau_get_buffer: Assertion `0' failed.
I think this is mostly just an MPlayer and reference frames issue. The portion of killa that I have will play if I:

* Increase NUM_VIDEO_SURFACES_H264 to 18
* Hard-code max_references to 16
Stephen Warren is offline   Reply With Quote
Old 01-12-09, 12:33 PM   #498
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by psofa View Post
Hello! im using vdr with xine-vdpau on a 9500gt but the same problem appears in mplayer as well.
This clip from a 13E sat channel shows this corruption (see bottom).
Note that a guy with a pv-3 decoder card reports he doesnt see the corruptions while another with a gen2 decoder card confirms it.
Is it possible for an nvidia guy to confirm its a driver issue?
thanks
Thanks for the clip. We'll add it to our test pool. We're aware that some clips have the corruption shown in the screenshot, but haven't yet had a chance to look into this particular issue.
Stephen Warren is offline   Reply With Quote
Old 01-12-09, 12:41 PM   #499
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: mplayer vdpau

So, are there any builds (mplayer, VLC) that have vdpau implented by default?
By this i mean that it's possible to open a h264 file in VLC or mplayer and it will automatically use vdpau? I don't wanna use the command line everytime i wanna watch a HD movie..(I also need to add subtitles...etc..)
Duran is offline   Reply With Quote
Old 01-12-09, 01:04 PM   #500
zoomdoom
Registered User
 
Join Date: Jan 2009
Posts: 11
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
I think this is mostly just an MPlayer and reference frames issue. The portion of killa that I have will play if I:

* Increase NUM_VIDEO_SURFACES_H264 to 18
* Hard-code max_references to 16

Interestingly, that fixed the issue with the other file I could not get to play, but killasampla still fails.

I think I'll downgrade to 180.18 and see whether I can get it to play there. If so, it clearly is a regression in the driver...
zoomdoom is offline   Reply With Quote

Old 01-12-09, 01:36 PM   #501
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: mplayer vdpau

Quote:
Originally Posted by roberth View Post
Could someone make a patch that apply that change in vo_vdpau.c?
I have created a package for Ubuntu with those patches in.
Also added a 180.22 ubuntu package.

Repository is:
http://www.avenard.org/files/ubuntu-repos

As for a patch:
Code:
diff -urNad mplayer-vdpau~/libvo/vo_vdpau.c mplayer-vdpau/libvo/vo_vdpau.c
--- mplayer-vdpau~/libvo/vo_vdpau.c	2009-01-13 04:50:26.000000000 +1100
+++ mplayer-vdpau/libvo/vo_vdpau.c	2009-01-13 04:51:31.000000000 +1100
@@ -701,7 +701,7 @@
             uint32_t round_width = (vid_width + 15) & ~15;
             uint32_t round_height = (vid_height + 15) & ~15;
             uint32_t surf_size = (round_width * round_height * 3) / 2;
-            max_references = (12 * 1024 * 1024) / surf_size;
+            max_references = ((12 * 1024 * 1024) / surf_size) + 11;
             if (max_references > 16) {
                 max_references = 16;
             }
jyavenard is offline   Reply With Quote
Old 01-12-09, 01:54 PM   #502
quadtree
Registered User
 
Join Date: Jan 2009
Posts: 34
Default Re: mplayer vdpau

Quote:
Originally Posted by Duran View Post
So, are there any builds (mplayer, VLC) that have vdpau implented by default?
By this i mean that it's possible to open a h264 file in VLC or mplayer and it will automatically use vdpau? I don't wanna use the command line everytime i wanna watch a HD movie..(I also need to add subtitles...etc..)
For mplayer, just add the codecs and video output drivers you want to to your ~/.mplayer/config file. If you use a trailing comma in each setting, mplayer will try default codecs/outputs if it can't used the listed ones with the media you're playing.
Here's mine as an example:

# Default to VDPAU output and codecs
# (vc1/wmv3 not included since they're not currently supported on the 8600GT)
vo=vdpau,xv,
vc=ffh264vdpau,ffmpeg12vdpau,

With those settings, mplayer first tries to use the ffh264vdpau codec, then ffmpeg12vdpau. If neither work, it then goes through its normal list of codecs.
quadtree is offline   Reply With Quote
Old 01-12-09, 02:18 PM   #503
bgmiki
Registered User
 
Join Date: Jan 2009
Posts: 1
Default Re: mplayer vdpau

tnx to nvidia 180.22 i can play mkv files (720 and 1080) . i enable subtitle and mplayer-vdpau works great in smplayer ( see my post here http://smplayer.berlios.de/forums/vi...pid=4224#p4224)
bgmiki is offline   Reply With Quote
Old 01-12-09, 03:07 PM   #504
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: mplayer vdpau

Tearing is gone when I disable the Composite extension

However, video and sound is then not in sync. Sound is about .5s ahead of video and that gap keep increasing...

However, video is almost perfect with VDPAU, very impressed.. it's getting there

In the console I get:
Code:
myth@pcliving:~$ mplayer -fs /data/videos/High-Def/dfn_stardust1080.mkv 
MPlayer dev-SVN-r28045-4.3.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU         E8500  @ 3.16GHz (Family: 6, Model: 23, Stepping: 10)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick

Playing /data/videos/High-Def/dfn_stardust1080.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "Stardust", -vid 0
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang eng
[mkv] Track ID 3: subtitles (S_TEXT/UTF8), -sid 0, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x800  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1920 x 800 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x800 => 1920x800 H.264 HIGH VDPAU acceleration  [fs]
A: 137.6 V: 137.1 A-V:  0.485 ct: -0.002   0/  0  0% 96%  3.5% 2888 0 

           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.
That's on a 3.2GHz Core 2 Duo... Not a slow machine really !
jyavenard is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 12:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.