Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-24-09, 12:13 PM   #613
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: mplayer vdpau

Quote:
Originally Posted by julien-1993 View Post
@moonitie

how do u measure power comnsumption ?
P3 Kill a watt http://www.newegg.com/Product/Produc...82E16882715001
mooninite is offline   Reply With Quote
Old 01-25-09, 05:43 AM   #614
Godlikearg
Registered User
 
Join Date: Jan 2009
Posts: 12
Default Re: mplayer vdpau

Hi everybody,

First of all, thanks for the excellent work that has been done on this front. I really appreciate not having to boot to Windows in order to watch a HD videos .

I've been happily watching 720p videos for a while now flawlessly. However, I wanted to watch a few 1080p videos I have and never could. Some of them don't work with HA even on Windows (my guess is they were badly ripped) but just now I tried a sample from h264info.com (the Bourne Ultimatum trailer) and it failed with error 14.

Before submitting any bug reports, a few thinks I'd like to say:

1) I have a GF 9600GT (G94). Is this card supposed to be 1080p capable or should I consider myself lucky if I open any 1080p stream at all?
2) I have set max_ref frames to 16 in vo_vdpau.c, but to no avail.

Any help will be greatly appreciated.

Thanks in advance

Godlikearg.-
Godlikearg is offline   Reply With Quote
Old 01-25-09, 10:46 AM   #615
Edna K.
Registered User
 
Join Date: Jan 2009
Posts: 1
Default Re: mplayer vdpau

Quote:
Originally Posted by Godlikearg View Post
However, I wanted to watch a few 1080p videos I have and never could.
Hi,

try raising NUM_VIDEO_SURFACES_H264 in line 93 in vo_vdpau.c.
I set it to 32 this works best for me. Too low or too high values somehow produce choppy video playback on my machine.
Edna K. is offline   Reply With Quote
Old 01-25-09, 04:54 PM   #616
Godlikearg
Registered User
 
Join Date: Jan 2009
Posts: 12
Default Re: mplayer vdpau

Quote:
Originally Posted by Edna K. View Post
Hi,

try raising NUM_VIDEO_SURFACES_H264 in line 93 in vo_vdpau.c.
I set it to 32 this works best for me. Too low or too high values somehow produce choppy video playback on my machine.
Yeah, I had it set on 22, and couldn't open 1080p.

Strangest thing, I started not being able to even open 720p ones (error 23). Set it back to 17, recompiled, and still nothing. I rebooted and now not only I'm able to play 1080p, I'm also able to play some videos which even under the Windows driver I wasn't able (!).

I believe it was resource related?
Godlikearg is offline   Reply With Quote
Old 01-26-09, 05:55 PM   #617
seenxu
Registered User
 
Join Date: Nov 2008
Posts: 14
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
Error code 23 is VDP_STATUS_RESOURCES.

You're running of video RAM.
Is it possible to measure the current free video ram with a command or something? or how much video ram at least to have, to play a 1080p video?

I got a 8600GT with 512mb, sometimes after X up for more than 7 days, it will not allow me to playback 1080p videos, but at least restart X solve the problem.
seenxu is offline   Reply With Quote
Old 01-26-09, 08:04 PM   #618
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: mplayer vdpau

180.25 still requires compiz to be disabled to use VDPAU codecs properly.
mooninite is offline   Reply With Quote
Old 01-26-09, 09:58 PM   #619
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

New MPlayer patches are available at ftp://download.nvidia.com/XFree86/vd...402051.tar.bz2. This version is based on an ffmpeg snapshot that already includes VDPAU support.
Stephen Warren is offline   Reply With Quote
Old 01-26-09, 10:59 PM   #620
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
New MPlayer patches are available at ftp://download.nvidia.com/XFree86/vd...402051.tar.bz2. This version is based on an ffmpeg snapshot that already includes VDPAU support.
Hi Stephen.

Does this version fix or add any new features ?

I'm trying to build a package using the standard ubuntu mplayer build rules, but it fails..

I also notices that this mplayer doesn't build opengl rendering which I use..

If this new version doesn't add anything, I will live with the previous one for the time being
jyavenard is offline   Reply With Quote

Old 01-26-09, 11:40 PM   #621
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

There aren't any new VDPAU-related features in this latest MPlayer release, except slightly lower memory usage in some cases depending on screen/clip aspect ratio and size.

However, it'd be really great to have as many people use the new version as possible, because it uses VDPAU support that's part of official ffmpeg SVN, and we'd like to make sure that works correctly.
Stephen Warren is offline   Reply With Quote
Old 01-27-09, 04:34 AM   #622
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
However, it'd be really great to have as many people use the new version as possible, because it uses VDPAU support that's part of official ffmpeg SVN, and we'd like to make sure that works correctly.
I've built the packages, however, one video that use to play fine, now won't play
Code:
VIDEO:  [avc1]  1920x800  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 800 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x800 => 1920x800 H.264 HIGH VDPAU acceleration 
Error 25 at libvo/vo_vdpau.c:990:  0.003   0/  0 ??% ??% ??,?% 8 0
It plays fine with mythtv, and with the previous version of mplayer (though it may have been because it had this patch:
Code:
--- mplayer-vdpau~/libvo/vo_vdpau.c	2009-01-13 04:50:26.000000000 +1100
+++ mplayer-vdpau/libvo/vo_vdpau.c	2009-01-13 04:51:31.000000000 +1100
@@ -701,7 +701,7 @@
             uint32_t round_width = (vid_width + 15) & ~15;
             uint32_t round_height = (vid_height + 15) & ~15;
             uint32_t surf_size = (round_width * round_height * 3) / 2;
-            max_references = (12 * 1024 * 1024) / surf_size;
+            max_references = ((12 * 1024 * 1024) / surf_size) + 11;
             if (max_references > 16) {
                 max_references = 16;
             }
Packages is available in my repository:
Add:
deb http://www.avenard.org/files/ubuntu-repos files/
to your /etc/apt/sources.list
jyavenard is offline   Reply With Quote
Old 01-27-09, 05:55 AM   #623
TarrasQ
Registered User
 
Join Date: Mar 2004
Location: Oulu, Finland
Posts: 12
Default Re: mplayer vdpau

Compiling this gives me an error for videoSurfaces not being declared. I must be missing some dev package, but which one? I use Fedora 10.
__________________
You are - I might be also
TarrasQ is offline   Reply With Quote
Old 01-27-09, 06:16 AM   #624
seenxu
Registered User
 
Join Date: Nov 2008
Posts: 14
Default Re: mplayer vdpau

on ubuntu 8.10 amd64 / 8600GT 512mb / dual monitors 2 * 1680 x 1050, vdpau-3402051 compiled succesfully and tried with several 720p, 1080p apple trailers, all works.

thx for the great job!
seenxu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 10:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.