Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-09, 08:19 AM   #745
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: mplayer vdpau

the vo vdpau output is selected by default

(working time, sorry. reply later)
sl1pkn07 is offline   Reply With Quote
Old 02-10-09, 10:41 AM   #746
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by Dragoran View Post
That's a hack, the a real fix would be to detect the stream and adjust this dynamicly instead of hardcoding it.

Stephen already said that this has not been done because the initial ffmpeg version used to create the patch did not export this information, but now it should be possible to do.
The latest MPlayer patch should now create the correct number of reference frames automatically.
Stephen Warren is offline   Reply With Quote
Old 02-10-09, 10:43 AM   #747
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by assem046 View Post
What did you change where? libvo/vo_vdpau.c ?

This one:
#define NUM_VIDEO_SURFACES_H264 17

What number can it be? Is there a range between 0 and xxx?
There is no specific maximum for this values; it's just based on how much video RAM you have.
Stephen Warren is offline   Reply With Quote
Old 02-10-09, 10:44 AM   #748
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by sl1pkn07 View Post
Code:
switch (format) {
    case IMGFMT_VDPAU_H264_MAIN:
    case IMGFMT_VDPAU_H264_HIGH:
        {
            // FIXME: Use "h->sps.ref_frame_count" here instead.

            // Level 4.1 limits:
            uint32_t round_width = (vid_width + 15) & ~15;
            uint32_t round_height = (vid_height + 15) & ~15;
            uint32_t surf_size = (round_width * round_height * 3) / 2;
            max_references = (12 * 1024 * 1024) / surf_size;
            if (max_references > 16) {
                max_references = 16;
            }
        }
        break;
    default:
        max_references = 2;
        break;
    }
After that and before the if (IMGFMT_IS_VDPAU(image_format)) simply write :

Code:
max_references = 16;
The above change isn't required in the latest MPlayer patch; max_references is "calculated" automatically based off the information in the stream.
Stephen Warren is offline   Reply With Quote
Old 02-10-09, 12:13 PM   #749
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: mplayer vdpau

ok, im compiling latest mplayer by nvidia only with #define NUM_VIDEO_SURFACES_H264 hack (change 17 to 18). the all my videos (1080p/720p/480p) works again


jyavenard: in your latest mplayer version (mplayer_1.0-svn28348-vdpau-0ubuntu5)

MPlayer interrupted by signal 11 in module: filter video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
sl1pkn07 is offline   Reply With Quote
Old 02-10-09, 03:26 PM   #750
teox99
Registered User
 
Join Date: Jan 2009
Location: Italy - Rome
Posts: 56
Default Re: mplayer vdpau

mplayer-vdpau-3482714 works a little bit better and faster for h264 and vc-1 codec. no big prob to report.
thanks for the good job
teox99 is offline   Reply With Quote
Old 02-10-09, 05:34 PM   #751
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: mplayer vdpau

The bug that I reported earlier is still happening, with 180.29 and mplayer-vdpau-3482714.
System is still OpenSuSE 11.1 (gcc 4.3.2, could it be a compiler bug?), but now with kernel 2.6.29-rc3.
It happens with every video that I tested, with "-vo vdpau".
The codec (e.g. ffh264 or ffh264vdpau) makes no difference.
I remember that earlier versions of vdpau worked like a charm (32xxxxx and earlier I guess).
Code:
./mplayer -vo vdpau -vc ffh264vdpau /windows/C/Documents\ and\ Settings/DeiF/Mis\ documentos/Mis\ Vídeos/Muestras\ 720p/animusic_rc_m720p.mov                                      
MPlayer dev-SVN-r28348-4.3 (C) 2000-2009 MPlayer Team                                                                 
CPU: Intel(R) Core(TM)2 Duo CPU     T5450  @ 1.66GHz (Family: 6, Model: 15, Stepping: 13)                             
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1                                                           
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2                                                               
mplayer: could not connect to socket                                                                                  
mplayer: No such file or directory                                                                                    
Failed to open LIRC support. You will not be able to use your remote control.                                         

Playing /windows/C/Documents and Settings/DeiF/Mis documentos/Mis Vídeos/Muestras 720p/animusic_rc_m720p.mov.

libavformat file format detected.
[lavf] Audio stream found, -aid 0
[lavf] Video stream found, -vid 1
VIDEO:  [avc1]  1280x720  24bpp  29.970 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:                                                            
 name: Animusic - Resonant Chamber                                    
==========================================================================
Forced video codec: ffh264vdpau                                           
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1280x720 => 1280x720 H.264 HIGH VDPAU acceleration
VDPAU capture: Enabled
vdp_imp_device_create_x11(0x13c8d40, 0, -, -)
VDPAU nvidia: Error detected 1028 43  5
VDPAU nvidia: Backtrace:
01: /usr/lib64/libvdpau_nvidia.so [0x7fb5c6c07768]
VDPAU nvidia: Error detected 0 5357
VDPAU nvidia: Backtrace:
01: /usr/lib64/libvdpau_nvidia.so [0x7fb5c6c07768]
    -> 25
Error 25 at libvo/vo_vdpau.c:258
Please, tell me if there is anything I can test to help.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (34.2 KB, 126 views)
DeiF is offline   Reply With Quote
Old 02-10-09, 05:55 PM   #752
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

@DeiF,

Thanks for letting us know. We do have a bug filed on this, we just haven't fixed it yet.

FYI, this problem is due to the driver itself, not the MPlayer patch version.
Stephen Warren is offline   Reply With Quote

Old 02-10-09, 07:08 PM   #753
enito
Registered User
 
Join Date: Aug 2004
Posts: 23
Default Re: mplayer vdpau

Hi, i still have the same trouble, using latest one nvidia driver and my 8300 internal card. When i use vdpau in fast motion i see a line, not explicit a line , but is like when a fast movement is made and drive can process fine.. I hope you can understand, when i see video without vdpau i dont have any trouble , of course i get more use of my cpu. Any tip?

thx!!!

FIXED, composite disabled and now no tering
enito is offline   Reply With Quote
Old 02-11-09, 01:06 AM   #754
kross
Registered User
 
Join Date: Jan 2009
Posts: 11
Default Re: mplayer vdpau

I'm experiencing two problems with mplayer-vdpau-3482714 and driver 180.29.

First, it crashes in the same way (in some videos) as previous versions, before I set max_references to 16 manually. I will get a green screen, and many seconds later mplayer will exit with "Error 2 at libvo/vo_vdpau.c:1175".

If I change:

Code:
case IMGFMT_VDPAU_H264_HIGH:
    vdp_decoder_profile = VDP_DECODER_PROFILE_H264_HIGH;
    max_reference_frames = FFMIN(16, rndr->info.h264.num_ref_frames);
    break;
to

Code:
case IMGFMT_VDPAU_H264_HIGH:
    vdp_decoder_profile = VDP_DECODER_PROFILE_H264_HIGH;
    max_reference_frames = 16;
    break;
then it plays without error.

Second, I have some h.264 (I think) videos that don't seem to be hardware accelerated. I get the "Your system is too SLOW to play this!" warning in mplayer. Video then lags behind audio by several seconds, or video is jerky.

I have a test clip that shows both problems. All the output from mplayer says it's h.264, but it doesn't seem to be hardware accelerating the decoding. And at 84.5 seconds in, I get the crash.

http://download.statuspro.tv/test.mkv

It's about 115 MB. I just truncated a much larger mkv file. If I knew how to extract from the middle of an mkv file, I would.

Thanks!
-- Kevin
kross is offline   Reply With Quote
Old 02-11-09, 06:24 AM   #755
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: mplayer vdpau

Quote:
Originally Posted by kross View Post
I have a test clip that shows both problems. All the output from mplayer says it's h.264, but it doesn't seem to be hardware accelerating the decoding. And at 84.5 seconds in, I get the crash.

http://download.statuspro.tv/test.mkv

It's about 115 MB. I just truncated a much larger mkv file. If I knew how to extract from the middle of an mkv file, I would.

-- Kevin
Just tried your video, and it plays just fine with VDPAU with about 4% CPU usage only...
I only get a green screen when it reaches the end of the video.
jyavenard is offline   Reply With Quote
Old 02-11-09, 06:37 AM   #756
Fruit
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Re: mplayer vdpau

Using mplayer-vdpau-3482714 I get the following error on some files:

vo_vdpau: get_image failed
[VD_FFMPEG] Only buffers allocated by vo_vdpau allowed.
mplayer: libmpcodecs/vd_ffmpeg.c:1198: vdpau_get_buffer: Assertion `0' failed.

I can fix this by increasing NUM_VIDEO_SURFACES_H264 to 18.

Patch: http://www.fruit.je/y/more-surfaces.diff
Sample file (13 MiB): http://www.fruit.je/y/pe-001.mkv

GeForce 8600 GT (rev a1) 256 MB
Driver 180.27-0ubuntu1

cheers

Last edited by Fruit; 02-11-09 at 10:25 AM. Reason: add memory info
Fruit is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 09:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.