Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-09, 06:35 PM   #997
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by yau3 View Post
I noticed a strange problem with deinterlacing on one clip I have (1080i60 MBAFF H.264), which was transcoded using x264 from a 1080i60 MPEG-2 source (The source has no problems).

When I enable VDPAU deinterlacing on it, audio and video quickly lose sync (Video plays too slow). In this case it does not matter whether I use software or hardware decoding. I tested this using SVN revisions 28971 and 28950.

Strangely, when using MPlayer SVN revision 28950 using this patch from the mailing list, deinterlacing is fine using both software decoding (with -vo vdpau:deint=4) and hardware decoding (with -vo vdpau:deint=2). It seems that this patch has a positive impact on deinterlacing performance which the newer version doesn't have.
Note that "this patch" should not be different from r28971. If you see differences, I'm quite sure it is because deint=4 was not working with "this patch" (the first version of the patch I posted yesterday).
I'll try to explain:
(deint=1 shows only one field: This might be ok in some circumstances, but it is not deinterlacing)
deint=2 should never have any performance impact, but should always look worse than deint=3 (deint=2 is approximately the same as -vf tfields=1)
deint=3 has some performance impact, but looks as good as -vf yadif
deint=4 has strong performance impact, and looks similar to deint=3 imo
You can improve the performance of deint=3 and deint=4 with nochroma-deint, this looks very similar and slightly improves performance
AFAIK, performance is depending on: output display size (i.e. my pal sample looses sync with deint=4 if I use fullscreen, but works in window mode) and your hardware (video memory bandwidth)
Currently, deint=3 and deint=4 only work with software decoders, for hardware accelerated decoding, deint>2 is automatically corrected to deint=2

Hope that helps, Carl Eugen

Last edited by cehoyos; 03-19-09 at 11:42 AM.
cehoyos is offline   Reply With Quote
Old 03-16-09, 10:16 PM   #998
nullack
Registered User
 
Join Date: Oct 2007
Posts: 74
Default Re: mplayer vdpau

Wow! Im genuienly blown away by how good ffmpeg and mplayer are these days. A wmapro decoder! awesome. And Carl I see youve been doing vdpau deinterlace stuff too, simply fantastic. If I was a billionare, there'd be a sizeable donation to the two projects!
nullack is offline   Reply With Quote
Old 03-16-09, 10:23 PM   #999
yau3
Registered User
 
Join Date: Dec 2008
Posts: 14
Default Re: mplayer vdpau

cehoyos,

thank you for your reply. I am aware of what you have described; the strange thing here though is that the problem appears for me using any deint greater than 1, and only on this 1080i60 file. Performance-wise, there should therefore be no difference to other files when using software decoding, but there is.

Okay, this is kind of hard to describe. I'll give you an example:
I use the following command line (both commands behave nearly identically in this case):
Code:
mplayer -vo vdpau:deint=2 -vc ffh264 <FILE>
mplayer -vo vdpau:deint=2 -vc ffh264vdpau <FILE>
Note that I'm not using any advanced deinterlacing here.

With SVN 28950 + version 1 of the patch, the stream plays fine (this is also true for any deint values greater than 2 in software mode).
With SVN 28950 + version 4 of the patch OR SVN 28971, the stream desyncs slowly (and even faster when using -vc ffh264 and -vo vdpau:deint=4).

I think I'll upload my sample - can I upload it to ftp://ffmpeg.org/MPlayer/incoming/?
yau3 is offline   Reply With Quote
Old 03-17-09, 04:20 AM   #1000
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by yau3 View Post
I think I'll upload my sample - can I upload it to ftp://ffmpeg.org/MPlayer/incoming/?
Of course.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 03-17-09, 08:58 AM   #1001
yau3
Registered User
 
Join Date: Dec 2008
Posts: 14
Default Re: mplayer vdpau

OK, I'v uploaded the file. It's called "vdpau-deinterlacing-anomaly.mp4".
It has been transcoded from the "hdtv_demo.tp" sample floating around.
yau3 is offline   Reply With Quote
Old 03-18-09, 10:16 AM   #1002
BassKnight
Registered User
 
Join Date: Nov 2007
Posts: 20
Default Re: mplayer vdpau

I have two machines, one running Ubuntu AMD64 and other running Ubuntu i386. The 64-bit system has a 8500GT and the 32bit system has a 8200IGP. Some files play fine in the 64-bit system, but in the 32-bit system mplayer only shows green garbage. I'm using SVN r28990.

Sample: http://www.sendspace.com/file/t6c3yz
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.7 KB, 106 views)
File Type: gz clannad_sample_stderr.log.gz (15.2 KB, 108 views)
BassKnight is offline   Reply With Quote
Old 03-19-09, 10:34 AM   #1003
ikari_01
Registered User
 
Join Date: Mar 2006
Location: Hannover
Posts: 9
Send a message via ICQ to ikari_01
Default Re: mplayer vdpau

Hi,
I can't get playback to work with VDPAU with any supported format.
MPlayer just logs some errors and exits. No video window is displayed.

I tried all of the video files posted by Plagman on page 1.

The error messages are quite the same with any type of file I tried (e.g. h264)

Code:
[h264_vdpau @ 0x88d1980]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x88d1980]decode_slice_header error
[h264_vdpau @ 0x88d1980]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x88d1980]decode_slice_header error
[h264_vdpau @ 0x88d1980]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x88d1980]decode_slice_header error
[h264_vdpau @ 0x88d1980]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x88d1980]decode_slice_header error
[h264_vdpau @ 0x88d1980]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x88d1980]decode_slice_header error
[h264_vdpau @ 0x88d1980]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x88d1980]decode_slice_header error
[h264_vdpau @ 0x88d1980]no frame!
I then ran:
Code:
$ export VDPAU_TRACE=1
$ export VDPAU_NVIDIA_DEBUG=3
$ ./mplayer -v -vo vdpau -vc ffh264vdpau /mnt/shion/media/clips/vdpau-test/Grey.ts >/tmp/mplayer.stdout.log 2>/tmp/mplayer.stderr.log
to create the attached log files.

MPlayer/gcc version is: MPlayer SVN-r29002-4.3.2.
MPlayer compiled with: ./configure --enable-vdpau && make -j3

Playback works, albeit with tearing, when stripping the 'vdpau' from the -vc option (e.g. -vc ffh264 instead of -vc ffh264vdpau). Adding '-demuxer lavf' did not help.

Tried with 180.37 and 185.13.

EDIT:
I just discovered it works perfectly when running mplayer as root! Now what Seems I need to fix some permissions, but which?
Attached Files
File Type: log mplayer.stdout.log (9.4 KB, 103 views)
File Type: log mplayer.stderr.log (2.5 KB, 98 views)
File Type: gz nvidia-bug-report.log.gz (36.5 KB, 105 views)
ikari_01 is offline   Reply With Quote
Old 03-19-09, 11:02 AM   #1004
BassKnight
Registered User
 
Join Date: Nov 2007
Posts: 20
Default Re: mplayer vdpau

ikari_01: check the permissions on /dev/nvidiactl, generally owned by user root and group video. If that's the case, simply do:

Code:
usermod -a -G video your_user_name
And restart your session.

Additionaly, in order to remove tearing, try disabling the composite extension.
BassKnight is offline   Reply With Quote

Old 03-19-09, 11:16 AM   #1005
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by ikari_01 View Post
Hi,
I can't get playback to work with VDPAU with any supported format.
MPlayer just logs some errors and exits. No video window is displayed.
Please do not use the configure option --enable-vdpau. It does not do what you expect.
If you have to send another log file, please put stdout and stderr together in one file. Imo, they are unreadable as-is.

I hope BassKnight is right about your problems, Carl Eugen
cehoyos is offline   Reply With Quote
Old 03-19-09, 11:39 AM   #1006
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by yau3 View Post
Code:
mplayer -vo vdpau:deint=2 -vc ffh264 <FILE>
mplayer -vo vdpau:deint=2 -vc ffh264vdpau <FILE>
Note that I'm not using any advanced deinterlacing here.

With SVN 28950 + version 1 of the patch, the stream plays fine (this is also true for any deint values greater than 2 in software mode).
With SVN 28950 + version 4 of the patch OR SVN 28971, the stream desyncs slowly (and even faster when using -vc ffh264 and -vo vdpau:deint=4).
I can confirm that my first patch was "faster" than current svn (with your sample).
Note however that I can still use deint=2 with latest svn (easily with and still working without hardware acceleration) and even with my "faster" patch, deint=3 shows steadily increasing desync with -vc ffh264 for me.
Imo, the sample is just too complex to allow advanced deinterlacing on slow hardware, but if you find a solution that improves the situation for you: Patch welcome!

Sorry for the delay, deinterlacing with hardware accelerated decoding had priority, Carl Eugen
cehoyos is offline   Reply With Quote
Old 03-19-09, 11:55 AM   #1007
ikari_01
Registered User
 
Join Date: Mar 2006
Location: Hannover
Posts: 9
Send a message via ICQ to ikari_01
Default Re: mplayer vdpau

@BassKnight:
Thanks , I'm already in group video though. /dev/nvidiactl was root:root with 666 permissions, so I should have had access anyway. I changed /dev/nvidiactl to root:video to no avail.
Guess I'll take a hard look at the strace. Anyway, it's good to see this work in general

@cehoyos:
Sorry about the logs.
My bad also about the --enable-vdpau option. I expected I would need to specify it because when I didn't, configure listed vdpau under the disabled optional drivers.

Anyway, kudos to everyone involved in making it happen!
ikari_01 is offline   Reply With Quote
Old 03-19-09, 01:10 PM   #1008
ikari_01
Registered User
 
Join Date: Mar 2006
Location: Hannover
Posts: 9
Send a message via ICQ to ikari_01
Thumbs up Re: mplayer vdpau

Now it works!

I had vf=pp=ac in my ~/.mplayer/config which seems to collide. (apparently via color space mismatches or the likes.)
ikari_01 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 12:36 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.