Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-14-09, 12:55 AM   #1069
eisman
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: mplayer vdpau

Still nothing on menu support?
eisman is offline   Reply With Quote
Old 04-14-09, 02:38 AM   #1070
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by skeptic View Post
I solved the tearing problem adding the following to my /etc/X11/xorg.conf file:
I believe upgrading the driver to version 185 should also fix tearing.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 04-14-09, 02:40 AM   #1071
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by eisman View Post
Still nothing on menu support?
While I understand that you are unhappy with menu not working with hardware decoding, this has not much to do with vdpau: MPlayer's menu is simply broken, and, unfortunately, no developer is currently working on fixing this issue.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 04-14-09, 06:06 PM   #1072
Nebulus
Registered User
 
Join Date: Jan 2005
Posts: 23
Default Re: mplayer vdpau

Hi,

i cant playback my DVB-S2 (h264) recordings.

The Video playback loocks half the framerate it should have. So Audio and Video is desyncing directly after starting the playback.



Driver: NVIDIA-Linux-x86_64-180.44
Mplayer: MPlayer SVN-r29150-4.3.3 (C) 2000-2009 MPlayer Team


ERROR:
VDPAU_NVIDIA_DEBUG=3 mplayer /mnt/sdb6/HD_TS/Arthur\ und\ die\ Minimoys.ts -vo vdpau -vc ffh264vdpau
MPlayer SVN-r29150-4.3.3 (C) 2000-2009 MPlayer Team

Playing /mnt/sdb6/HD_TS/Arthur und die Minimoys.ts.
TS file format detected.
VIDEO H264(pid=767) AUDIO A52(pid=772) NO SUBS (yet)! PROGRAM N. 129
FPS seems to be: 25.000000
================================================== ========================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
================================================== ========================
================================================== ========================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
VDec: vo config request - 1920 x 1080 (preferred colorspace: H.264 VDPAU acceleration)
VDec: using H.264 VDPAU acceleration as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0xb70560]number of reference frames exceeds max (probably corrupt input), discarding one
Nebulus is offline   Reply With Quote
Old 04-14-09, 11:27 PM   #1073
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by dapharsyde View Post
When you say run mplayer without stdout/stderr redirected to file, where would I then see log information? I'm wondering if you meant that I *should* redirect to file, and I'm guessing I'd accomplish that by doing mplayer filename.mpg > log.txt ?
Yes, I meant with not without.

Quote:
Originally Posted by dapharsyde View Post
Is it safe to assume that Ubuntu 8.04 has the CONFIG_MAGIC_SYSRQ option enabled by default?
Honestly, I have no idea, but I certainly hope so.
Stephen Warren is offline   Reply With Quote
Old 04-15-09, 04:25 AM   #1074
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by Nebulus View Post
i cant playback my DVB-S2 (h264) recordings.

The Video playback loocks half the framerate it should have.
Please confirm that the video plays fine with mplayer -demuxer lavf -vc ffh264 -correct-pts
If it does not, this is not a VDPAU bug and should not be reported here.

Carl Eugen

PS: You could try -mc 100 -delay -0.n
cehoyos is offline   Reply With Quote
Old 04-15-09, 11:09 AM   #1075
olifre
Registered User
 
Join Date: May 2008
Posts: 50
Default Re: mplayer vdpau

Quote:
Originally Posted by dapharsyde View Post
Is it safe to assume that Ubuntu 8.04 has the CONFIG_MAGIC_SYSRQ option enabled by default?
The thing is: Yes, it has. However, it will NOT work when you are in X (at least not with Ubuntu 8.10, with 8.04, you should first try it out), for the new X-Server in Ubuntu uses another method to configure it's input-devices and thus stops SysRQ from working. In the "real" terminal, it still works fine - another method to enable it also if you are in X would be to readd the normal input devices to Xorg.conf (updating to the newest Ubuntu commented them all out).
olifre is offline   Reply With Quote
Old 04-15-09, 02:37 PM   #1076
Nebulus
Registered User
 
Join Date: Jan 2005
Posts: 23
Default Re: mplayer vdpau

Quote:
Originally Posted by cehoyos View Post
Please confirm that the video plays fine with mplayer -demuxer lavf -vc ffh264 -correct-pts
If it does not, this is not a VDPAU bug and should not be reported here.

Carl Eugen

PS: You could try -mc 100 -delay -0.n

mplayer -demuxer lavf -vc ffh264 -correct-pts Der\ goldene\ Kompass.ts -mc 100 -delay -0.0
and:
mplayer -vo vdpau -vc ffh264vdpau -correct-pts Der\ goldene\ Kompass.ts -mc 100 -delay -0.0

Plays the Recording , Audio and Video are in Sync, but the Videoplayback is not smooth and VERY choppy.
Output:
pts value < previousV: -0.167 ct: -0.712 0/ 0 28% 9% 8.3% 34 0
pts value < previousV: -0.095 ct: -0.756 0/ 0 26% 8% 7.0% 34 0
pts value < previousV: -0.022 ct: -0.782 0/ 0 25% 8% 5.1% 34 0
pts value < previousV: 0.000 ct: -0.782 0/ 0 25% 8% 4.6% 34 0
and so on...
Nebulus is offline   Reply With Quote

Old 04-16-09, 01:56 AM   #1077
dapharsyde
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: mplayer vdpau

Quote:
Originally Posted by olifre View Post
The thing is: Yes, it has. However, it will NOT work when you are in X (at least not with Ubuntu 8.10, with 8.04, you should first try it out), for the new X-Server in Ubuntu uses another method to configure it's input-devices and thus stops SysRQ from working. In the "real" terminal, it still works fine - another method to enable it also if you are in X would be to readd the normal input devices to Xorg.conf (updating to the newest Ubuntu commented them all out).
Supposing that I'm unable to get SysRq to do anything in 8.04, what are these "normal" input devices that I need to put into my xorg.conf file?

My xorg.conf file's input device section currently looks like this:

Code:
Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
EndSection
dapharsyde is offline   Reply With Quote
Old 04-16-09, 06:33 AM   #1078
yau3
Registered User
 
Join Date: Dec 2008
Posts: 14
Default Re: mplayer vdpau

Quote:
Originally Posted by Nebulus View Post
Plays the Recording , Audio and Video are in Sync, but the Videoplayback is not smooth and VERY choppy.
It appears that H.264 using PAFF interlacing is broken in MPlayer (This bug has been there for at least two years). For every field, one frame is displayed (It should be one frame for every two fields). I have not yet seen a PAFF sample that plays correctly. MBAFF interlacing is fine, though. However, most DVB-S2 broadcasts seem to use PAFF. In Germany, that would be the channels Premiere, ANIXE HD and ASTRA HD+.
yau3 is offline   Reply With Quote
Old 04-18-09, 01:14 PM   #1079
psychok9
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: mplayer vdpau

With last 185.19 and VDPAU, vsync is enabled on twinview?
I've many problems with the 2nd TV LCD (and I've disabled the 1st PC monitor when I use it).
With 1st only enabled I've forced vsync on and it works.
psychok9 is offline   Reply With Quote
Old 04-19-09, 01:49 PM   #1080
Sky777
Registered User
 
Join Date: May 2007
Posts: 65
Default Re: mplayer vdpau on slow CPU and PCI card

which Mplayer option can help to improve the playback of h264 1080i files on slow CPU (pentium 4 3 Пря and PCI vdpau card Sparkle 8400)

Now I have the problem with the recording recorded with vdr 175

I have not so bad results only with these options

Quote:
mplayer 00001.ts -demuxer lavf -correct-pts -mc 100 -delay -0.0
but I would like to avoid the messages as

Quote:
[h264_vdpau @ 0x88c1680]mmco: unref short failure0 ??% ??% ??,?% 2 0
[h264_vdpau @ 0x88c1680]mmco: unref short failure
pts value < previousA-V: -0.829 ct: -0.277 0/ 0 ??% ??% ??,?% 12 0
pts value < previousA-V: -0.519 ct: -0.527 0/ 0 ??% ??% ??,?% 12 0
pts value < previousA-V: -0.203 ct: -0.761 0/ 0 39% 15% 6.4% 12 0
pts value < previousA-V: -0.046 ct: -0.782 0/ 0 31% 13% 5.7% 12 0
pts value < previousA-V: -0.001 ct: -0.783 0/ 0 25% 11% 6.2% 12 0
pts value < previousA-V: 0.029 ct: -0.770 0/ 0 23% 11% 6.0% 12 0
pts value < previousA-V: 0.048 ct: -0.747 0/ 0 21% 10% 5.6% 12 0




[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one
[h264_vdpau @ 0x88c1680]number of reference frames exceeds max (probably corrupt input), discarding one


[NULL @ 0x88c1680]missing picture in access unit 0 11% 8% 2.6% 12 0
[NULL @ 0x88c1680]missing picture in access unit 0 11% 8% 2.6% 12 0
[NULL @ 0x88c1680]missing picture in access unit 0 11% 8% 2.6% 12 0
the full MPLayer log you can find here is http://paste.org.ru/?e706k7

the sample you can find here is ftp:upload.mplayerhq.hu/MPlayer/incoming/00001.ts
Sky777 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 03:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.