Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-20-09, 02:52 AM   #1081
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau on slow CPU and PCI card

Quote:
Originally Posted by Sky777 View Post
I have not so bad results only with these options
Code:
mplayer 00001.ts -demuxer lavf -correct-pts -mc 100 -delay -0.0
0 is of course the default for delay, so you don't need it.
Quote:
but I would like to avoid the messages as
Did you read the fine manual?
There are different options to make mplayer more "quiet".

Carl Eugen

AFAICT, the correct way to quote from MPlayer's output is the CODE tag, not the QUOTE tag (that disappears when answering).
cehoyos is offline   Reply With Quote
Old 04-20-09, 08:23 PM   #1082
albatorsk
Registered User
 
Join Date: Jul 2005
Posts: 2
Default Re: mplayer vdpau

Quote:
Originally Posted by psychok9 View Post
With last 185.19 and VDPAU, vsync is enabled on twinview?
I've many problems with the 2nd TV LCD (and I've disabled the 1st PC monitor when I use it).
With 1st only enabled I've forced vsync on and it works.
Just a bump for this question as I was about to ask the same thing. I'm playing videos with mplayer, and when I'm using the xv output plugin I can switch which monitor I want vsync to apply to with the nvidia-settings application. That works very well. Unfortunately, I can't get any vsync on any screen when using the vdpau output plugin. I'm using TwinView in clone mode, by the way. nVidia driver 180.51. Is this expected behaviour? Is there a simple fix for this?
albatorsk is offline   Reply With Quote
Old 04-20-09, 09:23 PM   #1083
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

When using the blit-based presentation queue, sync-to-vblank is only available in 185.19 and later. The overlay-based presentation queue has always had sync-to-vblank. For the blit-based presentation queue, monitor selection is controlled by an environment variable; see the README for details.
Stephen Warren is offline   Reply With Quote
Old 04-21-09, 12:07 AM   #1084
yeye69
Registered User
 
Join Date: Dec 2008
Posts: 8
Default Re: mplayer vdpau

is there any link between a number of reference frames and wm (compiz, metacity)?

When I'm watching this:

Video
ID : 4113 (0x1011)
Menu ID : 1 (0x1)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Duration : 1h 44mn
Bit rate : 26.6 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16/9
Frame rate : 23.976 fps
Standard : NTSC
Resolution : 24 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.534

in metacity everything is ok, but in compiz mplayer gave me that:

[h264_vdpau @ 0x88d8ee0]number of reference frames exceeds max (probably corrupt input), discarding one
yeye69 is offline   Reply With Quote
Old 04-21-09, 01:18 AM   #1085
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: mplayer vdpau

Quote:
Originally Posted by yeye69 View Post
is there any link between a number of reference frames and wm (compiz, metacity)?

When I'm watching this:

Video
ID : 4113 (0x1011)
Menu ID : 1 (0x1)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Duration : 1h 44mn
Bit rate : 26.6 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16/9
Frame rate : 23.976 fps
Standard : NTSC
Resolution : 24 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.534

in metacity everything is ok, but in compiz mplayer gave me that:

[h264_vdpau @ 0x88d8ee0]number of reference frames exceeds max (probably corrupt input), discarding one
This sounds like you are running out of video memory .. which gpu is that?
Dragoran is offline   Reply With Quote
Old 04-21-09, 02:08 AM   #1086
yeye69
Registered User
 
Join Date: Dec 2008
Posts: 8
Default Re: mplayer vdpau

Sorry, I forgot to post a gpu's characteristics :

GF 9600GT 512M
yeye69 is offline   Reply With Quote
Old 04-21-09, 03:04 AM   #1087
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by yeye69 View Post
[h264_vdpau @ 0x88d8ee0]number of reference frames exceeds max (probably corrupt input), discarding one
This message indicates broken input (as it tries to say). It has not much to do with vdpau, you should get the same message with the software decoder (without "_vdpau").
But it is of course possible that there was a fatal problem before that triggers meaningless messages. Complete, uncut output of mplayer -v -vo vdpau -vc ffh264vdpau might help explaining that.

Carl Eugen

Last edited by cehoyos; 04-21-09 at 05:46 AM. Reason: Try to clarify
cehoyos is offline   Reply With Quote
Old 04-21-09, 04:37 AM   #1088
yeye69
Registered User
 
Join Date: Dec 2008
Posts: 8
Default Re: mplayer vdpau

mplayer -v -vo xv -vc ffh264

[h264 @ 0x88d8ee0]no picture
[h264 @ 0x88d8ee0]no picture8 ct: -0.000 2/ 2 ??% ??% ??,?% 0 0
[h264 @ 0x88d8ee0]no picture1 ct: -0.000 3/ 3 ??% ??% ??,?% 0 0
[ffmpeg] aspect_ratio: 1.777778t: -0.004 4/ 4 ??% ??% ??,?% 0 0
VDec: vo config request - 1920 x 1080 (preferred colorspace: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO Config (1920x1080->1920x1080,flags=0,'MPlayer',0x32315659)
VO: [xv] 1920x1080 => 1920x1080 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@goldbach.in-berlin.de> and others
[ASPECT] Warning: No suitable new res found!
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x59565955 (UYVY) packed
Xvideo image format: 0x30323449 (I420) planar
using Xvideo port 280 for hw scaling
*** [vo] Exporting mp_image_t, 1920x1080x12bpp YUV planar, 3110400 bytes
Unicode font: 4959 glyphs.
Unicode font: 4959 glyphs.
COLLECT_SECTION, start: 64, size: 184, collected: 184??% ??,?% 0 0
SKIP: 0+1, TID: 0, TLEN: 17, COLLECTED: 184
PARSE_PAT: section_len: 17, section 0/0
PROG: 0 (1-th of 2), PMT: 31
PROG: 1 (2-th of 2), PMT: 256
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 2, TLEN: 63, COLLECTED: 184
FILL_PMT(prog=1), PMT_len: 184, IS_START: 64, TS_PID: 256, SIZE=184, M=0, ES_CNT=4, IDX=0, PMT_PTR=0xa99b800
PROG DESCR, TAG=88, LEN=4(4)
PROG DESCR, TAG=88, LEN=4(4)
...descr id: 0x28, len=4
PARSE_PMT(1 INDEX 0), STREAM: 0, FOUND pid=0x1011 (4113), type=0x10000005, ES_DESCR_LENGTH: 6, bytes left: 27
...descr id: 0x5, len=4
PARSE_PMT(1 INDEX 1), STREAM: 1, FOUND pid=0x1100 (4352), type=0x2000, ES_DESCR_LENGTH: 6, bytes left: 16
...descr id: 0x5, len=4
PARSE_PMT(1 INDEX 2), STREAM: 2, FOUND pid=0x1101 (4353), type=0x2000, ES_DESCR_LENGTH: 6, bytes left: 5
PARSE_PMT(1 INDEX 3), STREAM: 3, FOUND pid=0x1102 (4354), type=0x2001, ES_DESCR_LENGTH: 0, bytes left: 0
----------------------------
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 127, TLEN: 25, COLLECTED: 184
FILL_PMT(prog=0), PMT_len: 184, IS_START: 64, TS_PID: 31, SIZE=184, M=0, ES_CNT=0, IDX=1, PMT_PTR=0xa99b83c
COLLECT_SECTION, start: 64, size: 184, collected: 184 6% 11.2% 0 0
SKIP: 0+1, TID: 0, TLEN: 17, COLLECTED: 184
PARSE_PAT: section_len: 17, section 0/0
PROG: 0 (1-th of 2), PMT: 31
PROG: 1 (2-th of 2), PMT: 256
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 2, TLEN: 63, COLLECTED: 184
FILL_PMT(prog=1), PMT_len: 184, IS_START: 64, TS_PID: 256, SIZE=184, M=0, ES_CNT=4, IDX=0, PMT_PTR=0xa99b800
PROG DESCR, TAG=88, LEN=4(4)
PROG DESCR, TAG=88, LEN=4(4)
...descr id: 0x28, len=4
PARSE_PMT(1 INDEX 0), STREAM: 0, FOUND pid=0x1011 (4113), type=0x10000005, ES_DESCR_LENGTH: 6, bytes left: 27
...descr id: 0x5, len=4
PARSE_PMT(1 INDEX 1), STREAM: 1, FOUND pid=0x1100 (4352), type=0x2000, ES_DESCR_LENGTH: 6, bytes left: 16
...descr id: 0x5, len=4
PARSE_PMT(1 INDEX 2), STREAM: 2, FOUND pid=0x1101 (4353), type=0x2000, ES_DESCR_LENGTH: 6, bytes left: 5
PARSE_PMT(1 INDEX 3), STREAM: 3, FOUND pid=0x1102 (4354), type=0x2001, ES_DESCR_LENGTH: 0, bytes left: 0
----------------------------

last section repeats many times
yeye69 is offline   Reply With Quote

Old 04-21-09, 11:34 AM   #1089
Sky777
Registered User
 
Join Date: May 2007
Posts: 65
Default Re: mplayer vdpau on slow CPU and PCI card

Quote:
Originally Posted by cehoyos View Post
There are different options to make mplayer more "quiet".

no, I mean - is it possible to avoid that warnings at all on my slow system - even without -quiet option ? or my file-sample is corrupted ?
__________________
PCI Sparkle GeForce 8400 GPU G98 A2 512 MB + AMD Sempron(tm) Processor 2800+ + svn Mplayer + xine-vdpau rev. 279 + vdr 1.7.9 & Nvidia 190.25 + XBMC
Sky777 is offline   Reply With Quote
Old 04-21-09, 12:06 PM   #1090
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau on slow CPU and PCI card

Quote:
Originally Posted by Sky777 View Post
no, I mean - is it possible to avoid that warnings at all on my slow system
Please note that there are no "slow" systems when talking about VDPAU. All SSE capable systems are fast enough for (most) HDTV videos when using VDPAU. (There are of course GPU's not managing every de-interlacing mode for every input file.)
Quote:
- even without -quiet option ?
-really-quiet, -msglevel all=-1 are alternatives.
Quote:
or my file-sample is corrupted ?
Sort of. Since it is difficult (and sometimes impossible) to cut DVB recordings on an I-frame boundary, such recorded streams practically always produce output like yours.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 04-21-09, 04:01 PM   #1091
albatorsk
Registered User
 
Join Date: Jul 2005
Posts: 2
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
When using the blit-based presentation queue, sync-to-vblank is only available in 185.19 and later. The overlay-based presentation queue has always had sync-to-vblank. For the blit-based presentation queue, monitor selection is controlled by an environment variable; see the README for details.
Thanks! Upgrading to 185.19 and setting the env variable did the trick.
albatorsk is offline   Reply With Quote
Old 04-26-09, 02:39 PM   #1092
teox99
Registered User
 
Join Date: Jan 2009
Location: Italy - Rome
Posts: 56
Default Re: mplayer vdpau

Hello

I'm trying to get mplayer to play the TrueHD audio track in a file from a Blu-Ray disc (m2ts)
mplayer correctly recognizes the others AC3 audio tracks within the file but it fails to find the TrueHD audio track and Audio: no sound is provided.
exactly, tsMuxer recognize the audio tracks as AC3 core + True-HD

i tried with
mplayer -vc ffh264vdpau -vo vdpau -cache 8192 -ac hwdts,hwac3,ffmlp -aid 4352
mplayer -vc ffh264vdpau -vo vdpau -cache 8192 -demuxer lavf -aid 4352
mplayer -vc ffh264vdpau -vo vdpau -cache 8192 -ac ffmlp -aid 4352

What to do?
teox99 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 05:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.