Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-04-09, 11:30 AM   #1105
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by coolman7 View Post
Will Mplayer for Windows work with VDPAU?
There are no VDPAU implementations for Windows. The device creation API for Windows is not even defined.
Stephen Warren is offline   Reply With Quote
Old 05-05-09, 06:59 AM   #1106
The_Rebel
Registered User
 
Join Date: Jan 2009
Posts: 9
Default Re: mplayer vdpau

Have we got video filters working with VDPAU yet?
The_Rebel is offline   Reply With Quote
Old 05-05-09, 08:09 AM   #1107
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by The_Rebel View Post
Have we got video filters working with VDPAU yet?
While this is technically possible (the decoded image could be copied into the system's main memory), it will be slower than software decoding on most modern hardware, so it has no high priority atm.
Patch (for FFmpeg) of course welcome, Carl Eugen
cehoyos is offline   Reply With Quote
Old 05-05-09, 08:19 AM   #1108
apaige
Registered User
 
Join Date: Apr 2008
Posts: 106
Default Re: mplayer vdpau

At least -panscan works (that's pretty useful with 16/9 content on a 16/10 screen).
apaige is offline   Reply With Quote
Old 05-05-09, 08:26 AM   #1109
nullack
Registered User
 
Join Date: Oct 2007
Posts: 74
Default Re: mplayer vdpau

Windows uses DXVA
nullack is offline   Reply With Quote
Old 05-05-09, 08:27 AM   #1110
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by apaige View Post
At least -panscan works (that's pretty useful with 16/9 content on a 16/10 screen).
I use it as well on my 16/10 screen, but it is a vo function ("w" and "e" should work fine while playing), not a video-filter (they are activated with "-vf").

Carl Eugen
cehoyos is offline   Reply With Quote
Old 05-05-09, 08:53 AM   #1111
The_Rebel
Registered User
 
Join Date: Jan 2009
Posts: 9
Default Re: mplayer vdpau

Quote:
Originally Posted by nullack View Post
Windows uses DXVA
God bless Windows.
The_Rebel is offline   Reply With Quote
Old 05-12-09, 01:11 PM   #1112
play3r
Registered User
 
Join Date: Jan 2009
Posts: 10
Default Re: mplayer vdpau

Display problem with some VC1 streams
-------------------------------------

I started seeing this in backups of Planet Earth blu-rays. It doesn't occur all the time, but seems to occur when the camera pans down over a "complex" scene. I thought it was something about the Planet Earth discs. However, I then saw it in some other streams, but always VC1. The test file below, bottom_of_frames.m2ts, is a prime example of the problem.

The display problem is along the bottom edge of the picture. It appears to be some type of pixelation, but always along the bottom of the frame. The pixelation almost looks like a dynamic bar graph. The "bars" are white and vary in height. Best I can describe. Please look at the example.

The test stream is a short (just a few seconds) segment of a file that is much too long to upload/download. I can provide more if needed.

Both the graphics driver and mplayer were the latest at the time of the test:

NVIDIA Linux 180.51
MPlayer SVN-r29301-4.1.2

Axle AX-93GS nVidia 9300GS (G98) 512MB GDDR2 PCI-Express
X Window Server 7.1.1
KDE 3.5


Command line was:

mplayer -codecs-file /etc/mplayer/codecs.conf -demuxer lavf -vc ffvc1vdpau -vo vdpau -ac hwac3 -ao alsa:device=plughw=0.0 bottom_of_frames.m2ts


The test file was uploaded to https://partners.ftp.nvidia.com

Thanks in advance.
play3r is offline   Reply With Quote

Old 05-12-09, 04:54 PM   #1113
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

play3r, I have repro'd your issue and will file a bug.
Stephen Warren is offline   Reply With Quote
Old 05-13-09, 09:25 AM   #1114
play3r
Registered User
 
Join Date: Jan 2009
Posts: 10
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
play3r, I have repro'd your issue and will file a bug.
Great! Thank you for looking into this. I had tried several searches to find someone who had seen something similar, but had no luck. Glad your've now seen it, too.

With your knowledge of the internals, do you have a theory about what is happening?
play3r is offline   Reply With Quote
Old 05-13-09, 10:35 AM   #1115
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

play3r, Sorry, I don't have any better information on that problem yet. I'll post back here when I do.
Stephen Warren is offline   Reply With Quote
Old 05-14-09, 01:54 PM   #1116
eisman
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: mplayer vdpau

Still nothing on menu support? I have to ask all the time because the svn webbrowse is still offline. Are you going to keep it that way or are you waiting for something specific?
eisman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.