Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-23-09, 02:40 PM   #1141
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: mplayer vdpau

what about "-vc ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau" ???
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote
Old 06-23-09, 02:53 PM   #1142
teox99
Registered User
 
Join Date: Jan 2009
Location: Italy - Rome
Posts: 56
Default Re: mplayer vdpau

same prob

user[STREAM]$ mplayer -vc ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau, -vo vdpau -cache 8192 -vid 0 -ac hwdts,hwac3,ffac3 -demuxer lavf -aid 1 -fps 23.976 00000.m2ts
MPlayer SVN-r29382-4.2.4 (C) 2000-2009 MPlayer Team

Playing 00000.m2ts.
Cache fill: 0.00% (0 bytes)
libavformat file format detected.
LAVF: Program 1
[lavf] Video stream found, -vid 0
VIDEO: [HDMV] 1920x1080 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Forced video codec: ffh264vdpau
Forced video codec: ffmpeg12vdpau
Forced video codec: ffvc1vdpau
Forced video codec: ffwmv3vdpau
Cannot find codec matching selected -vo and video format 0x564D4448.
================================================== ========================
teox99 is offline   Reply With Quote
Old 06-24-09, 04:10 AM   #1143
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by teox99 View Post
Forced video codec: ffh264vdpau
Cannot find codec matching selected -vo and video format 0x564D4448.
Please upload a sample to
ftp://ffmpeg.org/MPlayer/incoming (write-only) and report the file-name here.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 06-24-09, 02:17 PM   #1144
teox99
Registered User
 
Join Date: Jan 2009
Location: Italy - Rome
Posts: 56
Default Re: mplayer vdpau

some probs using your ftp anyways
here it is
http://www.teoxonline.com/utils/00000.m2ts

thanks a lot and good luck!
teox99 is offline   Reply With Quote
Old 06-24-09, 02:40 PM   #1145
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: mplayer vdpau

Code:
General
ID                               : 0
Complete name                    : /home/dk75/Desktop/00000.m2ts
Format                           : BDAV
Format/Info                      : BluRay Video
File size                        : 57.5 MiB
Duration                         : 29s 529ms
Overall bit rate                 : 16.3 Mbps
Maximum Overall bit rate         : 48.0 Mbps

Video
ID                               : 4113 (0x1011)
Menu ID                          : 1 (0x1)
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.1
Format settings, CABAC           : Yes
Format settings, ReFrames        : 4 frames
Duration                         : 29s 529ms
Bit rate                         : 14.4 Mbps
Width                            : 1 920 pixels
Height                           : 1 080 pixels
Display aspect ratio             : 16/9
Frame rate                       : 23.976 fps
Resolution                       : 24 bits
Colorimetry                      : 4:2:0
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.289
Stream size                      : 50.6 MiB (88%)

Audio #1
ID                               : 4352 (0x1100)
Menu ID                          : 1 (0x1)
Format                           : AC-3
Format/Info                      : Audio Coding 3
Format profile                   : TrueHD
Duration                         : 28s 861ms
Bit rate mode                    : Variable
Bit rate                         : 640 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Surround: L R, LFE
Sampling rate                    : 48.0 KHz
Stream size                      : 2.20 MiB (4%)

Audio #2
ID                               : 4353 (0x1101)
Menu ID                          : 1 (0x1)
Format                           : AC-3
Format/Info                      : Audio Coding 3
Format profile                   : TrueHD
Duration                         : 28s 860ms
Bit rate mode                    : Variable
Bit rate                         : 640 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Surround: L R, LFE
Sampling rate                    : 48.0 KHz
Stream size                      : 2.20 MiB (4%)

Text
ID                               : 4608 (0x1200)
Menu ID                          : 1 (0x1)
Format                           : PGS


And here is MPlayer log ( it's playing it well )
http://pastebin.com/m240ac76c


I will compile latest SVN to check whatever it's playing it as this older one
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote
Old 06-24-09, 04:20 PM   #1146
teox99
Registered User
 
Join Date: Jan 2009
Location: Italy - Rome
Posts: 56
Default Re: mplayer vdpau

actually i'm using MPlayer SVN-r29382-4.2.4
with your cmd line
Code:
mplayer -v -noconfig all -alang eng,jpn,pol -vo vdpau -vc ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau -softvol -ass -vf-clr -fs -fontconfig -overlapsub -subfont-autoscale 1 -ffactor 10 -tskeepbroken -tsprobe 100000 00000.m2ts
the video starts but no audio is provided.
adding -demuxer lavf occurs same error "Cannot find codec matching selected -vo and video format 0x564D4448"

and it's seems the same for your output...
you can notify "Audio: no sound" at line 301 from your debug text

teox99 is offline   Reply With Quote
Old 06-24-09, 05:48 PM   #1147
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by teox99 View Post
VIDEO: [HDMV] 1920x1080 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Forced video codec: ffh264vdpau
Forced video codec: ffmpeg12vdpau
Forced video codec: ffvc1vdpau
Forced video codec: ffwmv3vdpau
Cannot find codec matching selected -vo and video format 0x564D4448.
Quote:
Originally Posted by teox99 View Post
actually i'm using MPlayer SVN-r29382-4.2.4
with your cmd line
[code]the video starts but no audio is provided.
I hope you agree that you make it very difficult to help you with a VDPAU problem (that you do not seem to have).

And no, I do not know why audio does not play for this sample, but this is certainly not the place to discuss it anyway.

Carl Eugen

PS: I see now that the video does not play with -demuxer lavf
I will look into that, but note that there were always some files that only played without -demuxer lavf and some that needed it.

Please try to always post uncut MPlayer output, it makes debugging much easier!

Last edited by cehoyos; 06-24-09 at 05:51 PM. Reason: After trying one more thing, I finally see the problem
cehoyos is offline   Reply With Quote
Old 06-24-09, 05:53 PM   #1148
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by teox99 View Post
VIDEO: [HDMV] 1920x1080 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
You can force the video codec:
mplayer -demuxer lavf -vc +ffh264
mplayer -demuxer lavf -vs +ffh264vdpau
both work.

Carl Eugen
cehoyos is offline   Reply With Quote

Old 06-26-09, 10:05 AM   #1149
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: mplayer vdpau

Though it's not VDPAU problem but I've done some investigation and MPlayer from "svn up '{2009-05-31}'" ( SVN-r29330 ) is playing it well with "-demuxer lavf" ( with sound, also my BRD "Discovery Atlas: Brazil Revealed" ) but MPlayer from "svn up '{2009-06-01}'" ( SVN-r29333 ) and newest, including yesterday's SVN-r29389 have these error ( also with my BRD "Discovery Atlas: Brazil Revealed" ).
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote
Old 06-26-09, 12:32 PM   #1150
teox99
Registered User
 
Join Date: Jan 2009
Location: Italy - Rome
Posts: 56
Default Re: mplayer vdpau

thx dk75!
i can confirm the error for SVN-r29382-4.2.4 too.

i hope it will be fix in next update?!
please!
teox99 is offline   Reply With Quote
Old 06-27-09, 12:56 PM   #1151
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: mplayer vdpau

Quote:
Originally Posted by cehoyos View Post
You can force the video codec:
mplayer -demuxer lavf -vc +ffh264
mplayer -demuxer lavf -vc +ffh264vdpau
both work.

Carl Eugen

i'm confirm this. BUT only agree "+" in sintax, without "+", all cases fail (error 0x564D4448)


all cases, no play sound for me :S (with force audio codec ffeac3 and mlp and with force substream "-ausid")

attached logs
Attached Files
File Type: txt ident.txt (98.9 KB, 116 views)
File Type: txt mediainfo.txt (2.5 KB, 116 views)
File Type: txt error.txt (2.9 KB, 125 views)
sl1pkn07 is offline   Reply With Quote
Old 06-28-09, 11:40 AM   #1152
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: mplayer vdpau

Quote:
Originally Posted by sl1pkn07 View Post
i'm confirm this. BUT only agree "+" in sintax, without "+", all cases fail (error 0x564D4448)
Please test latest svn before reporting problems (and that is also the reason why complete, uncut output of mplayer call is needed for every report).

Carl Eugen
cehoyos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 12:50 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.