Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-18-08, 01:25 PM   #1
bistory
Registered User
 
Join Date: Apr 2008
Posts: 46
Default [180.11] Screen off after suspend to ram

Hello !
I've a problem on my laptop.
When suspend my system to ram, I can't wake him correctly, my screen isn't powered on anymore and I can't shut him down with magic sys rq...
My laptop is a Sony VAIO FZ11E with a 8400M GT, I hadn't this problem since 175.x driver series
I use Ubuntu 8.10 with a customized kernel, but previous drivers worked without any problem

Thanks for your help !
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (32.7 KB, 185 views)

Last edited by bistory; 12-03-08 at 03:55 AM.
bistory is offline   Reply With Quote
Old 11-18-08, 02:44 PM   #2
Kirurgs
Registered User
 
Join Date: Jul 2007
Posts: 165
Default Re: [180.08] Screen off after suspend to ram

The same with me with 180.0x series... 177.82 drivers are last to be known to work and I'm using it.
I tried some additional quirks in the hal fdi files, nothing helps. One thing - first suspend works for me, second doesn't and nothing really helps, no ctrl+alt+del (bckspc), no sysrq...
In case additional bug report needed, please ask, I just don't know how to provide it as useful as possible as nothing works and screen is blank.
__________________
** Laptop T500: C2D 2.53Ghz, 4Gb RAM, Radeon Mobility HD3650, ArchLinux x86_64, Gnome, custom 2.6.35.7, Catalyst 10.10...
** Homebrew router/media server: Intel Celeron 1.2GHz 256Mb RAM, Intel Integrated Video, ArchLinux i686, no GUI, 2.6.33.4
** Homebrew desktop: AMD Phenom X4 9950 Black Edition, 4Gb RAM, integrated Radeon HD3300 + discrete Radeon 4850 512M, Windows 7 Ultimate (for games), ArchLinux i686, Gnome, 2.6.29, catalyst 9.4... (this now just rocks in lunix, really! )
Kirurgs is offline   Reply With Quote
Old 11-18-08, 03:48 PM   #3
bilbo75
Registered User
 
Join Date: Nov 2008
Posts: 1
Default Re: [180.08] Screen off after suspend to ram

Acer 5920G Geforce 8600M GS.Same issue here.First suspend to ram works, the next ones no.
Slackware 12.1 kernel 2.6.27.6
bilbo75 is offline   Reply With Quote
Old 11-18-08, 03:58 PM   #4
bistory
Registered User
 
Join Date: Apr 2008
Posts: 46
Default Re: [180.08] Screen off after suspend to ram

Either my first suspend isn't working :s
bistory is offline   Reply With Quote
Old 11-18-08, 05:28 PM   #5
nevion
Registered User
 
Join Date: Dec 2004
Posts: 74
Default Re: [180.08] Screen off after suspend to ram

I had already sent in a bug report to nvidia on this for 180.06, but its still the same for 180.08.
Nvidia, please respond!

Additionally, I know that you get the whole "its beta" argument but please focus on not breaking suspend with these beta releases. Primarily its my only problem with this series as it fixes all kde problems I was having. Working suspend and broken kde = dealbreaker. So please publish a 180 series with working suspend as soon as possible. At this point, I consider it the most important thing you could do in the entire 180 series now that kde/2d performance has improved so much.

Other notes: on resume, either the computer reboots after a few seconds without a proper shutdown or it remains with the screen blank (sometimes powered on, sometimes not). I haven't been able to ssh in while it does so....
nevion is offline   Reply With Quote
Old 11-19-08, 01:02 AM   #6
perfectska04
Registered User
 
Join Date: Nov 2008
Posts: 31
Default Re: [180.08] Screen off after suspend to ram

This also affects me with an Nvidia 8600M GT/Inspiron 1520 in Ubuntu Intrepid. Suspend has worked perfectly for me for all the driver releases in the past year, but both 180.* drivers I've tested break suspend. Perhaps the laptop does wake up, but the screen does not turn back on.

It's a shame, because I didn't notice anything else bad about this series but suspend is a deal breaker.
perfectska04 is offline   Reply With Quote
Old 11-19-08, 10:44 AM   #7
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: [180.08] Screen off after suspend to ram

Unfortunately I have to confirm that sometimes resume from s3 does not work, and the system is not in a state in which a bug report could be created.

Lenovo R61, nvidia nvs140m, problem occuring since 180.* series.

Please fix this nvidia, it used to work.

Fuchs
NvFuchs is offline   Reply With Quote
Old 11-22-08, 10:20 AM   #8
bistory
Registered User
 
Join Date: Apr 2008
Posts: 46
Default Re: [180.08] Screen off after suspend to ram

Nothing new ?
bistory is offline   Reply With Quote

Old 11-22-08, 01:54 PM   #9
dionua
Registered User
 
Join Date: Aug 2006
Posts: 35
Default Re: [180.08] Screen off after suspend to ram

+1 here.
dionua is offline   Reply With Quote
Old 11-22-08, 02:13 PM   #10
JakubZ
Registered User
 
Join Date: Sep 2006
Posts: 10
Default Re: [180.08] Screen off after suspend to ram

I have the same problem on my GForce 6600 GT. After updating to 180.08, suspend to ram no longer works.
JakubZ is offline   Reply With Quote
Old 11-23-08, 01:20 AM   #11
elonden
Registered User
 
Join Date: Nov 2008
Posts: 1
Default Re: [180.08] Screen off after suspend to ram

All,

Try using acpi_sleep=S3_bios or acpi_sleep=S3_mode as a kernel boot parameter. (modify the menu.lst in grub bootloader.)
During S3 resume (which happens after the machine has been suspended to RAM), hardware needs to be reinitialized properly. For most devices this is simple, except for video cards, which are normally initialized by the BIOS. The kernel does not have enough information to restore the video device, because that information is in the BIOS and not accessable at all. This option lets the kernel try to use the ACPI subsystem to restore the video card in two different ways.

If this doesn't work don't suspend your system. :-)

Regards,
Erwin
elonden is offline   Reply With Quote
Old 11-23-08, 09:33 AM   #12
nevion
Registered User
 
Join Date: Dec 2004
Posts: 74
Default Re: [180.08] Screen off after suspend to ram

Well what the hell, it works now. I used to have to use that trick back when this t61p was new but i thought hal and the fdi's it comes with grew beyond that, despite that the 177 series worked fine with suspend and resume without me having to supply the parameter to the kernel cmdline. Now I wonder what all that junk about power_management.quark.s3_mode=true or s3_bios crap in the fdi's is all about and why it doesn't take effect.

>>If this doesn't work don't suspend your system. :-)
Oh yea, thats a great solution....
nevion is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM

All times are GMT -5. The time now is 01:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.