Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-25-03, 10:26 AM   #1
Dirk
Registered User
 
Join Date: May 2003
Posts: 4
Default No Fast Writes enabled

Hi there

i try to get my graphics card enabled with agp fast writes, but this wont work. The nvidia driver tells me in

/proc/drivers/nvidia/agp/status

Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Enabled

Sys: Linux 2.4.20 (kernel.org)
Dist: SuSE 8.1
MB: K7VZA with VIA Technologies, Inc. VT8363/8365 [KT133/KM133] host-bridge
VGA: WinFast with GeForce4 MX 440 running AGP4X

How will I be able to enable FastWrites.

Thanks in advance for any hint.

Dirk
Attached Files
File Type: txt xf86config.txt (4.7 KB, 129 views)
Dirk is offline   Reply With Quote
Old 05-25-03, 11:25 AM   #2
DrOzz
Registered User
 
Join Date: May 2003
Location: Sydney, Nova Scotia
Posts: 70
Default

maybe in your bios....
DrOzz is offline   Reply With Quote
Old 05-25-03, 12:35 PM   #3
Dirk
Registered User
 
Join Date: May 2003
Posts: 4
Default No Fast Writes enabled

Hallo Dr. Ozz

i have got no options i my bios to explicit set AGP Fast Writes to true. I also read the whole dokumentation of my motherboard i found no hint about that. Is there a change to check wether it is a bios setting problem. I have a another pc using a Microstar mainboard with exactly the same problem. But on this board, the system dont know anything about the host-bridge (only PCI identifiert). So could it be a problem with the nvidia driver (wrong recognition of my host-bridge?).

Dirk
Dirk is offline   Reply With Quote
Old 05-25-03, 12:36 PM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

Really if options like Fast Writes / SBA are disabled leave them disabled. These options can be very, very unstable (especially on older chipsets). Because of this they are disabled and enabling them doesn't bring much extra performance (.1% or a little more).
Thunderbird is offline   Reply With Quote
Old 05-25-03, 01:34 PM   #5
Dirk
Registered User
 
Join Date: May 2003
Posts: 4
Default No Fast Writes enabled

Hallo Thunderbird

my problem is the performance, you´re right. A teammate has, like me, a Geforce 4 graphics adapter and he reaches about 6000 fps using glxgears. With an older card (Geforce 2) i get 2600 fps. With my new card i only get about 2000 fps. I think thats to less. I read all the hints that enabling Fast Writes will make the system instable but i like to test this. So if one can tell me a way to force my system to do so this would be great.

Dirk
Dirk is offline   Reply With Quote
Old 05-26-03, 03:12 AM   #6
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

Glxgears is not a real benchmark. The results you get are not really comparable to other systems (it are just plain polygons instead and no textures). Performance depends on color depth, resolution...

Compare performance of real games (quake3, rtcw, ut2003 ..).

And don't compare a GF4MX 440 with a GF4 Ti (likely your friend has such a geforce4). A Geforce4 Ti is a lot faster than a MX. Further a Geforce2 GTS is not much slower than a GF4MX440. In some cases it might even be faster. (4 pipelines vs 2 pipelines)
Thunderbird is offline   Reply With Quote
Old 05-26-03, 05:04 PM   #7
feeyo
Registered User
 
feeyo's Avatar
 
Join Date: Nov 2002
Location: Amsterdam
Posts: 140
Arrow

Hi,
Yes i was asking myself this 2. how can i enable Fast writes in the drivers. cause i have it enabled in my BIOS...

This is what is says on terminal:
Card: nVidia Geforce 2 MX/MX400
Card number: 1
Memory speed: 166.447 MHz
Core speed: 199.656 MHz

-- General info --
Card: nVidia Geforce 2 MX/MX400
PCI id: 0x110
GPU speed: 199.656 MHz
Bustype: AGP

-- Memory info --
Amount: 64 MB
Type: 128 bit SDR
Speed: 166.447 MHz

-- AGP info --
Status: Enabled
Rate: 4X
AGP rates: 1X 2X 4X
Fast Writes: Supported, Disabled
SBA: Unsupported, Disabled

Here it tells me it is supported but disabled.

Anybody know how to enable it???

Thanks.
__________________
http://www.agilityos.com
feeyo is offline   Reply With Quote
Old 05-26-03, 11:08 PM   #8
Dirk
Registered User
 
Join Date: May 2003
Posts: 4
Default No Fast Writes enabled

Hallo Thunderbird

yes, I got this information right now. I can`t compare the two card because the difference is to big.

But I think I can compare two linux systems using glxgears, can´t I (not in detail but there is a difference between 2000 and 6000 fps). Well the problem is my card and so thats all i wanted to know.

Thanks for the hint

Dirk
Dirk is offline   Reply With Quote

Old 05-27-03, 06:56 AM   #9
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

That 2000fps for a gf4mx is quite normal. Have a gf4mx420 here and it scores about 1700points. Your friend is very likely using a Geforce4Ti which is a much, much faster card.

And now to feeyo. First thanks for using my nvclock
For SBA/FW nvclock Unsupported/Supported means the following. When it shows supported it tells that the motherboard supports SBA/FW else it shows unsupported. If SBA/FW are supported it doesn't have to be enabled. These features are very unstable and don't give a real performance boost. (especially unstable on Via K*133*/appolo pro133* boards)

You can enable these features by editing os-registry.c of the nvidia kernel module or by adding some options to /etc/modules.conf. (look up the names in os-registry.c)
Thunderbird is offline   Reply With Quote
Old 05-27-03, 08:12 AM   #10
feeyo
Registered User
 
feeyo's Avatar
 
Join Date: Nov 2002
Location: Amsterdam
Posts: 140
Talking nvclock rules

NP thunderbird, its a cool tool

Bedankt, i will try to check the diffrences with fast writes enabled and disabled.
I have a nForce 2 motherboard so i dont think it will get to instable ( i hope ).
But i am just curious

peace.
__________________
http://www.agilityos.com
feeyo is offline   Reply With Quote
Old 05-27-03, 05:28 PM   #11
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

feeyo -- if nvclock only looks at the AGP bridge's capabilities (from Thunderbird's description, that sounds like it's the case), there's also a file that will tell you what the card itself supports. cat /proc/driver/nvidia/agp/card once, to see what the card hardware is telling the driver about fast write support.

I'm guessing that if you cat /proc/driver/nvidia/agp/host-bridge, it'll say "fast writes: supported". Check the card file too -- both have to say "supported" for the module parameter to do anything.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 05-28-03, 04:50 AM   #12
feeyo
Registered User
 
feeyo's Avatar
 
Join Date: Nov 2002
Location: Amsterdam
Posts: 140
Talking

Both supported

Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x1f000104


Host Bridge: PCI device 10de:01e0
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000104

So now i could enable it without any lags or probs??

Thanx.
__________________
http://www.agilityos.com
feeyo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make Your Own Cocoa Powder for Fast Chocolatey Drinks Anywhere You Go [Food] News Archived News Items 0 05-14-12 08:00 AM
AGP Fast write and SiS 735 not supported ? Chojin NVIDIA Linux 9 10-11-02 06:52 PM
how to activate fast writes and SBA cyzz NVIDIA Linux 7 10-08-02 06:38 AM
AGP not being enabled on Geforce2 mx frankjr NVIDIA Linux 1 09-22-02 02:01 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 11:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.