Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-29-08, 05:57 AM   #1
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

I'm using 180.08 with a Geforce Go 7600 on Ubuntu 8.04.
When I terminate glxgears, about 20 pixels from the right edge of the screen are displayed on the left side of the Monitor (moving the left edge of the screen to the right for about 20 pixels). Every part of the monitor image is displayed, but not at the right position. The image is shifted to the right and everything that is jutting out at the right is displayed on the left.
This only happens one time, I can not shift the image even further by repeatedly starting and stopping glxgears. If change the resolution of the monitor, the shift is gone, but it can be restored again by starting and stopping glxgears.
If I try to make a screen shot, I can not see this effect.
This "feature" was not present in 177.82.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (38.7 KB, 99 views)
Lysius is offline   Reply With Quote
Old 12-02-08, 05:18 PM   #2
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

I'm still seeing this in 180.11
Lysius is offline   Reply With Quote
Old 12-13-08, 08:25 AM   #3
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

Bug still exists with 180.16. And it is not limited to glxgears but openGL apps in general.
Lysius is offline   Reply With Quote
Old 12-16-08, 12:38 AM   #4
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

I have tested this with an other PC (7600GS and 7600GT) with 180.16 on Ubuntu 8.04 and there this bug also seems to be present.

Every time I killed glxgears, the monitor went blank, as if the resolution was changed for all three monitors on both cards. It seems as if the cards recovered from this error on their own, but it is quite disturbing.

Perhaps it is important to mention that I used kde 3.5 for all the tests.

EDIT: This is not specific to KDE 3.5, it also happens if I start and terminate glxgears from an xterm in plain X
Lysius is offline   Reply With Quote
Old 12-19-08, 07:48 AM   #5
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

Has nobody else seen this?
Lysius is offline   Reply With Quote
Old 12-29-08, 03:59 AM   #6
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

I also experience this with 180.11.02 and 180.18.

And I did some further testing and found that this does not happen with every OpenGL app. Prey (native Linux client) does not show this, no matter if I run it in full screen or windowed.
And it does only happen if I kill glxgears by using ctrl+c in the terminal window, if I just close the window, everything stays fine.
It also happens with all OpenGL screen savers I have tested.
Lysius is offline   Reply With Quote
Old 01-08-09, 04:48 PM   #7
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

So, this is my 6th answer to this thread...

But I still see this with 180.22.

I have attached a new bug report this generated after the bug happened.
Attached Files
File Type: gz nvidia-bug-report.log.gz (41.1 KB, 82 views)

Last edited by Lysius; 01-08-09 at 05:34 PM. Reason: Update bug report
Lysius is offline   Reply With Quote
Old 01-22-09, 04:01 AM   #8
Gr4ff1t1sTar
Registered User
 
Join Date: Jan 2009
Posts: 1
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

nothing

Last edited by Gr4ff1t1sTar; 12-01-10 at 10:28 AM.
Gr4ff1t1sTar is offline   Reply With Quote

Old 01-28-09, 07:49 AM   #9
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

Still happens with 180.25
Lysius is offline   Reply With Quote
Old 01-28-09, 05:52 PM   #10
chriswyatt
Registered User
 
Join Date: Jan 2009
Posts: 5
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

Got the same problem:

I started a thread on the Ubuntu forums, if you read, originally I thought it was a hardware issue but it looks like it could've been a major coincidence, very odd ...

http://ubuntuforums.org/showthread.php?t=1043400

And a bug report was filed here:

https://bugs.launchpad.net/ubuntu/+s...iz/+bug/321224

Do any of you get this when running Compiz also? And can you fix it by using the methods mentioned in the bug report?
chriswyatt is offline   Reply With Quote
Old 01-29-09, 05:44 AM   #11
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

I didn't try compiz, but it is likely to also happen there. I think terminating glxgears is a much better test case as I'm sure it is much simpler and you can easily find the point at which things go wrong.

Yes, changing the scaling method works, as it seems to cause a reset of some kind as does switching to tty or changing the resolution with xrandr.

Also happens with 180.27.

Has someone else tried an external monitor? For me the external monitor turns black for a second (looks like changing resolution or the scaling method) every time I kill glxgears, so there is no shifted image, but this reset of the display should not happen.
Lysius is offline   Reply With Quote
Old 01-30-09, 05:06 AM   #12
joaopa
Registered User
 
Join Date: Apr 2005
Posts: 65
Default Re: screen position offset after terminating glxgears with 180.08 on Geforce Go 7600

Bug appears for me too. I have a nvidia geforce 7600go with the 180.25 driver and the 180.27 driver

The workaround crtl+alt+F1 following by ctrl+alt+F7 works too.

I use Kde 4.1.1
Attached Files
File Type: gz nvidia-bug-report.log.gz (34.6 KB, 67 views)
joaopa is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 06:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.