Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-17-08, 07:21 PM   #49
patstew
Registered User
 
Join Date: Dec 2008
Posts: 2
Default Re: 180.* graphical corruption and freezes system

I was having problems with crashing, though not so much the corruption that you're describing, and I fixed it by removing all of the hacks I'd added to xorg.conf/nvidia-settings etc getting kde4 to work with the older drivers (Even though they improved the old ones they made the new one unstable for me). As far as I know the new betas come with the best settings by default anyway.
patstew is offline   Reply With Quote
Old 12-17-08, 10:21 PM   #50
psychok9
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: 180.* graphical corruption and freezes system

During a Wow OpenGL + Wine session I got 1 great, and total 3d corruption.
After that, I've closed wow, and restarted... and all was ok
Ubuntu 8.10 x86_64, Zotac 8800 GT AMP, nVidia driver 180.16.
psychok9 is offline   Reply With Quote
Old 12-18-08, 03:40 AM   #51
rockman1981
Registered User
 
Join Date: Dec 2008
Posts: 34
Default Re: 180.* graphical corruption and freezes system

Quote:
Originally Posted by rockman1981 View Post
I have this issue too..
Trying setting GlyphCache at zero
nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=0 &

Seems more stable (and even faster!)
Will keep an eye on it
I spoke too soon..
No changes at all.. after some minutes, system freeze and random pixels on screen...
rockman1981 is offline   Reply With Quote
Old 12-18-08, 11:54 AM   #52
xin44
Registered User
 
Join Date: Dec 2006
Posts: 72
Default Re: 180.* graphical corruption and freezes system

it's very strange, i'm feeling we are speaking alone ... no nvidia's reaction - this extremly annoying bug is describe for a while, and nothing ...
xin44 is offline   Reply With Quote
Old 12-18-08, 12:55 PM   #53
kernelOfTruth
Gentoo Linux addict
 
Join Date: Nov 2007
Location: Vienna, Austria; Germany; hello world :)
Posts: 202
Default Re: 180.* graphical corruption and freezes system

Quote:
Originally Posted by bendley View Post
This is so annoying, i am stuck with the 177.82 driver because of this problem.
I would rather use the new 180drivers because besides this problem they work great for me, but i cant live with those random freezes.
you are definitely NOT alone

http://www.nvnews.net/vbulletin/show...7&postcount=25

so the best solution would be to send over your boxen to nvidia headquarter (just kidding)

try to remember the steps you made individualising your installation (esp. those with ubuntu) post as much hardware specs as possible (perhaps the mainboard interferes with graphics card ?); your xorg.conf etc.

if nvidia can't reproduce / see if with their own eyes how are they supposed to develop "fixed" drivers out of the blue ?
__________________
2.6.30-rc3-zen0+ w. compcache, reiser4 + ccreg40 (lzo-compression + checksumming)
gcc version 4.4.0-pre9999 built 20090425 (prerelease) rev. 146764 (Gentoo SVN)
gcc version 4.4.0 (Gentoo Hardened 4.4.0-r1, espf-0.2.1)
Ubuntu Jaunty/9.04 x86_64 Dell XPS M1330
kernelOfTruth is offline   Reply With Quote
Old 12-18-08, 03:29 PM   #54
Dessimus
Registered User
 
Join Date: Apr 2003
Location: Va, USA
Posts: 1
Send a message via AIM to Dessimus Send a message via Yahoo to Dessimus
Default Re: 180.* graphical corruption and freezes system

I confirm having this problem with the screen going briefly to black, then corrupting and crashing the machine and then not response via keyboard or ssh.

I can't purposely reproduce it, but it usually happens when I'm running WoW in Wine. It is much more common if I start streaming a tv show or movie via hulu while playing WoW (on dual screens).

This only started for me after switching to KDE4 though and it generally happens once or twice a day. I used to reboot this box just to upgrade kernels occasionally but now all the time becuase of this.

2.6.27-gentoo (previous kernels too), nvidia 177.82 (previous drivers too)
AMD 64 X2 5200+ (32-bit kernel)
GeForce 8600 GT
Dessimus is offline   Reply With Quote
Old 12-20-08, 06:02 AM   #55
DeepThought
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: 180.* graphical corruption and freezes system

I'm having the same problem (8600M GT) with all the 180.x-drivers (yet I haven't tested 180.11.02). I have found no way to reproduce the bug, but I have found some things that all crashes seems to have in common:
  • It have never happened when I just left my computer alone for a while.
  • I believe that every time it has happened, it has been related to some kind of major change in the screen. Like:
    • One I did a "cat somefile | grep something" with lots of output.
    • Once it was a python script that suddenly gave lots of output.
    • Once it was when I started a fullscreen game, that changed the gamma of the screen.
  • It's always a total freeze, no response to anything I can think of (SysRq, Ctrl-Alt-Backspace, a light touch on the "on/off"-button etc.)
  • The distortion of the screen is always horizontal shifts.

This is what it looks like (sorry for the crappy picture):
http://pici.se/pictures/gfTVeNgtw.jpg

Original picture:
http://pici.se/pictures/MauikhWFh.png

Based on my poor knowledge about it, I think the logs seems to be empty too (it seems like the computer freezes before it writes to the logs?). But I would be happy if someone told me which logs that are interesting, and I'll be more than happy to attach them next time it happens!

And if I find any failsafe reproduction procedure, I'll post it asap, because this really is a big issue!
DeepThought is offline   Reply With Quote
Old 12-20-08, 03:05 PM   #56
psychok9
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: 180.* graphical corruption and freezes system

Quote:
Originally Posted by psychok9 View Post
During a Wow OpenGL + Wine session I got 1 great, and total 3d corruption.
After that, I've closed wow, and restarted... and all was ok
Ubuntu 8.10 x86_64, Zotac 8800 GT AMP, nVidia driver 180.16.
Today I've collected many total 3d corruption during OpenGL WOW + Wine session... I hope nVidia can fix it soon.
psychok9 is offline   Reply With Quote

Old 12-20-08, 04:10 PM   #57
adamorjames
Registered User
 
adamorjames's Avatar
 
Join Date: Oct 2008
Posts: 39
Default Re: 180.* graphical corruption and freezes system

Picture by me from a different thread:
adamorjames is offline   Reply With Quote
Old 12-21-08, 02:42 PM   #58
fakbill
Registered User
 
Join Date: Nov 2008
Posts: 13
Default Re: 180.* graphical corruption and freezes system

Well I see this bug on my 8600M GT + 180.16.
It *looks like* it is related to a kde4 theme on top of gtk applications.

I have removed the new standard kde theme of vlc and I haven't seen this bug after this modification.
I do not think it is so easy and I pretty sure I'm going to see the bug one again soon However, its looks like it helps.

I can test whatever is needed to kill this bug (if someone has a clue...)

Btw, the kde4 openoffice theme is fully broken on my ubuntu box (corrupted icons display). It may be related.

Of course, the is nothing in the logs AFAICS
fakbill is offline   Reply With Quote
Old 12-22-08, 04:12 AM   #59
rockman1981
Registered User
 
Join Date: Dec 2008
Posts: 34
Default Re: 180.* graphical corruption and freezes system

Quote:
Originally Posted by fakbill View Post
Well I see this bug on my 8600M GT + 180.16.
It *looks like* it is related to a kde4 theme on top of gtk applications.
I don't think so..
i tried starting my session with no gtk applications at all.. same result, screen corruption after some minutes, and total freeze
rockman1981 is offline   Reply With Quote
Old 12-22-08, 04:48 AM   #60
xin44
Registered User
 
Join Date: Dec 2006
Posts: 72
Default Re: 180.* graphical corruption and freezes system

"Default Re: 180.* graphical corruption and freezes system
The problem is that I can't seem to reproduce the issue, no matter what I do. Is there anything in particular that would help trigger the corruption/freeze? When the problem happens, does NVRM output Xid messages in the kernel log? It would help if you could login from a remote system while the problem is happening and watch the kernel log; please post any findings here. Only one user's nvidia-bug-report.log exhibited Xid messages and I'm not sure they're directly related. Thanks for your help."

AND

"(it seems like the computer freezes before it writes to the logs?)"

...is it the end of the road...???
xin44 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.